Go Back   Cockos Confederated Forums > Projects > REAPER > Open Bug

ReaStream on OS X will not receive Issue Tools
issueid=2134 03-04-2010 04:43 PM
Human being with feelings
ReaStream on OS X will not receive
ReaStream on OS X can send, but not receive

Reaper 3.35 OS X (Snow Leopard)

To reproduce and confirm, 3 machines are needed. One OS X (Snow Leopard) and two Windows machines.

-> On the first Windows box, create two tracks
-> Insert ReaStream on track 1, set it to send midi (0 audio channels), label it "midi", enter the IP of the second Windows box.
-> Insert ReaStream on track 2, set it to receive, label it "audio"
-> On the second Windows box, create one track
-> Insert ReaStream, set it to receive, label it "midi"
-> Insert a midi instrument plugin
-> Insert another ReaStream, set it to send audio to the IP of the first Windows box, label it "audio"
-> On the first Windows box, arm track one for midi input and play a midi keyboard, or use an already populated midi item in the track.

Result: Audio created by the instrument plugin on the second Windows box is received on the second track on the first Windows box.

-> Now do exactly the above except replace "first Windows box" with "OS X" box
-> Change the IP listed in the second track on the second Windows box with the IP of the OS X box

Result: NO audio is received on the OS X box

I believe this does not affect Reaper on Tiger, but it does on Leopard and Snow Leopard.
Issue Details
Issue Type Open Bug
Project REAPER
Category OSX particulars
Status Unconfirmed
Priority 5 - Medium
Affected Version 3.35
Fixed Version (none)
Users able to reproduce bug 4
Users unable to reproduce bug 2
Assigned Users (none)
Tags (none)

03-05-2010 06:58 AM
Human being with feelings
 
Can the one who voted No confirm that they can successfully
receive data on (Snow) Leopard with ReaStream?

Also it needs to be said that it works properly on Tiger (PPC).
Reply
03-05-2010 07:35 AM
Human being with feelings
 
Yes, I forgot to include that my OS X machine is running Snow Leopard. I've edited the report to include that info.
Reply
03-05-2010 12:33 PM
Human being with feelings
 
It's actually much simpler than that.

ComputerA: 1 track w/ ReaStream, Receive "default", armed, monitoring, accept MIDI input.

ComputerB: 1 Track with ReaStream, Sending to IP of ComputerA "default", armed, monitoring, optionally with something like ReaSynth before ReaStream (so you can hear instead of just watching).

ComputerA works if it's a Windows machine, but not if it's a Mac.


Update: I tested with ComputerA = G4 PPC Mac running Leopard and an older version of Reaper (3.12) and it actually works, receiving from both platforms. I can download and test the new PPC version later.

Update 2: Working also on PPC version 3.35 on Leopard.
Reply
03-05-2010 12:50 PM
Human being with feelings
 
So maybe it's just the Intel build, since Tiger and Leopard on PPC have reports of it working.
Reply
03-05-2010 11:57 PM
Human being with feelings
 
Confirmed MAC-PC-MAC part of the test using a Win XP install in Parallels. Substituting Plasq's Wormhole for Reastream worked fine by comparison (terrible roundtrip latency though). Mac OS was 10.5.4.

Bill.
Reply
03-06-2010 09:22 AM
Human being with feelings
 
Reply
03-06-2010 09:54 AM
Human being with feelings
 
Sorry! I accidently press No, but Yes, i have this bug too
Here is mine thread http://forum.cockos.com/showthread.php?p=465728
Reply
07-18-2010 05:05 PM
Administrator
 
I can't duplicate this (on 10.6), however please check:

1) Make sure that the FX for tracks with ReaStream are running. The easiest way to do this is to record arm those tracks. If FX are on a track, and the track has no media items, and no receives, REAPER will generally not run FX for that track.

2) Make sure that when applicable, REAPER is allowed through your computer's firewall. For example, Windows Firewall will often prevent ReaStream from listening on UDP if not allowed.
Reply
07-19-2010 02:39 AM
Human being with feelings
 
Will do another test today with 2 PCs and one mac (10.5.8.), however I have tried doing this on several occasions @ work with 4 macs, 2 being PPC tiger and two OSX 10.5.8 and 10.6, it seemed 10.5.+ would not receive no matter what.
Reply
07-19-2010 04:41 AM
Human being with feelings
 
"To reproduce and confirm, 3 machines are needed. One OS X (Snow Leopard) and two Windows machines."

I can do some testing on 2 machines as well -- one is a quad-boot including both a Win XP SP3 and a hackint0sh OS X 10.5.4 boot partition; the other is a Mac (Intel, runs both OS X 10.5.8 and 10.6.4 -- of course one could also test with multi-boot Mac running Bootcamp & Windows...).

Last time I checked this I didn't get it working, and I'd really love to see it work correctly.

@Cockos: may I also suggest making OSX AU & VST versions of the ReaStream plugin (and the other ReaPlugs), pretty please with pink sugar on top?
Reply
This petition for a change to Confirmed was accepted
07-19-2010 06:13 AM
Human being with feelings
 
Setup:
OSX 10.6.1 used to send ReaStream
OSX 10.5.8 used to receive ReaStream
Reaper version on both Macs: 3.651 (32bit)

Results:
Here is my video http://www.vimeo.com/13453101.
As result ReaStream not receive audio, but CocoaPacketAnalyser network sniffer software shows that needed data comes into operation system.

Waiting for the fix. Thanks!
07-19-2010 06:48 AM
Human being with feelings
 
Did another test. 2 Windows machines, both receive and send
with ReaStream to each other no problem. Both can receive
audio stream from 3rd OSX (10.5.8) machine, the OSX cannot
receive from any of windows machines.

I really have no other idea what network / firewall settings to check.

e
Reply
This petition for a change to Confirmed was accepted
07-21-2010 11:51 AM
Human being with feelings
 
I can duplicate this on OS X 10.6(.4, MBP 5,1 Intel Core 2 Duo @2,4GHz, 2 GB RAM) as receiving system (with hackint0sh OS X 10.5.4 Intel P640 Prescott @3.2GHz, 2GB RAM as sending system). Everything seems to be just fine, networking-wise. No incoming data flow in ReaStream though. :(
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 04:44 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.