Go Back   Cockos Confederated Forums > Projects > REAPER > Open Bug

Midi Clock Out not Syncing Issue Tools
issueid=2738 07-17-2010 06:28 AM
Human being with feelings
Midi Clock Out not Syncing
midi clock dose not keep time with external synced gear

Specifically, when looping a section of the arrangement, the timing sent to my MPC is not only off time but on every loop it goes off time by different amounts,





Taken from no-fi's FR

reaper's way of doing things (midi transport stop message followed by an SPP message then a midi transport continue message) does not match any other daw I know of, and it causes massive problems with a bunch of looping sequencers and drum machines and even midi-dinsync converters of mine and friends that I have tried with it.
Issue Details
Issue Type Open Bug
Project REAPER
Category MIDI recording and playback
Status Confirmed
Priority 1 - Highest
Affected Version 3.65
Fixed Version (none)
Users able to reproduce bug 32
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

07-17-2010 06:32 AM
Human being with feelings
 
also note if the loop starts at the very beginning of the project then it will be off time the same amount on every loop


Discuss here http://forum.cockos.com/showthread.p...720#post546720
Reply
08-26-2010 08:56 PM
Human being with feelings
 
The only way Reaper will synch with an external device via MIDI is when playback starts at the beginning of the file. If the project is started after the beginning, the synch is incorrect.
Reply
08-27-2010 07:16 AM
Human being with feelings
 


as you can see the first take is on time with the grid, but from it loops it shifts & stays at that shifted position for all takes there after, & drops the first note of the loop

if i do not use count in recording or i use punch in record during playback then all midi is recorded to the "shifted position" shown in the capture above
Reply
09-05-2010 03:09 PM
Human being with feelings
 
Same desync problem when reaper is sending the clock to my Alesis SR18.
Reply
10-14-2010 03:00 PM
Human being with feelings
 
the only way reaper's midi clock out syncs with my hardware correctly is if:

1) i start recording from the very beginning of my project

2) the metronome MUST be turned on

3) "count-in" before recording MUST be enabled


if i do not follow all three of these steps, things are guaranteed to not sync correctly and be off by a noticeable amount.

(i've wasted so much time trying to deal with this....please fix this bug)
Reply
10-14-2010 05:44 PM
Human being with feelings
 
Quote:
Originally Posted by slops
the only way reaper's midi clock out syncs with my hardware correctly is if:

1) i start recording from the very beginning of my project

2) the metronome MUST be turned on

3) "count-in" before recording MUST be enabled


if i do not follow all three of these steps, things are guaranteed to not sync correctly and be off by a noticeable amount.
i can confirm this behavior,

[Why is this bug still listed as Unconfirmed?]
Reply
10-14-2010 07:20 PM
Human being with feelings
 
been like this since first versions of reaper, i never could get a loop correct with midi clock sync out to my fantom, and several other boards, but never had an issue in cubase when looping in this situation. +1 to fix this for sure
Reply
10-15-2010 02:18 AM
Human being with feelings
 
same here. loop get out of sync after some time.
Reply
12-02-2010 12:12 AM
Human being with feelings
 
Still not fixed in the early 4th version... Why nothing is done about this MAJOR issue ?
Reply
12-17-2010 03:16 PM
Human being with feelings
 
Up. This is definitely a major bug. It drives me crazy. :^(
Reply
12-17-2010 04:36 PM
Human being with feelings
 
Quote:
Originally Posted by Daniel Diersant
Still not fixed in the early 4th version... Why nothing is done about this MAJOR issue ?
this is a major issue for those of us that actually sync reaper with hardware and expect it to work properly. if you don't actually sync hardware with reaper then this bug is completely off your radar and not an issue. since there does not seem to be a huge amount of people screaming bloody murder at this issue i don't think anything is going to be done about this bug anytime soon sadly.

honestly, i would take functioning midi sync over any of the new features coming to reaper, but i doubt this will ever be fixed.

pretty depressing.
Reply
12-18-2010 05:35 AM
Human being with feelings
 
only 10 users have confirmed this bug! so i guess it only effects a small number of us!?
Reply
12-18-2010 01:14 PM
Human being with feelings
 
Quote:
Originally Posted by Subz
only 10 users have confirmed this bug! so i guess it only effects a small number of us!?

i dont think the majority of reaper users are syncing external hardware to dump tracks, so the number of users confirming this bugs is less than normal.

the small number confirming this bug still does not mean this isn't a showstopper issue for some of us though.

i have even seen people mention reaper's syncing issues on the mpc forums and they either completely give up or actually track in their tracks unsynced and then sync all the tracks by hand. that is a horrible workaround to this issue.
Reply
01-13-2011 12:44 AM
Human being with feelings
 
Unfortunately confirmed and very annoying. I'm testing the Reaper as new potential DAW, and I will not buy it till the problem will be resolved.

Here is the problem:
Reaper is the master: Preferences - Midi devices - output - Delta AP - Midi + Clock (low latency)

MPC 1000 is the slave - mode -pad9 - f2 - Sync In Slave - MIDI clock - MMC ON.
Generaly it's working only first time when I press Play in Reaper FROM BEGINNING, then something wrong is going on. On second "play" MPC is delayed, even when not playing, only changing position of cursor in Reaper, when I press: 5.1.00 (fifth measure, beat one) MPC shows: 4.4.72 (always 0.0.24 less, 1/4= 96 ticks on MPC midi), so I can not use it as a slave now. Maybe just shift the master out clock 0.0.24 ticks ahead would be enough to go?

It's not working neither if "snap (to grid) enabled" option it turned on (then you see always A.4.72 on MPC when full measure in Reaper is starting in position (A+1).1.0) nor when "snap to grid" is turned off (the A.B.48 or A.B.72 is on MPC when full beat is reached in Reaper). I see that when I change position of the cursor on the ruler when not playing. MPC shows position then.

System: Windows 7 64 bit, newest Reaper x64, MPC 1000 with JJ.OS 1 (v. 4.99), Delta Audiophile 2496 sound card with newest 64bit drivers for MIDI connection.

Major BUG. It seems that Reaper cannot be the master at all. Another DAW system (Cubase LE) is working fine.


screenshot:
-UPPER TRACK (green) - WAV recorded from MPC set as a master (working fine)
-LOWER TRACK (red) - the same WAV recorded, Reaper is the master (delayed 1/16 note always, bad sync). See:
Reply
01-31-2011 12:02 PM
Human being with feelings
 
Quote:
Originally Posted by sunkingzx
been like this since first versions of reaper, i never could get a loop correct with midi clock sync out to my fantom, and several other boards, but never had an issue in cubase when looping in this situation. +1 to fix this for sure
+1 !
The same here when I run my different externe Synths in Arpeggiator mode. The midi clock isn't in time and sometimes the Midi Notes are hanging when playing the recorded track. Affected are several Synths as DSI Mopho, Virus KC, Andromeda A6, Nova desktop or Waldorf Blofeld.

It cannot be the argument that there are only a small number of users who synced external Hardware. Also still today, there are enough Studios and other people who are using external Hardware with her DAW and when Reaper will be a professionell Sequencer like Logic, Cubase, Pro Tools and so on, this major bug has to be fixed ! Midi clock Sync to external Outboard is still a 'must have' for every modern Sequencer.

Cheers
Noisebeat
Reply
03-01-2011 02:44 AM
Human being with feelings
 
I'm having a similar issue with syncing with an Adrenalin 3. Unfortunately if I cannot find a solution, I will have to look at alternatives to Reaper as Beat Synced effects is something I'm very keen to explore in a live situation.

The issue is with maintaining the tempo. Reaper can start the sync based effects fine, and initially reaper is in perfect sync with the A3, however after about 30 seconds they get out of sync.

I've tried using a MTC time code generator and it seems to partially work only. IE it just delays how long it takes for Reaper and the A3 to get out of sync.

I hate to ask but can someone suggest an alternative to use in a Live situation. Ie a solution where I render my music in Reaper, insert the wav into another application and then sync with the A3 and do midi change events via the alternative apllication when playing live?
Reply
03-01-2011 06:45 AM
Human being with feelings
 
I can't get a MTC at all, thru the IACBuss (Mac OSX), and the incoming MMC allow only the start and stop feature, but not the locate of a specific time.
What I need to do is the same you can see here:
With Logic: http://www.youtube.com/watch?v=0F2Z7SBuKwI
With ProTools: http://www.youtube.com/watch?v=YEDcto7ou3c
Reply
05-15-2011 06:04 AM
Human being with feelings
 
Although I posted about this issue in another thread, i'll add my concerns here also as this is a major issue for me. Using Reaper as the master clock and syncing to an external machinedrum to record it audio. The audio comes in late as described in previous posts here, therefore making the use of Reaper with external sequencers useless at this time. Wish I found this thread before I dropped $40 on Reaper yesterday as it looks like I have to pay for another DAW instead :(
Reply
05-15-2011 10:10 AM
Human being with feelings
 
"Status Unconfirmed" :?:
Reply
05-15-2011 10:51 AM
Human being with feelings
 
ferox the quickest method currently around the midi clock out sync issues in reaper is to tab transient to the first trans of the audio recorded from the hardware.
Reply
05-15-2011 11:11 AM
Human being with feelings
 
You lost me there, "tab transient"? I've only had this program 2 days :)
Reply
05-15-2011 11:21 AM
Human being with feelings
 
Quote:
Originally Posted by Ferox
The audio comes in late as described in previous posts here, therefore making the use of Reaper with external sequencers useless at this time. Wish I found this thread before I dropped $40 on Reaper yesterday as it looks like I have to pay for another DAW instead :(
this is the easiest solution i've found for syncing:

Quote:
Originally Posted by slops
the only way reaper's midi clock out syncs with my hardware correctly is if:

1) i start recording from the very beginning of my project

2) the metronome MUST be turned on

3) "count-in" before recording MUST be enabled
i then move what i have recorded to whatever bar i need it to be at.


and yes, it is dumb to have to do this but its the only solution i have found that works.

honestly there are 7 million other things the reaper devs are trying to do so i'm not gonna complain, but at the same time its a shame that this issue has fallen through the cracks for so long and it is not being addressed at all. guess we just have to shrug and move on.
Reply
05-15-2011 12:09 PM
Human being with feelings
 
click on an audio clip and hit tab on your keyboard, u will see the edit cursor jump to the nearest point of the wave it detects, can do a quick split delete from that point.
Reply
05-15-2011 12:13 PM
Human being with feelings
 
Slops' method works if your recording from the very start but the same problem occurs for me if you start your recording at bar 5 say, so you cant drop in audio recordings.
Reply
05-25-2011 04:19 AM
Human being with feelings
 
Hi! for now, in the V4 Beta, the midi implementation is worst:

- No Midi sync like in the V3.

- When Reaper simulates MIDI Trhu (like monitoring playing a desktop synth with a midi or usb-midi keyboard), there are a lot of delay (in the v3 this not happens)
Reply
05-25-2011 06:51 AM
Human being with feelings
 
I'd like to add to this... I LOVE Reaper and I'd LOVE to move my studio over to it full time but this is the PRIMARY reason I am still using Sonar. The Reaper MIDI clock issues make it IMPOSSIBLE for me to switch and it is such a silly issue to be having at all. Very frustrating. I have a ton of external hardware and it's just a total stop for me with these issues. It's SONAR until it's fixed which is a real bummer.
Reply
05-25-2011 02:38 PM
Human being with feelings
 
I can't actually get my akai mfc to recognise reaper's clock at all
Reply
08-11-2011 03:58 AM
Human being with feelings
 
Isnt this Song position were talking about ? (not being able to start at some other point except the beginning )

http://home.roadrunner.com/~jgglatt/...dispec/seq.htm


Otherwise let me know when you fix this issue. I almost bought it yesterday but lucky thou i found this thread which is a dealbreaker for me since I use Elektron OT
Reply
10-27-2011 12:59 AM
Human being with feelings
 
Next test:

Reaper 4.10 with
AKAI XR-20 drum machine.

The same problem, Reaper as a MASTER CLOCK, AKAI - SLAVE, confirmed. Akai starts delayed after Reaper, as MPC in test above.

Project tempo 64. Xr20 stays 0.074 second after the metronome beat (record from beginning)

In this case clock out of Reaper (Midi devices -> Midi out -> Enabled+clock) is still useless.

I did simple test: connected MIDI OUT with clock to MIDI IN (both on my sound card M-Audio Fast Track Ultra 8R), and used midi logger JS to see what happends on clock MIDI out. It seems, that position of SPP sended by clock is by one tick wrong to the beat_position JS variable. Should be 4* beat position (4spp length = 1 beat), and is (4xbeat_position)-1.

Clock time seems to be shifted one SPP and should be very easy to fix it. I did simple JS clock +SPP which can help somebody, I have very tight clock (1ms) with my XR 20 (you can use PDC correction in Propeties of MIDI OUT (I have -3ms) to have this accurate clock), see:
http://forum.cockos.com/showpost.php...7&postcount=11
Reply
03-02-2012 08:42 PM
Human being with feelings
 
This is extremely frustrating! sync problems with my mpc1000 as well. Otherwise love this program, but I am doing massive amounts of work on the mpc these days. Slows work down to a standstill sometimes
Reply
03-03-2012 05:35 AM
Human being with feelings
 
the post above yours provides a solution that works.
try that, it makes syncing useable in reaper.
Reply
03-04-2012 11:40 AM
Human being with feelings
 
This looks fantastic! But as a new-b, I don't know what to do with the text file shown in the link. I tried to copy it into a text file, changed extension to .dll and imported into my plugin folders. It doesnt show up...so what do you do with these scripts? Thanks!
Reply
03-04-2012 03:18 PM
Human being with feelings
 
Ahh...I see it now! I found out how to load it, but I needed to drop my reaper project tempo to 1/2 time to get the mpc to play back at the regular time. Other wise it plays double time. Is this right? I'm starting to wonder if I have some setting on my mpc or some other setting in reaper. I've also noticed that my mpc patterns are playing back at different velocity settings then what I recorded them at too. Maybe need to go to mpc forums next. Anyone have any experience with this?

I have lots to learn about Reaper- but if any other rookies are looking for info on how to use JS plugs, I found it here: http://forum.cockos.com/showthread.php?t=68667
Reply
03-04-2012 10:45 PM
Human being with feelings
 
Yes, I'm surprised Reaper cannot sync up with my Korg Electribe ES-1. Please address this issue.
Reply
03-04-2012 10:59 PM
Human being with feelings
 
i love how this is still unconfirmed TWO YEARS later.
Reply
03-05-2012 06:06 AM
-blšnk-
 
Yes, too bad I can't really test it, lacking some hardware to send the clock to. I'd love to confirm to give Cockos more drive to get this fixed finally. This stuff really needs to work.
Reply
03-05-2012 06:40 AM
Human being with feelings
 
Quote:
Originally Posted by chameleoned
I needed to drop my reaper project tempo to 1/2 time to get the mpc to play back at the regular time.
you need to disable send clock from the Reaper midi out

currently your sending 2 colocks (The Plugin & the Reaper one)

Subz
Reply
03-06-2012 03:56 PM
Human being with feelings
 
Thanks Subz!! That fixed the problem, it also seems to have fixed the problem with "note on" durations with midi sync in the MPC. Yee-Ha!
Reply
03-07-2012 03:01 AM
Human being with feelings
 
Quote:
Originally Posted by Adam Fulara
screenshot:
-UPPER TRACK (green) - WAV recorded from MPC set as a master (working fine)
-LOWER TRACK (red) - the same WAV recorded, Reaper is the master (delayed 1/16 note always, bad sync). See:
I think i have the same type of problem.
At firt i thought it was my external midi sequencers (Emu SP1200 and MPC60) that responded late. Then i thought it was normal cos Im running at a double tempo (184 BPM) but if it can be more tight why not?

Right now im syncing with SMPTE and i still have about the same amount of latency.
I need to nudge the SMPTE a bit back i guess so it can be on the 5th bar.
But since 184 bpm of my sequencers are not the same as a DAW's bpm, i will most likely be off grid eitherway so it doesnt make much sence to be tight on the grid.
Reply
07-12-2012 04:16 PM
Human being with feelings
 
DJ ALX try my solution of the problem (see post 10-27-2011 09:59 AM above). I use it since I have made it, and I forgot about the problem, anyway it should be fixed long time ago.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 09:19 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.