Go Back   Cockos Confederated Forums > Projects > REAPER > Closed Issue

Looping a Recorded Section Sync Issue Issue Tools
issueid=3881 01-16-2012 01:19 PM
Human being with feelings
Looping a Recorded Section Sync Issue

When recording any audio i then split the audio into the bars i want to keep and glueing them. If i then drap the clip to repeat it looks to be in sync but when you zoom in maximum on each bar it's loop point slowly goes further and further out of sync the more you drag it.




EDIT (gofer):
Discussion thread: http://forum.cockos.com/showthread.php?p=888624
Issue Details
Issue Type Closed Issue
Project REAPER
Category Audio recording and playback
Status Misdirected Post
Priority 5 - Medium
Affected Version 4.15
Closed Version (none)
Yes votes 0
No votes 3
Assigned Users (none)
Tags (none)

01-16-2012 01:53 PM
Fex Fex is online now
Human being with feelings
 
I respectfully suggest that there might have been an error in the original split & glue. I've got a loop snapping precisely to the bar after being dragged to repeat for more than 24 hours.
Reply
01-16-2012 03:18 PM
Human being with feelings
 
OK i have just inserted a wav file and split a section into a 2 bar section. I then delete the rest of the file and glue the section i want to keep. I then drag the right hand side of the clip across to bar 31. I then zoom in using the scroll wheel at bar 29 and the loop is not on the bar. If i extend this out to the gap just keeps getting bigger.
Reply
01-16-2012 07:05 PM
-blšnk-
 
Is Snap Settings -> Snap to sample rate enabled? That could lead to odd item length when splitting even when snap is enabled (depending on BPM, there might be no sample at exact measure/beat positions).

If you have it enabled, I think also enabling Project Settings -> "Force project time signatures to have beats on whole samples" should fix. (Only tempi which have beats on whole samples are possible with that enabled, so you will see tempi of 130.001 and similar)
Reply
01-17-2012 01:00 AM
Human being with feelings
 
I had reaper installed on my wifes machine so i tried it on that. It works as it should. SO it's either my machine or a reaper config issue. I have now uninstalled and then reinstalled and now it doesn't do it. I have tried the settings Gofer suggested but this doesn't make it do it either now. I have now loaded the project that 1st raised this issue and some of the clips still refuse to loop. I have found the offending clip and zoomed in max, then split at the cursor, then when i glue nothing happens the loop point is still just before the bar. Any other ideas?
Reply
01-17-2012 01:05 AM
Human being with feelings
 
Just a bit more info.
Tried inserting a clip as before and split/glue and loop. Now when i look at the loop point the split is ahead of the bar not behind the bar.
Reply
01-17-2012 03:50 AM
Human being with feelings
 
It looks like it's a glue issue. See screen shots of clip before and after Glue.
Reply
01-17-2012 05:49 AM
Fex Fex is online now
Human being with feelings
 
Can you possibly post the project file, with the audio item, or even just the audio item and the target tempo?
Reply
01-17-2012 09:40 AM
Human being with feelings
 
Hi Fex i have uploaded a zip with the offending loop.
Reply
01-17-2012 12:31 PM
Fex Fex is online now
Human being with feelings
 
Thanks.

Confirmed.

The first loop point is 4.4.99, not 5.1.00. However, splitting at 5.1.00, then copying, pasting, gluing and looping causes further odd behavior, with the loop point out of sync, as described.

Snap to project sample rate is not enabled.

If the source wav (resampled from 48.0kHz) is dropped into a new project, rendered to 44.1 kHz, copied, pasted, glued and looped, the copy also falls out of sync, but looping at different points to the original.

This is WEIRD.
Reply
01-17-2012 02:23 PM
Human being with feelings
 
Try stetching the loop and it doesn't snap to the next bar instead kind of has a loop point before it?

Thanks for confirming i'm not going mad.

I can't always replicate it but sometime the loop is ahead as well as behind.
Reply
01-17-2012 07:12 PM
Fex Fex is online now
Human being with feelings
 
Quote:
Originally Posted by GaryMust
I can't always replicate it but sometime the loop is ahead as well as behind.
I can replicate it. Try this:

Start a new project.
Set tempo to 155 BPM.
Create a track.
Set the time selection to cover the first four bars.
Insert an empty item.
Ctrl, click, drag, drop the copy right after the original.
Glue.
Loop.
Swear.
Reply
01-18-2012 12:13 AM
Human being with feelings
 
Yes it's the same here.

What happens now??
Reply
01-20-2012 10:11 AM
Human being with feelings
 
Just a bit more info.

I installed v4.00 and it still does it.
I installed v3.78 and it still does it.
So it looks like it's been around a while.
Reply
01-20-2012 10:46 AM
-blšnk-
 
Still can't reproduce (using Fex' receipt). Please create a thread in the Bug Report forum where more info can be collected without cluttering the issue tracker ticket.

EDIT:
Discussion thread: http://forum.cockos.com/showthread.php?p=888624

thanks, Gary :)
Reply
02-06-2012 11:52 PM
Human being with feelings
 
Hi

I have now uploaded a LIce/GIf clip of what happens.

Thanks

Gary
Reply
02-07-2012 12:17 AM
Human being with feelings
 
Not a bug. You need the "loop section of source" function to create proper looping audio!

Quote:
Originally Posted by Dstruct View Post
Example:

-> audio file with duration of 1 beat
-> now you could just drag it out but it won't stay in sync with the beat grid
-> rightclick the item and also enable "Loop section of item source" (make sure to resize the item to exactly 1 beat before)
-> drag out the item

=> now it will loop properly in sync with the beat grid forever ...

(in the Item Properties window you also can adjust the X-fade lenght in case you'll get some clicks at the loop boundaries)
Reply
02-07-2012 10:58 AM
Human being with feelings
 
First off thanks for solving the puzzle.
Secondly why is this not the default action of splitting/glueing ??

Is this the same for MIDI clips as well?

Surely nobody want their audio/midi going out of sync?

Sorry but i can't see the point in having to go into each clip select another thing to make it loop properly.
Reply
02-08-2012 07:00 AM
Human being with feelings
 
Quote:
Originally Posted by GaryMust
Is this the same for MIDI clips as well?
No.
Reply
02-08-2012 07:15 AM
Human being with feelings
 
Reaper is now doing weird things again.
I have inserted a loop and stretched it to the end of the bar, glued it and dragged it out. Without the "Loop section of item source" selected it is now staying in sync.

Getting extremely frustrated with how reaper is dealing with clips. One minute it works next is doesn't.

I now do not trust Reaper to work with my audio. I'm a big fan and renewed my license at version 4.

:(:(:( Very Sad day today.
Reply
02-08-2012 07:30 AM
Human being with feelings
 
Quote:
Originally Posted by GaryMust
Without the "Loop section of item source" selected it is now staying in sync.
Maybe because you have "Force project time signatures to have beats on whole samples" enabled (Project Settings) and "Snap to project sample rate" enabled (Grid/snap settings). This can be used as workaround too (instead of the "Loop section of item source" function).
Reply
02-08-2012 08:35 AM
Human being with feelings
 
Ok so i have the following.

"Force project time signatures to have beats on whole samples" - Unticked.
"Snap to project sample rate" - Unticked

Still doing it. Clip loop point is behind the beat.
Reply
02-08-2012 08:48 AM
Human being with feelings
 
Quote:
Originally Posted by GaryMust
Ok so i have the following.

"Force project time signatures to have beats on whole samples" - Unticked.
"Snap to project sample rate" - Unticked

Still doing it. Clip loop point is behind the beat.
Then you need to do this (Example):

-> audio file with duration of 1 beat
-> now you could just drag it out but it won't stay in sync with the beat grid
-> rightclick the item and also enable "Loop section of item source" (make sure to resize the item to exactly 1 beat before)
-> drag out the item

=> now it will loop properly in sync with the beat grid forever ...

(in the Item Properties window you also can adjust the X-fade lenght in case you'll get some clicks at the loop boundaries)
Reply
02-08-2012 09:10 AM
Human being with feelings
 
Your method works but don't you think it's a bit awkward to go into each clip and ensure each has the correct setting?

99.9% i would guess would want their clips to stay locked to the beat as a default by cutting and glueing at the relevant beat.

Why doesn't it stay in time if you cut each clip by 1 bar and then loop it?

1 bar is 1 bar isn't it??

Thanks for answering and helping me out.
Reply
02-08-2012 09:32 AM
Human being with feelings
 
If you don't want to do this all the time, you need to enable the "Force project time signatures to have beats on whole samples" (Project Settings) and "Snap to project sample rate" (Grid/snap settings) options.

You're working with whole samples this way all the time and the beat grid is snapped to samples too. Should work. Maybe you need to set (tick the checkbox) the project sample rate in the project settings for this to work!
Reply
02-08-2012 09:36 AM
Human being with feelings
 
Quote:
Originally Posted by GaryMust
Why doesn't it stay in time if you cut each clip by 1 bar and then loop it?

1 bar is 1 bar isn't it??

Thanks for answering and helping me out.
By default an item can have a lenght of x samples + x subsamples. "Glue" brings this to a file with a lenght of whole samples. So the item can become slightly larger (1 sample - x subsamples) after that.

If you tick "Snap to project sample rate" (Grid/snap settings) then this won't happen (because all stuff is snapped to whole samples).
Reply
02-08-2012 09:57 AM
Human being with feelings
 
A smile is now starting to appear.

This seems to be working as i would expect it to.

I wonder how these settings got turned off or are they not like that to start with?

Once again thanks for your help.
Reply
02-08-2012 10:10 AM
Human being with feelings
 
"Save as default project settings" button in the Project Settings should save project settings and grid/snap settings ...
Reply
02-12-2012 03:07 AM
Human being with feelings
 
Now i've got the loops staying in sync i now can't set the tempo correctly. If i enter 114 i get 113.998. I presume this is to do with forcing the Sample rate?

Just when i think i'm getting somewhere!

Hmmmm.
Reply
02-12-2012 03:29 AM
Human being with feelings
 
Yes, that's related to forcing the grid to snap to sample rate, as gofer said in his first reply to this report. It's to be expected when you base everything on sample rate. The difference between 140 and 139.998 is really not that big for human ear to sense it, so why worry?
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 11:17 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.