Go Back   Cockos Confederated Forums > Projects > REAPER > Closed Issue

Random 'loop' points added to rendered regions Issue Tools
issueid=3929 02-03-2012 02:58 AM
Human being with feelings
Random 'loop' points added to rendered regions

System: Windows 7 64bit, Reaper 4.151, latest SWS plugin installed.

Situation:

I have a project file set up with many wave files on one track. No FX. One region surrounds each wave file, the region is named exactly the same as the source wave file. So for instance a file called TESTSOUND.wav will have a region around it called TESTSOUND

I add markers, which will be written to the output files as cues. All markers have the same name: A_B

Some files have one marker, some have up to four markers.

I render using the following settings:

Render: Master mix
Project Regions
Filename: $region
'Write markers as cues' is ticked, all other check boxes are unticked.

Problem:

On rendering, some of the files have loops added which I did not specify. None of the output files should loop. The offending files when dragged into Sound Forge are reported as having 'illegal loop points' which are then 'fixed' by Sound Forge. If I drag the same files into Reaper there is a dotted line at the very start of the item with the name of the region it was rendered from at the very top, as if it was a cue (but running 'import media cues from items as project markers' does not convert this line into a marker)

Strangely, this does not happen with all rendered waves. In the session I have just tested this with it rendered these 'loops' in two of six output files. Running the same test with the same waves on a clean session the output files had loops in the same two files. The input files are identical and have no weird metadata. There seems to be no correlation between markers and these loops - if I add NO markers to the project and render the clean waves (I should get out what I put in) I still get these loop points added to some waves. Making sure that 'loop source' is unticked makes no difference.

Basically this is driving me mad and is stopping me working on a *very* important project.

We have ~10 commercial licenses in our studio for Reaper, so please consider us all supporters of this bug :)
Issue Details
Issue Type Closed Issue
Project REAPER
Category Editing behavior
Status Fixed
Priority 1 - Highest
Affected Version 4.15
Closed Version 4.22
Yes votes 1
No votes 0
Assigned Users (none)
Tags (none)

02-07-2012 03:36 AM
Human being with feelings
 
Attached 'rendertests.zip' containing test audio files and a session - all of which consistently reproduce this 'random loop points on render' issue.

Steps to reproduce:

1. Open the Reaper session 'tests to render_regioned.RPP'. If it can't find the source files, they can be found in the folder '1 original files'

2. The session contains 20 MP3 files, each surrounded by a region named 'TEST_01' to 'TEST_20'. Each region also has a marker within called 'R_P'. I used MP3 as waves made the zip too large to upload. The result is the same however.

3. Render the files as waves using the settings seen in 'Render Settings.png'.

4. Drag the resulting files into a new empty Reaper session. Some of the rendered wave files have some metadata which is interpreted as loop points by Sound Forge and other audio apps. This can be seen as the inclusion of the filename/region-name at the start of the rendered wave file as displayed in this new Reaper session. The affected files are: TEST_02, TEST_03, TEST_04, TEST_05, TEST_06, TEST_09, TEST_19

Notes:

The source files were created in Reaper. Recorded with a PC mic, cut up with the dynamic split, regions added to name the rendered files TEST_01 to TEST_20, then rendered into the '1 original files' folder.

The source files do not contain this metadata - it appears only in the resulting files after the render step.

The affected files are always the same, however I cannot see a pattern as to why certain files get this metadata and others do not.
Reply
02-07-2012 07:49 AM
Human being with feelings
 
Confirmed, Win7 32bit, REAPER 4.151, exactly as you described. The files you mention end up with loop points at the start/end and an additional unwanted marker at the start, for no reason that I can discern. Here's a screen cap of the first two files open in Wavosaur.

Reply
02-08-2012 03:13 AM
Human being with feelings
 
As an update to this, if you prefix the markers with # and render with 'Only write markers starting with #' selected in the render options, the resulting files are ok and do not include the extra unwanted markers and loop points. However, this means all my markers end up incorrectly named.

Please could the rendering be fixed so the loop points and extra markers are not included, or please could you add an option to only write markers starting with # but do not write the # to the marker when written. Thanks!
Reply
03-02-2012 09:00 AM
Administrator
 
Fixing, thanks for the report. By default, "write markers as cues" will also write project regions as loop cues. We'll add a separate option for this, so you can choose to embed just markers, just regions, or both.
Reply
03-05-2012 10:42 AM
Human being with feelings
 
Thanks Schwa, that's great news :)
Reply
04-11-2012 03:33 AM
Human being with feelings
 
The fix is perfect, thanks Schwa!
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 09:21 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.