Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Media Explorer <Project Directory> shortcut doesn't work if project folder name contains certain characters AND "Use Windows Explorer for browsing" is enabled Issue Tools
issueid=5062 01-24-2014 05:21 AM
Human being with feelings
Media Explorer <Project Directory> shortcut doesn't work if project folder name contains certain characters AND "Use Windows Explorer for browsing" is enabled

*** Note to mods: could you please rename this issue "Media Explorer shortcuts (including <Project Directory>) won't work if folder name contains certain characters AND "Use Windows Explorer for browsing" is enabled"? I got the scope a little unhelpfully narrow first time around. (And I don't believe I can rename any issues.) Thanks! ***

In the Media Explorer, with "Use Windows Explorer for browsing" enabled, clicking shortcuts (including <Project Directory>) to directories whose names contain certain characters, e.g. "international" ones like "", won't work. (It simply won't change what directory is loaded in the adjacent panel.)

Most important question up front: is this actually a REAPER issue? I imagine that because it only occurs when "Use Windows Explorer for browsing" is enabled, it might not be.

Steps to reproduce (demonstrating the <Project Directory> shortcut):

- Create a new folder with the character "" in it ('AltGr + e' should work, or 'Alt + 0233', etc.)
- Create a new REAPER project and save it in that folder.
- Open the Media Explorer, and make sure that "Use Windows Explorer for browsing" is checked (enabled).
- Click the <Project Directory> shortcut.

Expected: it takes us to the appropriate folder ("......\media", in my case).
Result: does nothing.

Note:
- Using Windows 7 Pro.
- All various Windows region/language settings set to "English (United Kingdom)".

Most relevant and recent discussion thread:
http://forum.cockos.com/showthread.php?t=120026

Some related issues in the tracker:
http://forum.cockos.com/project.php?issueid=396
http://forum.cockos.com/project.php?issueid=568
http://forum.cockos.com/project.php?issueid=876
http://forum.cockos.com/project.php?issueid=3972

Thanks.

PS, just a side note: should there perhaps be a whole issue tracker category for "internationalisation" stuff?
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Arcana
Status Fixed
Priority 4
Affected Version 4.591
Closed Version 5.0
Yes votes 1
No votes 0
Assigned Users (none)
Tags (none)

01-24-2014 10:35 AM
Issue Changed by Ollie
  • Status changed from Unconfirmed to Confirmed
05-21-2015 08:45 AM
Issue Changed by Jeffos
  • Status changed from Confirmed to Fix Coming Soon
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.