View Single Post
Old 05-03-2013, 02:21 AM   #1283
witti
Human being with feelings
 
witti's Avatar
 
Join Date: May 2012
Posts: 1,186
Default

Quote:
Originally Posted by Jeffos View Post
.. and no BR from witti. phewww that's ok witti?
Had a talk with SWS where i told him what i found out.

On a fresh install, both reaper and sws, all windows (we are talking about) open in the upper left corner, right ?
This is the initial position and size.

Take the Resources window for example.

Case 1:

Open the window.
It opens in the upper left corner, quite narrow in height.
Resize it. (Not reposition it !!)
Close it.
Save a screenset.
Close Reaper, re-open it and load that screenset.
Resource window size has not been saved.

Case 2:

Open the window.
It opens in the upper left corner, quite narrow in height.
Resize it AND reposition it (say to the middle of the screen) !!
Close it.
Save a screenset.
Close Reaper, re-open it and load that screenset.
Resource window size and position HAS BEEN SAVED !



It seems this bug has something to do with the (initial ?) position of the window.
Case2 is working, but when i move the window in this working screenset back to the upper left corner and save that screenset again, next time when i open reaper and load that screenset, the resources window has this bug behavior.

Case1 has still this docker bug.
You can dock the resources window, save a screenset, close Reaper, re-open it, and what you see is that the resource window is not in the docker anymore. Even after loading the screenset.


With some kind of workaround i got the snapshot window working:
Open the snapshot window.
Resize it and position it in the middle of the screen.
Close the window and save a screenset.
Close Reaper and reopen it.
Load that screenset.
Open the snapshot window and position it at the upper left corner (initial position).
Close the window and save that screenset again.

Voilą, the snapshot window remembers it's size.
(Strange enough, you can't do this with the resources window. As soon as you move the window at (or near?) the initial position (upper left corner) the window behaves buggy.)

Reaper 4.402
sws 2.3.0.17
all 32 bit on WinXP.

Sorry for the trouble, but experimenting with all the possibilities caused me some trouble, too.

If i wouldn't be Buddha this bug would bother me a lot !

Is there someone who can confirm all this ?
(Not that Buddha needs a confirmation, but in this case i make an exception.)

Last edited by witti; 05-03-2013 at 02:41 AM.
witti is offline   Reply With Quote