View Single Post
Old 06-11-2015, 08:37 AM  
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 6,720
Default Track manager - stop horizontal auto-scroll (fixed in R5.02)

I have the track manager docked to the right side of the arrange for quickly filtering and jumping to tracks. 'Track name' is first column.

Please watch the track managers horizontal scroll bar at the bottom.
As soon as I type something in the filter, the scrollbar moves to the right and I can't see the track names anymore, have to scroll back to left, which makes my use case a little annoying.



Why is it doing this, any way to stop it ?
I thought it's maybe because I have 'Indent track in folders' turned on, turning it off makes no difference though. Otherwise I couldn't spot a track manager's option which seems to be relevant, is there ?

edit:
Ah - seems it always scrolls the 'color' column into view for whatever reason (pretty clear actually from the gif ).
So putting that as the first column and fully narrowing it (because I don't need to see it, that's why I rearranged name as first column to begin with) does the trick.

edit2:
I can see the reasoning when color column is the leftmost as it is per default, but better logic (in the case of rearranging columns, which is possible via drag and drop) would be 'scroll to leftmost column' instead of 'always scroll to color column' I think.

Last edited by nofish; 09-22-2015 at 11:01 AM.
nofish is offline   Reply With Quote