Old 05-01-2012, 01:56 PM   #1
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default Crossfades behavior - Does someone like this?

I've always hated this behavior:




Why would REAPER create a crossfade where I don't want it? I'd even consider this a bug but maybe there's a good explanation for this.
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 05-01-2012, 02:52 PM   #2
artifus
Human being with feelings
 
Join Date: Jul 2010
Posts: 113
Default

it is to prevent an audible click.
artifus is offline   Reply With Quote
Old 05-01-2012, 03:06 PM   #3
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default

Quote:
Originally Posted by artifus View Post
it is to prevent an audible click.
I've explicitly left the item right edge like that (overlapping the next item) but I needed to crossfade it with the previous item.

By the way, that item has a fade out, so no "audioble click" will happen.
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 05-01-2012, 03:42 PM   #4
pbk
Human being with feelings
 
pbk's Avatar
 
Join Date: Jul 2009
Location: Sonic Aisle Botch, FL
Posts: 604
Default

Quote:
Originally Posted by Mercado_Negro View Post
I've explicitly left the item right edge like that (overlapping the next item) but I needed to crossfade it with the previous item.

By the way, that item has a fade out, so no "audioble click" will happen.
Methinks too that we need more fading/zero-x/overlap options. It would be nice to have a right click menu when two or more items are selected and the submenus as the options (eg use crossfading, snap to zero crossing with first item prevailing, snap to zero crossing with second item prevailing, etc).
__________________
It takes an ordered complex system to recognize another ordered complex system.
pbk is offline   Reply With Quote
Old 05-02-2012, 12:44 AM   #5
planetnine
Human being with feelings
 
planetnine's Avatar
 
Join Date: Oct 2007
Location: Lincoln, UK
Posts: 4,727
Default

Never noticed that MN , have you got auto crossfade on?

>
__________________
Nathan, Lincoln, UK.

dB marks on MCP faders FR: http://forum.cockos.com/project.php?issueid=3059
planetnine is offline   Reply With Quote
Old 05-02-2012, 01:39 AM   #6
mako55a
Human being with feelings
 
Join Date: Jan 2011
Location: Polska, Komorów
Posts: 238
Default

Quote:
Originally Posted by planetnine View Post
Never noticed that MN , have you got auto crossfade on?

>
I can not confirm. Think it is bug.
mako55a is offline   Reply With Quote
Old 05-02-2012, 01:44 AM   #7
timlloyd
Human being with feelings
 
Join Date: Mar 2010
Posts: 4,651
Default

I couldn't repro either (on osx), but will try again tonight. Does look like a bug.
timlloyd is offline   Reply With Quote
Old 05-02-2012, 03:16 AM   #8
IXix
Human being with feelings
 
Join Date: Jan 2007
Location: mcr:uk
Posts: 2,473
Default

Quote:
Originally Posted by Mercado_Negro View Post
I'd even consider this a bug but maybe there's a good explanation for this.
I think it's a bug/nitpick/oversight. If autoxfade is on, it should only create xfades for items that don't already overlap. Probably an easy fix.
IXix is offline   Reply With Quote
Old 05-02-2012, 05:48 AM   #9
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default

Quote:
Originally Posted by planetnine View Post
Never noticed that MN , have you got auto crossfade on?

>
Yeah, I enable it in my video before doing it.

Thanks for confirming guys but maybe I didn't explain myself properly. Please watch this new .gif:



All 3 items are overlpapping each other. I always work with auto x-fades off and I enable it only when I need it. Why does REAPER have to create that crossfade on the right if I'm just grabbing and moving the left?
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 05-02-2012, 06:12 AM   #10
AdamWathan
Human being with feelings
 
AdamWathan's Avatar
 
Join Date: Apr 2008
Location: Cambridge, Ontario
Posts: 2,635
Default

Agreed, that is annoying behavior!
AdamWathan is offline   Reply With Quote
Old 05-02-2012, 07:09 AM   #11
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 9,569
Default

MN... I just ran a 'confirm or not' test here... win XP 32 bit reaper, using the latest pre release

It does NOT do that for me... no crossfades show when auto crossfade is turned off..

it makes me wonder if there is something amiss with the toolbar [icon] link to toggle that on and off
PS... I see I am using the Xenios action to toggle crossfades and off...
__________________
You don't have to agree with me, but it will go a lot easier on you if you do http://tinyurl.com/cr7o7yl

Last edited by hopi; 05-02-2012 at 07:18 AM.
hopi is offline   Reply With Quote
Old 05-02-2012, 08:45 AM   #12
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default

Quote:
Originally Posted by hopi View Post
MN... I just ran a 'confirm or not' test here... win XP 32 bit reaper, using the latest pre release

It does NOT do that for me... no crossfades show when auto crossfade is turned off..

it makes me wonder if there is something amiss with the toolbar [icon] link to toggle that on and off
PS... I see I am using the Xenios action to toggle crossfades and off...
That's OK, it doesn't create any crossfades when auto x-fades are on, the problem happens when you enable it and grab-n-move one edge, REAPER creates a crossfade on the other edge.
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 05-02-2012, 10:50 AM   #13
timlloyd
Human being with feelings
 
Join Date: Mar 2010
Posts: 4,651
Default

^ Confirmed on OSX. Yeah, if I worked this way, it would be quite annoying. I've virtually always got "trim behind edits" on, so it doesn't happen.
timlloyd is offline   Reply With Quote
Old 05-02-2012, 12:39 PM   #14
philait
Human being with feelings
 
Join Date: Mar 2010
Location: Newcastle - UK
Posts: 566
Default

Wink Wink New Pre
philait is offline   Reply With Quote
Old 05-02-2012, 01:10 PM   #15
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default

Quote:
Originally Posted by philait View Post
Wink Wink New Pre
Whoa!!!!!!! Thanks!
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 05-02-2012, 01:25 PM   #16
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 9,569
Default

Quote:
Originally Posted by Mercado_Negro View Post
That's OK, it doesn't create any crossfades when auto x-fades are on, the problem happens when you enable it and grab-n-move one edge, REAPER creates a crossfade on the other edge.
OK... so a little further then...

would you want it to put a crossfade on the edge being moved?.. or no crossfade at all, ...or exactly how should it behave?
__________________
You don't have to agree with me, but it will go a lot easier on you if you do http://tinyurl.com/cr7o7yl
hopi is offline   Reply With Quote
Old 05-02-2012, 08:51 PM   #17
AdamWathan
Human being with feelings
 
AdamWathan's Avatar
 
Join Date: Apr 2008
Location: Cambridge, Ontario
Posts: 2,635
Default

Crossfade on the edge being moved, not the edge that isn't being touched.

I do this sometimes too, turn off autoxfades and trim behind so I can have something spill over into something else, but you want a crossfade at the beginning. Reaper makes (made? ) it very very hard...
AdamWathan is offline   Reply With Quote
Old 05-02-2012, 09:10 PM   #18
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default

Quote:
Originally Posted by AdamWathan View Post
Crossfade on the edge being moved, not the edge that isn't being touched.

I do this sometimes too, turn off autoxfades and trim behind so I can have something spill over into something else, but you want a crossfade at the beginning. Reaper makes (made? ) it very very hard...
Yeah, it is a nightmare... I mean, it was
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Old 05-03-2012, 10:42 AM   #19
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 9,569
Default

Quote:
Originally Posted by AdamWathan View Post
Crossfade on the edge being moved, not the edge that isn't being touched.

I do this sometimes too, turn off autoxfades and trim behind so I can have something spill over into something else, but you want a crossfade at the beginning. Reaper makes (made? ) it very very hard...
so Adam and MN... are you saying that if you turn off auto fades AND choose trim behind also, that you get what you want? or is there a way to autoXfade only the item being moved left edge?
__________________
You don't have to agree with me, but it will go a lot easier on you if you do http://tinyurl.com/cr7o7yl
hopi is offline   Reply With Quote
Old 05-03-2012, 10:57 AM   #20
AdamWathan
Human being with feelings
 
AdamWathan's Avatar
 
Join Date: Apr 2008
Location: Cambridge, Ontario
Posts: 2,635
Default

No this bug was fixed in the latest prerelease, that's what we're saying
AdamWathan is offline   Reply With Quote
Old 05-03-2012, 11:29 AM   #21
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Somewhere between one and two
Posts: 7,329
Default

That was quick - was about to say I had experienced the same thing and assumed it was me having inadvertently reset some arcane setting...
Maybe I am NOT such an old fool after all.

P.S. Thanks for the fix to the devs!

Now wondering how many other weirdnesses that I experience are actually bugs and not Ivan being clumsy/thick/old/etc.....
ivansc is offline   Reply With Quote
Old 05-03-2012, 11:41 AM   #22
Mercado_Negro
Human being with feelings
 
Mercado_Negro's Avatar
 
Join Date: Aug 2007
Location: Caracas, Venezuela
Posts: 7,221
Default

Quote:
Originally Posted by ivansc View Post
Now wondering how many other weirdnesses that I experience are actually bugs and not Ivan being clumsy/thick/old/etc.....
You know, I always experience weird behaviors in REAPER and since it always happen in the middle of something I tend to forget it or just leave it alone. I guess we should do this more often, maybe we'll find a bug or something (and hopefully it will be easy to fix).
__________________
Pressure is what turns coal into diamonds - Michael a.k.a. Runaway
Mercado_Negro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.