COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 12-07-2014, 08:24 AM   #1
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default NINJAM LAN SERVER

I installed Ninjam server on PC 1 and client on PC 2; both are on LAN.
I can login on server, I have audio signal on client but I can't route the audio signal on server.
If I search my server on Ninjam server list I cannot see it.
What's the problem?

Last edited by Mark Jones; 12-07-2014 at 08:32 AM.
Mark Jones is offline   Reply With Quote
Old 12-07-2014, 12:30 PM   #2
the all new rob
Human being with feelings
 
the all new rob's Avatar
 
Join Date: Dec 2007
Location: east coast of Kansas
Posts: 681
Default

It's functioning as intended.

You don't need to have the server in the list to connect, just enter the IP address and port.

The list is showing you publicly accessible servers that the owners have taken the trouble to register. Think of it as a convenience feature.
__________________
"Well feeling (emotion) combined with an artist's discipline is the rarest thing in the world."
-- Ursula Nordstrom
the all new rob is offline   Reply With Quote
Old 12-08-2014, 01:48 AM   #3
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Quote:
Originally Posted by the all new rob View Post
It's functioning as intended.

You don't need to have the server in the list to connect, just enter the IP address and port.

The list is showing you publicly accessible servers that the owners have taken the trouble to register. Think of it as a convenience feature.
Thanks for the reply, but the problem is that I cannot route the audio signal from client to server.
I'm missing something...
No help from the online guide.
Mark Jones is offline   Reply With Quote
Old 12-09-2014, 12:23 AM   #4
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

You're not making it clear what the problem is.

Check this post - making absolutely sure you can only hear sound from NINJAM.

1) Can you hear yourself? If not, you have a problem with your audio connection into NINJAM client, not from NINJAM client to server.

2) Can you hear click when connected to the server? If not, you have a problem with your audio connection out of the NINJAM client, not from server to client.

3) If that's working fine, try a public server. Check you have "transmit" enabled ("xmit") and politely ask on an occupied channel if others can hear you. If so, you know your set up is good. If not, you'll need to figure out what's wrong -- but it's still not a problem with your local server but with your client connection in general.

Can you confirm all of that's working? If not, please be very specific about how you tested - general statements do not really explain to people what they can say that will help you, so you're not helping yourself or helping others to help you.

The best thing is always to list a set of steps you took, saying what you expect to happen and what actually happens. That way people can most likely see where you're going wrong.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 12-10-2014, 04:35 AM   #5
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Quote:
Originally Posted by pljones View Post
You're not making it clear what the problem is.

Check this post - making absolutely sure you can only hear sound from NINJAM.

1) Can you hear yourself? If not, you have a problem with your audio connection into NINJAM client, not from NINJAM client to server.
YES

Quote:
Originally Posted by pljones View Post
2) Can you hear click when connected to the server? If not, you have a problem with your audio connection out of the NINJAM client, not from server to client.
YES

Quote:
Originally Posted by pljones View Post
3) If that's working fine, try a public server. Check you have "transmit" enabled ("xmit") and politely ask on an occupied channel if others can hear you. If so, you know your set up is good. If not, you'll need to figure out what's wrong -- but it's still not a problem with your local server but with your client connection in general.
YES, I CAN CONNECT TO PUBLIC SERVER AND USERS CAN HEAR ME.

I think I have some config problem on my LAN Server.
Please, what are the correct steps?
Mark Jones is offline   Reply With Quote
Old 12-10-2014, 11:54 AM   #6
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

Quote:
Originally Posted by Mark Jones View Post
YES
You can you can hear youself. You say you can successfully connect to your private server and hear click. You say you can successfully connect to a public server and others can hear you.

I am not clear on what you are saying is not working.

Are there other users on your private server you cannot hear?

Are they unable to hear you?
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 12-11-2014, 04:01 AM   #7
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Quote:
Originally Posted by pljones View Post
You can you can hear youself. You say you can successfully connect to your private server and hear click. You say you can successfully connect to a public server and others can hear you.

I am not clear on what you are saying is not working.

Are there other users on your private server you cannot hear?

Are they unable to hear you?
If I join public servers I can hear myself and other users.
If I join my lan server, I can't Xmit any signal.
Client and Server are connected (I can login).
I have no signal, no remote channel in Ninjam on the server.

How do you setup Ninjam on Server???
Mark Jones is offline   Reply With Quote
Old 12-11-2014, 10:19 AM   #8
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

Quote:
If I join my lan server, I can't Xmit any signal.
Can you explain that in some detail. What steps do you take and what happens? Compare with when you join a public server and say at what point things become different.
Quote:
I have no signal, no remote channel in Ninjam on the server.
I really do not know what you mean here. When you log into a public server you do not have a "remote channel in Ninjam", so why do you expect to have one on your private server? Remote channels shown in the client are other users logged into the public server. On your private server you would only see remote channels if there were other users logged in to your private server.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 12-11-2014, 02:05 PM   #9
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Quote:
Originally Posted by pljones View Post
On your private server you would only see remote channels if there were other users logged in to your private server.
Exactly... If I join my private server I expect to see client track on remote panel.

Did you ever use NINJAM to play from different rooms in your house?
If you did, tell me how...
Mark Jones is offline   Reply With Quote
Old 12-11-2014, 02:43 PM   #10
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

SOLVED. The server must be connected to the server in NINJAM panel (same as client).
I thought it was enough to start ninjamserver in command prompt to interact with.
Mark Jones is offline   Reply With Quote
Old 12-11-2014, 03:39 PM   #11
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

Ah, I think I understand.

You were trying to get two separate computers to connect to your private server.

One of the computers was running the server software and you didn't know that you needed to use the client software to connect to the server software on the same computer.

Is that it?
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 12-12-2014, 06:07 AM   #12
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Quote:
Originally Posted by pljones View Post
Ah, I think I understand.

You were trying to get two separate computers to connect to your private server.

One of the computers was running the server software and you didn't know that you needed to use the client software to connect to the server software on the same computer.

Is that it?
Ninjam Server is started in Command prompt but Reaper doesn't know.
It is necessary to connect server to server itself in Ninjam plugin inside Reaper.
Mark Jones is offline   Reply With Quote
Old 12-12-2014, 10:12 AM   #13
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

You say again
Quote:
It is necessary to connect server to server itself
but you are only talking about two clients and one server elsewhere, so it's still a bit confusing. Anyway, it's working for you.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 12-12-2014, 02:47 PM   #14
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Quote:
Originally Posted by pljones View Post
You say again

but you are only talking about two clients and one server elsewhere, so it's still a bit confusing. Anyway, it's working for you.
Example Setup with 2 PC.

Server (PC 1) = 192.168.1.2
Client (PC 2) = 192.168.1.x
user: ninja
password: pass

Start Server on PC 1:




On both pc goto Reaper, load Ninjam plugin and connect to 192.168.1.2:






Recorded files are in NINJAMsessions folder.

Last edited by Mark Jones; 12-14-2014 at 02:33 AM.
Mark Jones is offline   Reply With Quote
Old 12-12-2014, 04:03 PM   #15
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

So you are connecting two clients to your private server.

The NINJAM server is running on one computer.

You are also running the NINJAM client on that computer and connecting to the NINJAM server.

A second computer is also running the NINJAM client and connecting to the NINJAM server.

OK.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 12-14-2014, 02:35 AM   #16
Mark Jones
Human being with feelings
 
Join Date: Sep 2014
Posts: 84
Default

Is there a way to change BPI and lower latency?
"!vote BPI <value>" does't work...
"Voting not enabled" says the Ninjam...
Mark Jones is offline   Reply With Quote
Old 12-14-2014, 11:01 AM   #17
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 573
Default

The server commands are defined in User_Group:nChatMessage in the source.

"[voting system] Voting not enabled" is displayed if "!vote" is issued and m_voting_threshold > 100 || m_voting_threshold < 1.

m_voting_threshold defaults to 110, I think...

And that's likely changed by uncommenting this line in the config file:
# SetVotingThreshold 50 # sets threshold to 50%. can be 1-100%, or >100 to disable

(It would have been nice if the comment said "disabled by default" to make it clear.)
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:42 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.