Old 06-18-2017, 08:28 AM   #1
reaperDJ_MPLS
Human being with feelings
 
reaperDJ_MPLS's Avatar
 
Join Date: Mar 2017
Location: Minneapolis
Posts: 5
Default Python Problems

I have Python 3.6.0, 3.5.0, 3.4.1, 2.7.1 and REAPER 5.0. When I try to enable Python in REAPER for ReaScripting, REAPER can`t find Python. I have tried this with all my Pythons, but I get the same results every time.
Any help would be greatly appreciated.
reaperDJ_MPLS is offline   Reply With Quote
Old 06-18-2017, 01:36 PM   #2
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Germany
Posts: 2,853
Default

I have no experience with that myself, but a friend of mine happily does usesr Python (plus "Beyond", that needs a newer Python version) in Reaper (Windows). So it does work.

Maybe a 32 Bit / 64 Bit problem ?

-Michael
__________________
www.boa-sorte.de
mschnell is offline   Reply With Quote
Old 06-18-2017, 02:36 PM   #3
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 1,277
Default

Quote:
Originally Posted by reaperDJ_MPLS View Post
I have Python 3.6.0, 3.5.0, 3.4.1, 2.7.1 and REAPER 5.0. When I try to enable Python in REAPER for ReaScripting, REAPER can`t find Python.
Just to clarify:

- Which operating system are you using?
- Which Reaper 5.x version are you using exactly (and if 32- or 64-bit)?

- And what are your current 'Custom Path to Python directory' and 'Force Reascript to use specific Python .dll' settings under Preferences > Plug-ins > Reascript?

Last edited by solger; 06-18-2017 at 02:44 PM.
solger is offline   Reply With Quote
Old 06-19-2017, 12:16 PM   #4
reaperDJ_MPLS
Human being with feelings
 
reaperDJ_MPLS's Avatar
 
Join Date: Mar 2017
Location: Minneapolis
Posts: 5
Default

I`m using Windows Vista 64x (I think) and REAPER v 5.01. I have the "Custom Path to Python directory" set to C:\Users\...\AppData\Local\Programs\Python\Python 36 - 32\dlls and I haven`t tried the "Force Reascript to use specific Python .dll' settings under Preferences > Plug-ins > Reascript?" option.
Thanks!
reaperDJ_MPLS is offline   Reply With Quote
Old 06-19-2017, 12:44 PM   #5
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 6,878
Default

Long time that I set it up but this works for me:



I'm not sure anymore but I think without the "Force..." entry it didn't work for me either.
nofish is offline   Reply With Quote
Old 06-19-2017, 12:51 PM   #6
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 1,277
Default

Quote:
Originally Posted by reaperDJ_MPLS View Post
I`m using Windows Vista 64x (I think) and REAPER v 5.01. I have the "Custom Path to Python directory" set to C:\Users\...\AppData\Local\Programs\Python\Python 36 - 32\dlls and I haven`t tried the "Force Reascript to use specific Python .dll' settings under Preferences > Plug-ins > Reascript?" option.
Thanks!
As you can see in nofish's screenshot above, try to insert the file name (without adding the .dll extension) of the Python .dll in the 'Force ... specific Python .dll' field.
Especially if you have multiple Python versions installed on your system ...
solger is offline   Reply With Quote
Old 06-20-2017, 09:37 AM   #7
reaperDJ_MPLS
Human being with feelings
 
reaperDJ_MPLS's Avatar
 
Join Date: Mar 2017
Location: Minneapolis
Posts: 5
Default

Quote:
Originally Posted by nofish View Post
Long time that I set it up but this works for me:



I'm not sure anymore but I think without the "Force..." entry it didn't work for me either.
I`ll try that. Thanks a ton!
reaperDJ_MPLS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.