Old 05-04-2017, 01:49 PM   #1
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default v5.50pre7 - May 4 2017

# Automation items: fix undo after moving automation items with media items [p=1840145]
# Automation items: improve stability of overlapping automation item positioning
# Envelopes: fix initial envelope control panel knob edits and "move envelope points a little bit" actions
# Envelopes: improve behavior of "write current value..." actions and automation items
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-04-2017, 01:50 PM   #2
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default

# Automation items: fix undo after moving automation items with media items [p=1840145]

Was about to report that but guess I got beat to it!

Thanks for adding this option guys. Working well so far and such a massive bonus to have!
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-04-2017, 02:01 PM   #3
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default AI bug when gluing then undoing

Was testing out the copying when for some reason I decided to glue together an Automation item to see if it would work. Upon undoing though all the AIs went into tiny repeated loops within themselves and undoing no longer worked.

See before and after undo images below


Pre Undo (but after glue)
https://stash.reaper.fm/30652/AI_bug_PreUndo.JPG

Post Undo
https://stash.reaper.fm/30653/AI_bug_PostUndo.JPG

EDIT: just saw this "# Automation items: improve stability of overlapping automation item positioning", maybe this fixes it as I'm still on pre 6 sorry. I didn't update before I tested!

EDIT 2 Tested on pre7 and couldn't repeat the issue so maybe it's fixed

.
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.

Last edited by musicbynumbers; 05-04-2017 at 02:14 PM.
musicbynumbers is offline   Reply With Quote
Old 05-04-2017, 02:11 PM   #4
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by musicbynumbers View Post
# Automation items: improve stability of overlapping automation item positioning
Definitely way better when moving.

Still problematic when drawing.



Example 2:

__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-04-2017, 02:22 PM   #5
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by musicbynumbers View Post
# Envelopes: improve behavior of "write current value..." actions and automation items
Hmmm. I'd like to express some sort of "expected behaviour", but I'm not 100% sure how this should work.

But the way it works now seems a bit weird. Note how it behaves when your time selection overlaps the left edge, compared to the right edge:



It would seem to me like adding an envelope point on the edge of the AI, inside the time selection, is necessary.

Not 100% sure, this seems complex.

As mentioned before, actions like "Write current values for active Automation Item", "Write current values for active Automation Item inside time selection", "Write current values from Automation Item start to cursor", "Write current values from Automation Item end to cursor", etc... would make these behaviours more explicit.

Edit: Maybe this has to be done with specific "Automation items connect..." settings.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.

Last edited by Robert Randolph; 05-04-2017 at 02:49 PM.
Robert Randolph is offline   Reply With Quote
Old 05-04-2017, 02:26 PM   #6
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default

Other small bug with AIs.

I think AIs should be able to extend the length of the project so that not only items define the project end but also any AIs that are longer than the last item in the project.

Currently they don't.

Side note: This also is an issue for subprojects whereby the "=END" marker isn't where the project thinks is the end (which it should be) but currently it's seen as the end of the media item only which means faking it with a long empty midi item to get things like reverb tails to end naturally.
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-04-2017, 02:30 PM   #7
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default

2 more AI things

1. Undo changes in an AI item that has a 2nd AI item above or below it can cause the AI item you've just undone to change lanes which can be a bit confusing when it moves.

2. There doesn't seem to be an option to reset/delete all points within an AI item yet. Using the remove we have now deletes all AI items and automation for that track so an option for just resetting inside of that single AI would be great.

Thanks!
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-04-2017, 02:36 PM   #8
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

"Insert 4 envelope points at time selection" affects both the AI and underlying envelope.



Basically same bug as "Write current active..." bugs, just a different action.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-04-2017, 02:55 PM   #9
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

With ripple editing on, and "Move envelope points with media items" on... you can make automation items disappear!



All you do is move something from right to left.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-04-2017, 04:08 PM   #10
ovnis
Human being with feelings
 
Join Date: Oct 2011
Posts: 809
Default

Bug :

When I create AI with drag mouse, near the time signature marker (left side), it create AI on two measure instead one.


When I create AI with drag mouse, near the time signature marker (rigt side), it doesn't create AI.
__________________
My theme : http://forum.cockos.com/showthread.php?t=189977
Propagation of active takes color to all similarly named active takes : http://forum.cockos.com/showthread.php?t=165493
ovnis is offline   Reply With Quote
Old 05-04-2017, 04:14 PM   #11
ovnis
Human being with feelings
 
Join Date: Oct 2011
Posts: 809
Default

Bug :

Issue with time selection inside AI :
Sometimes, points are not created (on the AI edge) and points move...


__________________
My theme : http://forum.cockos.com/showthread.php?t=189977
Propagation of active takes color to all similarly named active takes : http://forum.cockos.com/showthread.php?t=165493
ovnis is offline   Reply With Quote
Old 05-04-2017, 04:57 PM   #12
gwok
Human being with feelings
 
gwok's Avatar
 
Join Date: Jun 2010
Location: Nelson, BC
Posts: 3,260
Default

Hey, I was wondering if anyone is using automation items/pre's for their regular work/worflow. I'd really like to run the pre's for a project I'm working on, though have avoided them up to now.

I know running the pre's comes with the use at your own risk caveat, though I'm wondering how close/stable the community/devs are feeling about the AI's. Are the general foundations of the AI seeming to be in place, and it's mostly bug squashing now, or are there potentially still big changes to come.

I know the devs are hesitant to comment on these types of questions, but if you could give any insight one way or another, it would be greatly appreciated!

Thanks!
__________________
MacPro Xeon, 10.9.5
Reaper 5
gwok is offline   Reply With Quote
Old 05-04-2017, 06:11 PM   #13
gpunk_w
Human being with feelings
 
Join Date: Dec 2010
Posts: 3,123
Default

AIs seem to be missing a few tricks, I have already mentioned not being able to run actions on selected points, but i also intuitively have gone to the media browser a few times to load Automation Items too, would definitely be an extremely fast workflow being able to drag n drop automation items from the media browser.
__________________
Reaper scripters, that is all !!!!!!!!!!!!!!!!
gpunk_w is offline   Reply With Quote
Old 05-04-2017, 08:18 PM   #14
Arthur McArthur
Human being with feelings
 
Join Date: Sep 2016
Location: Toronto
Posts: 222
Default

Quote:
Originally Posted by gpunk_w View Post
would definitely be an extremely fast workflow being able to drag n drop automation items from the media browser.
big +1
Arthur McArthur is offline   Reply With Quote
Old 05-04-2017, 11:55 PM   #15
Gianfini
Human being with feelings
 
Join Date: Jan 2015
Posts: 384
Default

Quote:
Originally Posted by gwok View Post
Hey, I was wondering if anyone is using automation items/pre's for their regular work/worflow. I'd really like to run the pre's for a project I'm working on, though have avoided them up to now.

I know running the pre's comes with the use at your own risk caveat, though I'm wondering how close/stable the community/devs are feeling about the AI's. Are the general foundations of the AI seeming to be in place, and it's mostly bug squashing now, or are there potentially still big changes to come.

I know the devs are hesitant to comment on these types of questions, but if you could give any insight one way or another, it would be greatly appreciated!

Thanks!
I just tested a couple of pre, most AI features are there and pretty stable, but the fixes that devs do each new pre-release do change the AI behavior a lot (e.g. when copying, moving, running actions, ...) so I woudn't recommend to actually run a non-test project through AI now, as the project could behave differently after the next pre-release fixes

Afterall we're only at pre-7

g

g
__________________
FR: Mark visibly the tracks that have been frozen totally or partially
FR: groove management (for audio items) a lá Logic or Studio
Gianfini is online now   Reply With Quote
Old 05-05-2017, 05:26 AM   #16
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,143
Default

Quote:
Originally Posted by ovnis View Post
Sometimes, points are not created (on the AI edge) and points move...
I think this is similar to a bug you reported in a previous thread but I still can't reproduce it. Are there tempo changes in the project? If you can consistently reproduce the bug, would it be possible to trim the project down and post it here or email to support at cockos with instructions for how to reproduce the bug? Thanks.
schwa is offline   Reply With Quote
Old 05-05-2017, 05:27 AM   #17
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,143
Default

Quote:
Originally Posted by gwok View Post
Are the general foundations of the AI seeming to be in place, and it's mostly bug squashing now, or are there potentially still big changes to come.
Things could definitely still change.
schwa is offline   Reply With Quote
Old 05-05-2017, 07:50 AM   #18
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,334
Default

I don't really get the flashing yellow bar in transport.
When it is heavily flashing during play in a project and i check all readouts in Performance window, i can see RT CPU is about 30 procent and CPU is about 20 procent.

With these readouts, why should the yellow flashing appear ?
Cause there seems no cpu overload.

Sidenote: i noticed that some plugins i have on a "sub master" folder track, like plugins from Kush, are causing heavy yellow flashing on my X99 Hackintosh OSX 10.10,
while playing the very same project on my macbook retina 2015 OSX 10.12 doesn't give
any yellow flashing at all.
There is some nifty weird nasty thing going on on my Hack
vanhaze is online now   Reply With Quote
Old 05-05-2017, 07:56 AM   #19
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by vanhaze View Post
I don't really get the flashing yellow bar in transport.
When it is heavily flashing during play in a project and i check all readouts in Performance window, i can see RT CPU is about 30 procent and CPU is about 20 procent.

With these readouts, why should the yellow flashing appear ?
Cause there seems no cpu overload.

Sidenote: i noticed that some plugins i have on a "sub master" folder track, like plugins from Kush, are causing heavy yellow flashing on my X99 Hackintosh OSX 10.10,
while playing the very same project on my macbook retina 2015 OSX 10.12 doesn't give
any yellow flashing at all.
There is some nifty weird nasty thing going on on my Hack
CPU load isn't the only thing that can cause overloads.

Realtime audio is about things being ready in time, and sometimes that doesn't happen because something else on the system takes priority (or time!) for some reason.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-05-2017, 09:33 AM   #20
gwok
Human being with feelings
 
gwok's Avatar
 
Join Date: Jun 2010
Location: Nelson, BC
Posts: 3,260
Default

Quote:
Originally Posted by schwa View Post
Things could definitely still change.
Thanks Schwa and Giafini!
__________________
MacPro Xeon, 10.9.5
Reaper 5

Last edited by gwok; 05-05-2017 at 09:42 AM.
gwok is offline   Reply With Quote
Old 05-05-2017, 11:07 AM   #21
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,982
Default

Quote:
Originally Posted by gwok View Post
Hey, I was wondering if anyone is using automation items/pre's for their regular work/worflow.
for me I'm not seeing the benefit yet. I was hoping that one automation item could be linked to multiple parameters in the project. One automation item per parameter is no different *imo* than 1 parameter in each automation lane. still gets cluttered, still takes up a lot of space, copy and paste of multiple parameters is still multiple steps.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 05-05-2017, 11:13 AM   #22
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by EpicSounds View Post
for me I'm not seeing the benefit yet. I was hoping that one automation item could be linked to multiple parameters in the project. One automation item per parameter is no different *imo* than 1 parameter in each automation lane. still gets cluttered, still takes up a lot of space, copy and paste of multiple parameters is still multiple steps.
One automation item can be linked to multiple parameters of the project.



It shouldn't be difficult to create an action/script that automatically does any automatic copy/pool to whatever selection of parameters.

I think that the main issue here would be that there is no 'automation item group' like item grouping. If that existed, then I think your request would be fairly trivial to implement as a workflow.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-05-2017, 11:20 AM   #23
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,143
Default

I think it's the screen real estate usage that EpicSounds dislikes. Envelope lanes can be hidden, btw.

Some other DAWs have a setup where automation clips or items live in some centralized place, and you can send them to multiple destinations. This is just a different design, though the functionality you can achieve should be equivalent.
schwa is offline   Reply With Quote
Old 05-05-2017, 11:21 AM   #24
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,334
Default

Quote:
Originally Posted by EpicSounds View Post
for me I'm not seeing the benefit yet. I was hoping that one automation item could be linked to multiple parameters in the project. One automation item per parameter is no different *imo* than 1 parameter in each automation lane. still gets cluttered, still takes up a lot of space, copy and paste of multiple parameters is still multiple steps.
Totally agree here with Jon ..
vanhaze is online now   Reply With Quote
Old 05-05-2017, 11:54 AM   #25
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,982
Default

Quote:
Originally Posted by schwa View Post
I think it's the screen real estate usage that EpicSounds dislikes. Envelope lanes can be hidden, btw.

Some other DAWs have a setup where automation clips or items live in some centralized place, and you can send them to multiple destinations. This is just a different design, though the functionality you can achieve should be equivalent.
I don't really know what can or can't be done. I've only seen demos of bugs and in my own brief testing found they didn't do what I thought they would.

I'll play with them a bit more today.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 05-05-2017, 11:58 AM   #26
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by schwa View Post
I think it's the screen real estate usage that EpicSounds dislikes. Envelope lanes can be hidden, btw.

Some other DAWs have a setup where automation clips or items live in some centralized place, and you can send them to multiple destinations. This is just a different design, though the functionality you can achieve should be equivalent.
I see. I inferred something different from the way he phrased it.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-05-2017, 01:21 PM   #27
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,982
Default

insert menu - shouldn't there be an action here?
Envelope: Insert automation item

is it possible to cmd-drag in the automation item lane to create a new one?

probably reported already, this needs some consistency

mouse modifiers> Envelope segment, left drag.
default action = insert envelope point, drag to move

__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 05-05-2017, 01:31 PM   #28
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by EpicSounds View Post
is it possible to cmd-drag in the automation item lane to create a new one?
Yes, if you have nothing else selected the 'copy' command will just create a new AI. This is assigned to option by default.

I have asked for a specific "create new automation item" action here: http://forum.cockos.com/showpost.php...&postcount=209

I think the current action/workflow is pretty crappy.

Quote:
Originally Posted by EpicSounds View Post
probably reported already, this needs some consistency

mouse modifiers> Envelope segment, left drag.
default action = insert envelope point, drag to move

This depends on the Editing Behaviour->Automation->Automation item connect... settings.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-05-2017, 01:36 PM   #29
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,982
Default

Quote:
Originally Posted by schwa View Post
I think it's the screen real estate usage that EpicSounds dislikes. Envelope lanes can be hidden, btw.
so let's say I create the effect I want using 3 automation lanes with automation items and unique automation on each. For me a really common of example of that is a zoom and pan for video.

If I select all three I can move and duplicate etc fairly easily. Certainly easier than without automation items without some complex scripts.

You suggested hiding, I can't hide lanes 2 and 3 and still move the 3 automation items together. I need some way of grouping across lanes that works while hidden.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 05-05-2017, 01:38 PM   #30
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by EpicSounds View Post
so let's say I create the effect I want using 3 automation lanes with automation items and unique automation on each. For me a really common of example of that is a zoom and pan for video.

If I select all three I can move and duplicate etc fairly easily. Certainly easier than without automation items without some complex scripts.

You suggested hiding, I can't hide lanes 2 and 3 and still move the 3 automation items together. I need some way of grouping across lanes that works while hidden.
Having automation item grouping would in fact be extremely cool and useful. Solves a lot of issues in fact.

Edit:

To be more clear why this would be helpful...

I've often wanted to stretch, move contents, edge edit and shift pooled items the same. Currently pooling items only affects the envelope points.

Perhaps even just an option for making pooled AIs work like grouped media items would be sufficient.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.

Last edited by Robert Randolph; 05-05-2017 at 01:45 PM.
Robert Randolph is offline   Reply With Quote
Old 05-05-2017, 01:45 PM   #31
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,982
Default

Quote:
Originally Posted by Robert Randolph View Post
Yes, if you have nothing else selected the 'copy' command will just create a new AI. This is assigned to option by default.

ok. a lot of my mouse modifiers have to change.

Quote:
Originally Posted by Robert Randolph View Post
This depends on the Editing Behaviour->Automation->Automation item connect... settings.
not quite. if that time selection is there it's still behaving differently, adding a point and moving the segment instead of moving just the point.

another thing.
can't figure out how to simply change the length of an automation item without looping or stetching.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 05-05-2017, 01:58 PM   #32
Robert Randolph
Human being with feelings
 
Robert Randolph's Avatar
 
Join Date: Apr 2017
Location: St. Petersburg, FL
Posts: 409
Default

Quote:
Originally Posted by EpicSounds View Post
ok. a lot of my mouse modifiers have to change.


not quite. if that time selection is there it's still behaving differently, adding a point and moving the segment instead of moving just the point.
Hmm... This works the same for me both ways. Time selection changes nothing.



So maybe some setting here somewhere that's affecting this?

Quote:
Originally Posted by EpicSounds View Post
another thing.
can't figure out how to simply change the length of an automation item without looping or stetching.
Only way I've figured to extend/shorten without stretch/loop is to use glue. Either glue to a new blank AI or loop/glue/delete.

I saw someone request the extend-without-stretching, so I assume that's coming.
__________________
http://www.admiralbumblebee.com
Audio/DAW stuff, Woodworking, Programming and more... new posts twice a week or more.
Robert Randolph is offline   Reply With Quote
Old 05-05-2017, 02:21 PM   #33
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,982
Default

AI length is definitely strange. dragging edge or changing the length in properties creates areas that can't be automated.

Thanks for the tip with glue.


Was just about to ask about committing automation items to the track automation?
answer - right-click, delete > Delete automation item, preserve points
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 05-05-2017, 11:51 PM   #34
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,334
Default

When i drag an AI horizontally over another, adjacent AI, both AI's get visually placed on top of eachother.

Now, my intuition would be that when dragging AI A over AI B, the envelope points in the overlapped part from AI B, would be replaced by those of AI A.
Just like what the function "trim content behind media items when editing" does on normal items.

I totally don't understand how the automation in the "overlapped area" is read out.
Am i maybe overseeing a setting concerning this (for me illogical) behaviour ?

Warm Regards.
vanhaze is online now   Reply With Quote
Old 05-06-2017, 01:02 AM   #35
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,334
Default

Can someone on OSX please try to replicate this issue:

- Go in Play
- Open Media browser and set "start on bar" and "tempo match on" and "loop on".
- Select an audio loop.
Outcome:
On the second pass of the previewed audioloop, there is audio tearing at the first part of the audioloop.
vanhaze is online now   Reply With Quote
Old 05-06-2017, 01:32 AM   #36
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default

Quote:
Originally Posted by vanhaze View Post
When i drag an AI horizontally over another, adjacent AI, both AI's get visually placed on top of eachother.

Now, my intuition would be that when dragging AI A over AI B, the envelope points in the overlapped part from AI B, would be replaced by those of AI A.
Just like what the function "trim content behind media items when editing" does on normal items.

I totally don't understand how the automation in the "overlapped area" is read out.
Am i maybe overseeing a setting concerning this (for me illogical) behaviour ?

Warm Regards.
This is super useful though for being able to have a say a repeated filter modulation which you can then slightly modify with a 2nd AI.

Or having micro volume changes on a audio item that repeats and then modify its volume for say the chorus.

And because the AIs can linked, it makes it easy to change all choruses at once for example.

There's other uses too but that's probably the main one for me.

Also, when we get the ability to mute AIs (please Schwa) we can then use the overlapping as a crude multiple take system for automation where we can have multiple takes and choose the best one by muting the others

Although, actual takes for AI would be better
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-06-2017, 01:37 AM   #37
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default

Quote:
Originally Posted by EpicSounds View Post
AI length is definitely strange. dragging edge or changing the length in properties creates areas that can't be automated.

Thanks for the tip with glue.


Was just about to ask about committing automation items to the track automation?
answer - right-click, delete > Delete automation item, preserve points

I think you can change the length if I recall but with a modifier pressed which is just one of a few places where it seems backwards to how normal AIs work. Maybe it needs to copy over are normal item modifiers as much as possible?
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-06-2017, 01:41 AM   #38
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,274
Default

Quote:
Originally Posted by EpicSounds View Post
so let's say I create the effect I want using 3 automation lanes with automation items and unique automation on each. For me a really common of example of that is a zoom and pan for video.

If I select all three I can move and duplicate etc fairly easily. Certainly easier than without automation items without some complex scripts.

You suggested hiding, I can't hide lanes 2 and 3 and still move the 3 automation items together. I need some way of grouping across lanes that works while hidden.
I think you can move them them all over the item which allows them to all move at once (maybe).

Would love to be able to group them to the normal items too so they move with them. Can't yet though.

Also, earlier someone mentioned that you can have a aliased copy of an AI on multiple envelope tracks but another cool thing with them is that if you double click the AI to get into its properties you can also shift and change the intensity of how that one affects that parameter even if it's a duplicate which is very cool!
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 05-06-2017, 03:57 AM   #39
gpunk_w
Human being with feelings
 
Join Date: Dec 2010
Posts: 3,123
Default

Quote:
Originally Posted by schwa View Post
I think it's the screen real estate usage that EpicSounds dislikes. Envelope lanes can be hidden, btw.

Some other DAWs have a setup where automation clips or items live in some centralized place, and you can send them to multiple destinations. This is just a different design, though the functionality you can achieve should be equivalent.
I did warn of the screen real estate issue when this was in its infancy (Not that it is just a real estate issue, but also a workflow issue) the other packages that treat automation items more as traditional items and allow them to be sent anywhere and to multiple locations is THE WAY to do it, a round wheel is a round wheel, Reaper automation items are usable as is, not optimal, the equivalent can be achieved but in a slower way.

These things set Reaper apart in terms of composition, and they are the reason why a lot of Reaper users still look elsewhere to do their compositions.
Reaper is biased heavily towards recording and mixing and in that sense these AIs are good enough.
__________________
Reaper scripters, that is all !!!!!!!!!!!!!!!!
gpunk_w is offline   Reply With Quote
Old 05-06-2017, 03:58 AM   #40
gpunk_w
Human being with feelings
 
Join Date: Dec 2010
Posts: 3,123
Default

How do we turn off this yellow flashing transport thing in OSX, it just flashes constantly, even with just a single audio file playing back.

__________________
Reaper scripters, that is all !!!!!!!!!!!!!!!!
gpunk_w is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:28 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.