Go Back   Cockos Incorporated Forums > REAPER Forums > MIDI and other music/audio protocols

Reply
 
Thread Tools Display Modes
Old 06-04-2017, 12:32 PM   #1
slagni
Human being with feelings
 
Join Date: Sep 2015
Posts: 20
Unhappy Midi volume CC#7 pins to 12db when clicking in Editor (SOLVED)

Greetings,

HELP? I have just installed the Chris Hein Viola Library. When I access Kontakt through Reaper the volume in the top right of Kontakt is initially at 0 immediately after loading a clean version of the library. In the wrench/Instrument options the "Midi Controller #7 (Volume) range is set at 0 db as well. If I bring up the Reaper midi editor and click anywhere in the viola midi channel that accesses this library the volume immediately pins at 12 db and stays there. I've tried setting volume at 80 in CC#7 (which is notably unreliable) and that works if I just play through...but anytime I click to edit its back at 12 db. I've tried checking and unchecking the "Accept standard controllers for Volume & Pan in wrench/Instrument options and that does not help. Anytime I access the Kontakt via Reaper after the initial loading of the library the volume in the top right of Kontakt is always pegged at 12 db. Support for the library says: "If the volume fader jumps to its maximum, this must be a CC7 sending from Reaper" I've cleaned the volume CC#7 channel to know affect. Any suggestions? All my other libraries work great (and I have many). Any thoughts are appreciated?
slagni is offline   Reply With Quote
Old 06-04-2017, 02:07 PM   #2
slagni
Human being with feelings
 
Join Date: Sep 2015
Posts: 20
Default More info

I bring up an empty Reaper template with Kontakt. Add the clean, stock CC version of the Solo Viola library to Kontakt. Bring up the empty midi channel associated with the library. Click and everything's fine (cause there's nothing there). Add a note. Click the note. It pins to 12 db. Frustrating.
slagni is offline   Reply With Quote
Old 06-05-2017, 11:50 PM   #3
slagni
Human being with feelings
 
Join Date: Sep 2015
Posts: 20
Default Solution found...no idea why

I found that if I click the "reverse polarity" icon on the Send output of the midi channel in Reaper going to Kontakt on the input midi channel for the Solo Viola patch it solves the problem. I have no idea why.
slagni is offline   Reply With Quote
Old 06-05-2017, 11:54 PM   #4
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 18,567
Default

You need to disable resetting CC7. Check out options for Reset MIDI CC/Pitch on playback start, stop and loop/skip in Preferences->Audio->Playback.

You will want to put cc7=-1 in "CC reset overrides" there, and disable resetting MIDI CC/Pitch on playback start and loop/skip. Do the same for CC10, as well.
EvilDragon is online now   Reply With Quote
Old 06-06-2017, 06:48 AM   #5
slagni
Human being with feelings
 
Join Date: Sep 2015
Posts: 20
Smile Thank You

Evil Dragon...that works great. Thanks so much. I was totally unaware of that option. Also, its great to hear that you are doing well.
slagni is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:02 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.