Old 06-09-2017, 12:37 PM   #1
alexoden
Human being with feelings
 
Join Date: Feb 2014
Posts: 2
Default Please help turn script off

I'm editing midi drums and enabled a reascript mouse modifier to drag left for fine adjustment of note velocity. I decided I didn't want to use this modifier and I cannot click on any midi notes now. Whenever I put the mouse over the note I just see an up and down arrow for adjusting velocity.

I went into the reascript modifier and the state said "on". I tried to turn this off and can't figure out how to do it. I'd appreciate any help. Even if I have to reinstall SWS. Uggg, this couldn't have happened at a worse time!
alexoden is offline   Reply With Quote
Old 06-09-2017, 01:16 PM   #2
X-Raym
Human being with feelings
 
X-Raym's Avatar
 
Join Date: Apr 2013
Location: France
Posts: 3,958
Default

Try this action in the Action List:

ReaScript: Close all running ReaScripts



(but usual, you just have to re-run the script, if you set it to have only one instance at the same time the first time you run it).
X-Raym is offline   Reply With Quote
Old 06-09-2017, 02:31 PM   #3
alexoden
Human being with feelings
 
Join Date: Feb 2014
Posts: 2
Default

Quote:
Originally Posted by X-Raym View Post
Try this action in the Action List:

ReaScript: Close all running ReaScripts



(but usual, you just have to re-run the script, if you set it to have only one instance at the same time the first time you run it).
Thanks for your reply!

Just tried this and it didn't work unfortunately. I uninstalled SWS as well and still nothing. The only thing I can think of is that I accidentally changed the default left click setting.

I went into the midi piano roll mouse modifiers and tried to change a few things but still no luck. Man, I hope I don't have to reset all of my mouse modifiers to their default to get this fixed.
alexoden is offline   Reply With Quote
Old 06-09-2017, 06:24 PM   #4
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 1,000
Default

I do not think that your problem is related to ReaScripts.

Instead, you probably set the mouse modifier for MIDI note -> Left drag to "Edit note velocity (fine)". Simply go to Preferences -> MIDI editor mouse modifiers and reset the mouse modifier to something like "Move note".

If you used the Actions list, you probably clicked on
Set default mouse modifier action for "MIDI note left drag" to "Edit note velocity (fine)",
which can be reset by clicking on
Set default mouse modifier action for "MIDI note left drag" to "Move note" (factory default).

These mouse modifier actions in the Actions list are not toggles, so you cannot switch them "Off" by clicking on them again. Instead, you must switch to an alternative mouse action for the same context (which is probably "MIDI note left drag" in this case).
juliansader is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:26 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.