Old 06-13-2017, 01:16 PM   #1
AdrianW
Human being with feelings
 
Join Date: Jun 2012
Posts: 19
Default Change Tempo Without Affecting Midi

I don't know that I'll ever understand how this works but here's my question:

I have a session with two audio tracks. I made a custom tempo map using slices with an average of 52 bps in 3/4 time, then created a midi bass track. Now, the bps turned out to be too slow for a loop I wanted to add so I created a new custom tempo map with an average of 156 bps at 3/4 time. Works great for the loop but the midi bass track is now about three times too fast. I'm sure there's a way to fix this but I can't figure it out. As a workaround I just rendered the original midi bass to a wave file but I'd really like to know how to keep it a midi track in sync with the new tempo map. Thanks.
AdrianW is offline   Reply With Quote
Old 06-13-2017, 01:26 PM   #2
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 1,287
Default

Open the Item Properties for the MIDI Item and try to change the Item Timebase (either from Beats to Time or the other way around) ...

Some general info about Track Timebase can be found here: www.youtube.com/watch?v=eus1hMD_eUo

Last edited by solger; 06-13-2017 at 01:36 PM.
solger is offline   Reply With Quote
Old 06-13-2017, 03:37 PM   #3
AdrianW
Human being with feelings
 
Join Date: Jun 2012
Posts: 19
Default

Quote:
Originally Posted by solger View Post
Open the Item Properties for the MIDI Item and try to change the Item Timebase (either from Beats to Time or the other way around) ...

Some general info about Track Timebase can be found here: www.youtube.com/watch?v=eus1hMD_eUo
Thanks. I think the problem, in part, is that the recordings were done without a click-track. I created the tempo map by slicing a track on the beat and converting the slices to tempo markers. This works well but the tempo fluctuates slightly to match the beat. If it was a constant tempo it would be fairly simple to change it but I'm not sure it can be done with a custom map.
AdrianW is offline   Reply With Quote
Old 06-16-2017, 04:33 PM   #4
LugNut
Human being with feelings
 
Join Date: Jun 2013
Location: So Florida
Posts: 577
Default

Hi,
Midi items have to be set to ignore tempo. In item properties or with an sws command.
I know, its weird. And shouldn't be this way. Setting time base to time should be enough, but its not.
LugNut is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.