Old 01-27-2013, 12:06 PM   #1
pixeltarian
Mortal
 
pixeltarian's Avatar
 
Join Date: Oct 2008
Location: Saint Paul, MN
Posts: 3,134
Default what protocol do web links use?

I'm not a programmer, but I have this problem:

When I click a web link in a program (EG: "proceed to download page" in reaper) it opens the link in microsoft word. I tried changing the file types htm and html to my broswer but it still happens. Does anyone know the specific file type that a weblink within and application is?
pixeltarian is offline   Reply With Quote
Old 01-27-2013, 12:38 PM   #2
run, megalodon
Mortal
 
run, megalodon's Avatar
 
Join Date: Apr 2010
Posts: 3,054
Default

I don't know if this works on all version of windows, but try start>default programs>set program defaults

If not:

http://lmgtfy.com/?q=all+links+open+in+word
run, megalodon is offline   Reply With Quote
Old 01-27-2013, 02:41 PM   #3
pixeltarian
Mortal
 
pixeltarian's Avatar
 
Join Date: Oct 2008
Location: Saint Paul, MN
Posts: 3,134
Default

Quote:
Originally Posted by run, megalodon View Post
I don't know if this works on all version of windows, but try start>default programs>set program defaults

If not:

http://lmgtfy.com/?q=all+links+open+in+word
oops. I forgot to add:
I'm computer literate and know what program access defaults are and set everything web-related to chrome. I also tried everything I could find on google which is why I posted this.
pixeltarian is offline   Reply With Quote
Old 01-27-2013, 03:43 PM   #4
run, megalodon
Mortal
 
run, megalodon's Avatar
 
Join Date: Apr 2010
Posts: 3,054
Default

Whoopsie. Sorry then.
run, megalodon is offline   Reply With Quote
Old 01-28-2013, 09:10 PM   #5
sstillwell
Mortal
 
Join Date: Jul 2006
Location: Cowtown
Posts: 1,502
Default

It SHOULD be responding to whatever the default handler for http:// or https:// is.

If it's responding to file type/extension stuff instead, you've managed to redirect the handler for *.php

Do you do any web development work where you might have opened PHP files locally on your machine? Word isn't exactly a programmer's editor...

It's weird that Reaper would do that, though...

Scott
__________________
http://www.stillwellaudio.com/
sstillwell is offline   Reply With Quote
Old 01-30-2013, 08:46 AM   #6
Tomm
Mortal
 
Join Date: Nov 2007
Posts: 489
Default

It does that here too, because I have a text editor set up to open html files by default. Save the html file, then right click it and choose "Open With..." and choose a browser as a default. Then you should be fine.

If not (looks like you've tried this already) you sometimes have to "clear" the file type association completely first. Do this in Folder Options. Then either try opening the file again from the application or re-assign the file type. I've had to do this once or twice.

If not, throw the pc out of the window... I mean, try restarting windows.
Tomm is offline   Reply With Quote
Old 01-30-2013, 05:18 PM   #7
pixeltarian
Mortal
 
pixeltarian's Avatar
 
Join Date: Oct 2008
Location: Saint Paul, MN
Posts: 3,134
Default

Quote:
Originally Posted by Tomm View Post
It does that here too, because I have a text editor set up to open html files by default. Save the html file, then right click it and choose "Open With..." and choose a browser as a default. Then you should be fine.

If not (looks like you've tried this already) you sometimes have to "clear" the file type association completely first. Do this in Folder Options. Then either try opening the file again from the application or re-assign the file type. I've had to do this once or twice.

If not, throw the pc out of the window... I mean, try restarting windows.
Tried that. No dice. an '.html' and/or '.htm' file will open with my browser. A button within a program opens in MS word.
pixeltarian is offline   Reply With Quote
Old 01-30-2013, 05:18 PM   #8
pixeltarian
Mortal
 
pixeltarian's Avatar
 
Join Date: Oct 2008
Location: Saint Paul, MN
Posts: 3,134
Default

Quote:
Originally Posted by sstillwell View Post
It SHOULD be responding to whatever the default handler for http:// or https:// is.

If it's responding to file type/extension stuff instead, you've managed to redirect the handler for *.php

Do you do any web development work where you might have opened PHP files locally on your machine? Word isn't exactly a programmer's editor...

It's weird that Reaper would do that, though...

Scott
I don't see either of those in the protocol list.
pixeltarian is offline   Reply With Quote
Old 02-01-2013, 09:20 AM   #9
Tomm
Mortal
 
Join Date: Nov 2007
Posts: 489
Default

Then you probably just need to create the association manually? The screen should look something like this (win7):

Attached Images
File Type: jpg Untitled.jpg (57.1 KB, 83 views)
Tomm is offline   Reply With Quote
Old 02-01-2013, 11:39 AM   #10
pixeltarian
Mortal
 
pixeltarian's Avatar
 
Join Date: Oct 2008
Location: Saint Paul, MN
Posts: 3,134
Default

Quote:
Originally Posted by Tomm View Post
Then you probably just need to create the association manually? The screen should look something like this (win7):
I'm on windows 7 as well.

How do I create a protocol manually?
pixeltarian is offline   Reply With Quote
Old 02-01-2013, 07:34 PM   #11
Tomm
Mortal
 
Join Date: Nov 2007
Posts: 489
Default

In registry it should look something like this:

Computer\HKEY_CLASSES_ROOT\http\shell\open\command

"C:\program files\Chrome\Chrome.exe" --app="%1"



It's hard to say in your case, of course, but maybe try creating the "http" folder here and see if it comes up in the association window first.

Good luck.
Tomm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.