Go Back   Cockos Confederated Forums > REAPER Forums > REAPER Feature Requests

Reply
 
Thread Tools Display Modes
Old 08-20-2013, 05:47 PM   #81
hamish
Human being with feelings
 
hamish's Avatar
 
Join Date: Sep 2007
Location: Newcastle ('straya)
Posts: 1,510
Default

Quote:
Originally Posted by LugNut View Post

My other partition died...and i couldnt renumber my forum password..AND i couldnt get the site to resend me my pass^^...and so on...

Guido...er Lug
Damn, bad luck, my condolences on your partition. I was hoping it wasn't something so painful... and your punctuation gave you away ^^ (as well as your style with REAPER MIDI)
__________________
electricladyLAN, 'providing a good home to abandonware since 2006' http://www.cockos.com/forum/showthread.php?t=16067
you reaper what you sow ( o )===++
hamish is offline   Reply With Quote
Old 07-10-2014, 10:47 PM   #82
benbenben6
Human being with feelings
 
Join Date: Jun 2012
Posts: 9
Default Ignore Project Tempo

Hey,

I'm wondering if anyone knows a trick for recording Midi so that it's written as an item already set to 'ignore project tempo'.

On projects where the last thing you do is tempo map, using SWS actions to select all your midi and set it to 'ignore project tempo' and then go about mapping seems to lead to to fairly stable results. If however, you record Midi on an already tempo-mapped song, 'ignore project tempo' will destroy the original timing.

I thought maybe I could create a blank midi item, set it to ignore project tempo, and then overdub Midi into it. Unfortunately, this doesn't quite work.

There are some instructions on this thread that can work for after the Midi has been recorded, but at the moment it seems a bit lengthy a process to run on multiple takes. http://forum.cockos.com/showthread.php?t=118061&page=3

I've voted for the FR mentioned earlier in this thread, as that would solve this more elegantly.
benbenben6 is offline   Reply With Quote
Old 07-11-2014, 02:04 PM   #83
PooFox
Human being with feelings
 
PooFox's Avatar
 
Join Date: Dec 2009
Location: Boulder, Colorado
Posts: 1,875
Default

@benben i suppose you could enable alternate recording actions and then make a macro to stop recording and apply ingore project tempo to all recorded items (it should only affect the MIDI ones).

i still can't understand why MIDI and audio items can't both just follow the tempo map and timebase correctly. obviously that's the way it should be. instead, MIDI items have their own rules that are unpredictable and defy logic.
__________________
| Twilight Mystery School |
Surrealist Electronic Music
PooFox is offline   Reply With Quote
Old 07-11-2014, 03:31 PM   #84
benbenben6
Human being with feelings
 
Join Date: Jun 2012
Posts: 9
Default

Quote:
Originally Posted by PooFox View Post
@benben i suppose you could enable alternate recording actions and then make a macro to stop recording and apply ingore project tempo to all recorded items (it should only affect the MIDI ones).
Just to clarify: setting a Midi item to ignore project tempo if the Midi was recorded after the project has been tempo mapped will destroy original timing. On the forum I linked to above, Breeder gives some instructions on how to avoid this, but it seems like it would be hard to turn into a macro:

Quote:
Mark tempo markers around said item and select it
Run SWS/BR: Delete tempo marker and preserve position and length of selected items (including MIDI events)
Run SWS/BR: Enable "Ignore project tempo" for selected MIDI items (use tempo at item's start)
Copy the item
Undo to before deleting tempo markers
Delete selected item
Paste your item in it's place
benbenben6 is offline   Reply With Quote
Old 07-14-2014, 04:09 PM   #85
TimU
Human being with feelings
 
Join Date: Sep 2012
Location: Uk
Posts: 22
Default

Surely the Midi timebases should behave in exactly the same way as the audio timebases, ie.

- Beats (position, length, rate) - stretches the item when the tempo is changed and retains its position on the beat based grid

- Beats (position only) - item is not stretched by tempo adjustment and retains its position on the beat based grid (the snap offset dictates which part of the item retains its position)

- Time - The item's snap offset will occur at the same time regardless of tempo settings and will not be stretched by tempo adjustment

This is how midi items should behave, I was quite worried when I discovered that they don't

I think the original tempo thing should probably be implemented into the item properties menu for both midi and audio (and video) items
TimU is offline   Reply With Quote
Old 07-15-2014, 01:21 PM   #86
PooFox
Human being with feelings
 
PooFox's Avatar
 
Join Date: Dec 2009
Location: Boulder, Colorado
Posts: 1,875
Default

Quote:
Originally Posted by TimU View Post
Surely the Midi timebases should behave in exactly the same way as the audio timebases, ie.

This is how midi items should behave, I was quite worried when I discovered that they don't

I think the original tempo thing should probably be implemented into the item properties menu for both midi and audio (and video) items
i agree. biggest and most overlooked problem in reaper since i started using it. took me some months of investigation and frustration to even pinpoint the source of the problem and even then almost no one would chime in on it.

guess using midi, audio and tempo maps together is still considered "fringe" and not a critical thing to fix. go figure.

i gave up on tempo maps because of this. i just adjust the playrate envelope instead. it's actually better anyway because the tempo envelope can't do any curves and so it's hard to make it sound natural@.

@benben - i think it's going to be a hard workaround. what i would do is just render the project temporarily and record in a new project without a tempo map. hopefully you can just insert the recorded midi without problem. and until it's fixed i'd recommend using the playrate envelope while working. at the end you can convert it to a tempo map (i think?). you can just use tempo markers for time sig changes, since too many tempo shifts over the length of an item will screw things up. otherwise you probably need to chop your midi items so they start an end at tempo markers.
__________________
| Twilight Mystery School |
Surrealist Electronic Music

Last edited by PooFox; 07-15-2014 at 01:29 PM.
PooFox is offline   Reply With Quote
Old 07-28-2014, 02:01 PM   #87
TechDAWg
Human being with feelings
 
TechDAWg's Avatar
 
Join Date: Jul 2009
Location: Quebec
Posts: 17
Default ignoring tempo for midi items

People on the Reaper forum have been complaining about this for at least two years and nothing's been done yet on the devs side. Thanks to Breeders for is new SWS actions. After years of frustration, finally something helpful.
TechDAWg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:08 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.