Old 02-05-2017, 03:14 PM   #1
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default REAPER/Mac/Tascam US-2400 setup

I've searched for and read the threads concerning the US-2400 and still have had no success. It works fine in DP. I've tried all the modes on the US-2400 and created a Mackie Control and two Mackie Extender entries in the Control surfaces/OSC panel with the proper 8 and 16 offsets. REAPER still pays no attention to the Tascam when I move the faders. Is there a toggle I need to hit to make the whole thing work? The USB LED flashes when I move a fader but there's no visual response from REAPER's mixing board.
What am I missing?
cpd3 is offline   Reply With Quote
Old 02-08-2017, 12:30 PM   #2
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default

HELP! Please....
cpd3 is offline   Reply With Quote
Old 02-08-2017, 02:34 PM   #3
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 1,281
Default

I don't know the US-2400, but a quick search revealed these links:

- http://forums.cockos.com/showthread.php?t=85717
- https://github.com/DavidLichtenberge...r-csurf-us2400
solger is online now   Reply With Quote
Old 02-08-2017, 05:54 PM   #4
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default

Thank you for the info but I've checked those posts. The driver is Windows only (while I'm on a Mac) and the first topic dealt with getting the joystick of the US-2400 alive. The control surface was already working for that forum member. So the basic "make it work" is nowhere to be found within these posts or any I can find after searching "US-2400" as a search term.

I've done everything I can think of after reading all available posts, but I'm sure it's something simple I'm missing. (It always is...)

Anyone?
cpd3 is offline   Reply With Quote
Old 02-11-2017, 12:57 PM   #5
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default

A quick bump. Please help me get this thing alive. It should be easy but hasn't proved to be so far.
cpd3 is offline   Reply With Quote
Old 02-16-2017, 05:21 PM   #6
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default

Another bump. Please help me with this setup. I've done everything I can think of and I'm still in the weeds on this one.
cpd3 is offline   Reply With Quote
Old 02-17-2017, 08:50 AM   #7
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 1,281
Default

Quote:
Originally Posted by cpd3 View Post
Another bump. Please help me with this setup. I've done everything I can think of and I'm still in the weeds on this one.
Did you already try to set up the Tascam 2400 in 'Mackie Control - Sonar optimized' mode, as mentioned in the first link I posted?

Quote:
Basic setup:

To get the US-2400 basically working with Reaper, meaning faders are mapped to 24 channels and panning works, You have to do the following things:

- Set the US-2400 to 'Mackie Control - Sonar optimized'
- In Reaper, add a 'Mackie Control Universal, offset 0, for the Tascam's first USB-channel.
- add a Mackie Control Extender, offset 8, for the Tascam's second USB-channel.
- add a Mackie Control Extender, offset 16, for the Tascam's third USB-channel.
According to the Quick Start Guide, emulation modes can be set like this (Aux Key #2 is for selecting Mackie Control emulation mode, optimized for Sonar):
Quote:
Originally Posted by US-2400 Quick Start Guide
Set the emulation mode in the following ways :

1 With the US-2400 power in standby mode (press the POWER key so that the indicator pulses), press and hold the master fader’s SEL key and then press and hold one of the AUX keys as shown below.

2 Turn on the US-2400 power (press the POWER key) while holding down the master SEL key and one of the AUX keys

3 The appropriate AUX indicator flashes three times to show that the emulation mode has been selected (this happens every time the US-2400 is turned on, to confirm the current emulation).

Last edited by solger; 02-17-2017 at 09:04 AM.
solger is online now   Reply With Quote
Old 02-18-2017, 01:05 AM   #8
Hanswurst
Human being with feelings
 
Hanswurst's Avatar
 
Join Date: Dec 2015
Location: Germany
Posts: 12
Default

Also, check out this thread: http://forum.cockos.com/showthread.php?t=132165
Hanswurst is offline   Reply With Quote
Old 02-20-2017, 06:32 PM   #9
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default

Thank you both for the replies.

solger - yes, I tries all the available modes on the US-2400. No response from REAPER.

Hanswurst - the thread offers great information and a driver. Unfortunately, it's for Windows and, as I stated, I'm on a Mac. I did read it and all the other threads that a search with 'US-2400" and every variant I could think of turned up.

I have the three Mackie surfaces with the proper offsets in my setup. Audio/MIDI Setup shows the US-2400 with 3 MIDI ports coming from it. But REAPER doesn't react at all.

What am I missing? Is there something I need to arm in REAPER or should the physical and software faders simply move together as they do in DP?

It is a puzzlement...
cpd3 is offline   Reply With Quote
Old 02-20-2017, 07:28 PM   #10
cpd3
Human being with feelings
 
Join Date: Jun 2016
Posts: 7
Default

Suddenly REAPER is reacting but doing so insanely. Sometimes all three banks of 8 faders will go to the correct position and sometimes the first bank will go to an arbitrary uniform position for all faders unrelated to the on-screen mixer. In a random moment, touching and/or moving a fader (particularly in the first bank or the master) will provoke a spastic random movement from virtually all the faders simultaneously. This is reflected onscreen. The master fader causes this behavior in all circumstances.

So I guess it's progress, in that REAPER is seeing the US-2400 but, yikes.....

Thoughts?
cpd3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.