Old 06-21-2017, 09:12 PM   #2041
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 91
Default

Quote:
Originally Posted by Finnish View Post
Thanks. So it's not a native linux vst/so?
This zynaddsubfx version is a native linux vst with .so extension. Carla can also
host lv2 and ladspa plugins, so one who has some favorites in those formats,
can host a chain of them using Carla. I've just done a few, but the prospects
look good, as there are so many, and with a good variety.

In case I wasn't clear, the Carla version was itself a vst
hosted in Reaper, Carla 2:1.9.7+git20170520v5 according to synaptic,
part of the kxstudio repository.
Cheers

Last edited by 4duhwinnn; 06-21-2017 at 09:20 PM. Reason: clarity
4duhwinnn is offline   Reply With Quote
Old 06-21-2017, 10:08 PM   #2042
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 91
Default

Quote:
Originally Posted by osxmidi View Post
I've ported the Scorchcrafter GUI over (not my GUI design btw).

It looks about the same on Windows, maybe a bit fugly but functional.
Looks good, right in the range of expected art and function.
Cheers
4duhwinnn is offline   Reply With Quote
Old 06-22-2017, 07:26 AM   #2043
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 234
Default

Quote:
Originally Posted by 4duhwinnn View Post
Looks good, right in the range of expected art and function.
Cheers
It's up at https://github.com/osxmidi/LinVst/bl...rch-vst.so.zip if anyone is interested.

Short test https://soundcloud.com/aaabii/test

Distrho was used for the Mverb Windows vst to Linux vst port and it's pretty good for getting basic Windows vst GUI code over to Linux vst's.

http://distrho.sourceforge.net/plugins

http://distrho.sourceforge.net/ports

Last edited by osxmidi; 06-22-2017 at 09:55 AM.
osxmidi is online now   Reply With Quote
Old 06-22-2017, 09:26 AM   #2044
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 29
Default Batch name convert linvst.so

Hi OSXMIDI,
could you talk me through how to run the batch name converter? I'm a bit confused by the readme and I'm getting a bit sick of copying/renaming every VST. I was gonna try out the Toneboosters plug-ins.
__________________
Ubuntu Studio 16.10 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old 06-22-2017, 09:44 AM   #2045
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 234
Default

Quote:
Originally Posted by nosucherror View Post
Hi OSXMIDI,
could you talk me through how to run the batch name converter? I'm a bit confused by the readme and I'm getting a bit sick of copying/renaming every VST. I was gonna try out the Toneboosters plug-ins.
In the release there is linvst.so and lin-vst-server.exe and lin-vst-server.exe.so etc

linvst.so gets renamed to the windows vst name and lin-vst-server.exe and lin-vst-server.exe.so get placed in /usr/bin

In the convert folder there is linvstgtk3 (or linvstgtk2) which is a GUI renaming version.

Just run linvstgtk3 (should run by clicking on it) and hit the top button and then it wants to know where linvst.so is, so just search for it using the file chooser that pops up and once it's found just click on it and load it.

The second button wants to know the folder containing the windows dll's so just point it to the folder.

Then hit start and it will rename all of the windows dll's to their equivalent Linux names (ending with .so instead of .dll)

Then point Reaper to that folder and you should be able to load the windows vst's.


The commandline version needs to be copied to the windows dll folder and then run and it does the same thing as the GUI version.
osxmidi is online now   Reply With Quote
Old 06-22-2017, 10:17 AM   #2046
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 29
Default

Thank you OSXMIDI!
__________________
Ubuntu Studio 16.10 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old 06-22-2017, 11:27 AM   #2047
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 29
Default

@OSXMIDI
When you say 'in the convert folder' do you mean the linvstconvertsrc.zip? When I extract that I don't find anything I can run. Am I missing something?
__________________
Ubuntu Studio 16.10 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old 06-22-2017, 11:47 AM   #2048
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 91
Default

Quote:
Originally Posted by osxmidi View Post
It's up at https://github.com/osxmidi/LinVst/bl...rch-vst.so.zip if anyone is interested.

Short test https://soundcloud.com/aaabii/test

Distrho was used for the Mverb Windows vst to Linux vst port and it's pretty good for getting basic Windows vst GUI code over to Linux vst's.

http://distrho.sourceforge.net/plugins

http://distrho.sourceforge.net/ports
I've got this running (followed by the LaGrange ganular modulation plugin),
with some decent headphones, and it's brilliant. The tones run the gamut,
with 9 channels leaving little to the imagination, knobs are fluid,
and the labels are accurate, not just generic.

I'm not a fan of 'this is all you'll need' type of statements,
but if someone wants ultra simplicity controlling a huge range of tone,
this is going to be very hard to beat. A kid just learning guitar,
could really concentrate on developing skills, without having
to figure out a complex gui. Someone who could interface this
with an FCB1010 or similar controller, would be in hawgheaven.
Thanks for sharing your work, and discoveries!
4duhwinnn is offline   Reply With Quote
Old 06-22-2017, 12:55 PM   #2049
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 29
Default

@OSXMIDI

Forget my last post - I didn't have the latest linvst 1.02, I forgot to refresh my browser at GitHub. I see the 'convert' folder now. My apologies.
__________________
Ubuntu Studio 16.10 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old Yesterday, 07:23 AM   #2050
swindus
Human being with feelings
 
Join Date: Jun 2009
Posts: 47
Default

Quote:
Originally Posted by Justin View Post
Thanks, fixing for 5.50rc2c.
after removing the gtk+3 dev files and trying the new build (rc3) of Reaper I get this on a Reaper start:
reaper: symbol lookup error: ../REAPER/libSwell.so: undefined symbol: gdk_init_check

Installing the gtk+3 dev files again and Reaper is starting
swindus is online now   Reply With Quote
Old Yesterday, 08:33 AM   #2051
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 29
Default LinVst no GUI

Hi OSXMIDI,
I'm having problems with LinVst, it's not showing GUIs for plugins, the audio is getting processed but the window is a blank, I can use REAPER's controls. I've tried 1.02 and 1.03.
I had trouble with REAPER 550rc3, I had to separately compile swell to run it.
I'm on Ubuntu Studio 16.10, I have GTK-3dev and I've tried this on a laptop and a tower.
Any ideas?
Also, in the README example a couple of the extensions (.so) should read .exe.so
__________________
Ubuntu Studio 16.10 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old Yesterday, 08:56 AM   #2052
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 234
Default

Quote:
Originally Posted by nosucherror View Post
Hi OSXMIDI,
I'm having problems with LinVst, it's not showing GUIs for plugins, the audio is getting processed but the window is a blank, I can use REAPER's controls. I've tried 1.02 and 1.03.
I had trouble with REAPER 550rc3, I had to separately compile swell to run it.
I'm on Ubuntu Studio 16.10, I have GTK-3dev and I've tried this on a laptop and a tower.
Any ideas?
Also, in the README example a couple of the extensions (.so) should read .exe.so
It might depend on the plugin and your video hardware/drivers.

I've had a black screen with the OP-X Pro (Oberheim) vst, because the old Dell laptop I was using hasn't got great opengl support (old builtin Intel graphics) and opengl is needed for some windows vst's.

If I go to my Nvidia based computer then it's ok.

It could happen with newer hardware if the opengl drivers are not setup correctly for some reason.

Starting Reaper from the terminal will result in Wine sending out messages to the terminal about what's happening.

Maybe try a windows opengl program with Wine and see if there are any problems.

Thanks for pointing out the name problem, I've fixed it now.

Last edited by osxmidi; Yesterday at 09:43 AM.
osxmidi is online now   Reply With Quote
Old Yesterday, 09:00 AM   #2053
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Posts: 871
Default

@osxmidi: Don't know if you've seen it, but you have a pm
__________________
Software: Archlinux/KDE/Wine, Reaper64, Komplete8, IK Multimedia, Toontrack and various other plugs. Gear: i7-2600k, 16gb ram, RME Multiface, RME Babyface, Behringer X32, Genelec 8040, and much more :)
Jack Winter is online now   Reply With Quote
Old Yesterday, 02:02 PM   #2054
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 29
Default LinVst Toneboosters

Hi OSXMIDI
The plugins that are showing up with black GUIs are the Toneboosters older ones with fixed interfaces like Ferox3. The newer ones like Barricade4 are resizable and do show up in REAPER but crash it quite often and resizing is sketchy.
I've attached an error report and the terminal output.
Attached Files
File Type: txt barricade_VST_backtrace.txt (12.8 KB, 2 views)
File Type: txt Tonebooster_plugin_blackGUI.txt (1.8 KB, 2 views)
__________________
Ubuntu Studio 16.10 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old Yesterday, 06:15 PM   #2055
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,161
Default

Quote:
Originally Posted by swindus View Post
after removing the gtk+3 dev files and trying the new build (rc3) of Reaper I get this on a Reaper start:
reaper: symbol lookup error: ../REAPER/libSwell.so: undefined symbol: gdk_init_check

Installing the gtk+3 dev files again and Reaper is starting
Got it, thanks, will be fixed for rc4!
Justin is offline   Reply With Quote
Old Yesterday, 09:06 PM   #2056
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 234
Default

Quote:
Originally Posted by nosucherror View Post
Hi OSXMIDI
The plugins that are showing up with black GUIs are the Toneboosters older ones with fixed interfaces like Ferox3. The newer ones like Barricade4 are resizable and do show up in REAPER but crash it quite often and resizing is sketchy.
I've attached an error report and the terminal output.
Yeah, the errors are related to OpenGL/D3D.

Wine translates the Windows vst's D3D/DirectX function calls to Linux OpenGL equivalents and if your Linux OpenGL hardware/drivers can't support some of the functions, then it will result in blank screens and other display problems and maybe crashes.


Module Address Debug info Name (156 modules)
ELF 7a800000- 7a9f9000 Deferred opengl32<elf>


fixme:winediag:dxgi_check_feature_level_support None of the requested D3D feature levels is supported on this GPU with the current shader backend.
osxmidi is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.