Go Back   Cockos Confederated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 10-09-2016, 09:22 AM   #1
ELP
Human being with feelings
 
Join Date: Apr 2014
Posts: 943
Default Bug with the option: "Automatically correct overlapping Notes" set to disable (FIXED)

A simple swap to a different MIDI Editor view or a close and re-open XYZ MIDI item
causes REAPER to
do correct all overlapping Notes,
even if "Automatically Correct overlapping Notes" is set to disable..

This edit view swap/re open...
behavior with
"Automatically Correct overlapping Notes"
and you have the option set to disable -during editing-
can produce zero notes..
at least if there are >=three overlapping notes in a row.
I said that all zero notes ... now were fixed but it is unfortunately not.
here is one, hopefully the really last, possibility to produce

At the moment it is really better to have the auto correct option stays at enable!

Set the option to disable do not work!
..or better: only work if you never close/re open or swap the view and do editing these events again


Thank you and greetings
__________________
I hope you can understand me? Without german beer my written english is always very bad, with beer it becomes unbearable!.
Less is more! To much limited the own creativity.
ELP is offline   Reply With Quote
Old 10-21-2016, 12:39 AM   #2
ELP
Human being with feelings
 
Join Date: Apr 2014
Posts: 943
Default

<=v5.27
bump,..

the above stuff means also simplified, that REAPER only support overlapping Notes
(no matter if automatically correct overlapping notes is disable)
as long as you do not close the editor and reopen to edit the Item again)
-Or as long as you do not swap the editor view mode)

If you close or swap the mode from Piano to names/stuff or list view
and re-swap again to the Piano roll for editing,
the previous overlapping Notes are always automatically shorten...
As I write above no matter whether the automatically... option is disabled.


__________________
I hope you can understand me? Without german beer my written english is always very bad, with beer it becomes unbearable!.
Less is more! To much limited the own creativity.

Last edited by ELP; 10-21-2016 at 12:45 AM.
ELP is offline   Reply With Quote
Old 10-31-2016, 01:40 AM   #3
ELP
Human being with feelings
 
Join Date: Apr 2014
Posts: 943
Default

I bump this again, because with 5-27 - 5.28prexx overlapping notes are not possible anymore.
Together with swap the edit view and or re open item
(and this is important: if none of the overlapping Notes is selected!!)

If auto correct overlapping Notes is set to disable and You do not have select your overlapping Note(s), the Notes would always auto correct shorten to XY length..(No matter if auto correct is enable or not)
-this happens after you swap the editor and or re open the item again and no note is selected...

This is a bug which make REAPER(only at the moment, hopefully) to a DAW,
which is incompatible to handle overlapping Notes..
This begin already with just two simple overlapping Notes in a row

And since newer bugs have priority for Schwa:

for this reason !,... I test it also extra with a portable 5.23

and with 5.23 this is not happen.

the first Lice is the behavior within 5.23
the second Lice the none compatible behavior within 5.28pre8

As I said for reproduce it is important to deselect the overlapping Notes first.

5.23

5.27-5.28pre xx


Greetings


EDIT
& BTW with this bug behavior above, it is of course easy possible - and a new way to produce/get unwanted zero Note lengths..

Short Example Lice with 5.27
__________________
I hope you can understand me? Without german beer my written english is always very bad, with beer it becomes unbearable!.
Less is more! To much limited the own creativity.

Last edited by ELP; 10-31-2016 at 02:22 AM.
ELP is offline   Reply With Quote
Old 10-31-2016, 06:28 PM   #4
ELP
Human being with feelings
 
Join Date: Apr 2014
Posts: 943
Default

test....:

the possibility to getting zero Note(s) and the overlapping Note(s) problem is fixed with 5.28pre 9

Thank you
__________________
I hope you can understand me? Without german beer my written english is always very bad, with beer it becomes unbearable!.
Less is more! To much limited the own creativity.
ELP is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:25 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.