Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 11-03-2016, 09:04 AM   #1
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 3,689
Default MIDI Editor Key snap status incorrect (since v5.20) (FIXED)

Key snapping seems to be somewhat broken in MIDI editor.

To recreate the problem:
1. Set preference to one MIDI editor per project.
2. Create two MIDI items, then open one of them in MIDI editor.
3. Click the Key snap on, verify that it is on and working.
4. Without closing the MIDI editor, switch over to the other MIDI item. Notice how the Key snap is not showing up in piano roll and not working even though it seems to be selected at the bottom of the MIDI editor.
5. To turn the Key snap on for this 2nd item, click the Key snap off and then back on.

This problem shows up the same way in reverse when turning the Key snap off. For the first item you can simply click the Key snap off. For all the other items the editor task bar shows the snap being off but you have to actually click the Key snap back on and then off for it to work.

So the problem is that the Key snap status shows proper and works only for the first MIDI item when the snapping is switched on or off. For the rest the snapping has to be switched back and forth for it to work. This seems to have changed in Reaper v5.20, in v5.17 the snapping status changes and works at once for all the items. If this was an intended change > the snapping has to be switched individually for each item, then the task bar click box status should also update individually.


Original discussion here:
http://forum.cockos.com/showthread.p...15#post1752015

---
edit: Fixed in v5.31pre1.

Last edited by xpander; 12-20-2016 at 05:51 PM. Reason: update
xpander is offline   Reply With Quote
Old 11-03-2016, 01:35 PM   #2
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,216
Default

Mmm.. i tried to reproduce your issue here, but "no succes":

Keysnap stays turned on and works for the second selected midi item, for me. (1 midi editor set in prefs).
(Beware, i select that second midi item in Arrange view, maybe you select the 2nd midi item in a different way ?)

However, i am on mac (Reaper 5.28rc1 - 64bit).
Maybe it's a Reaper -Windows version issue...

Sorry can't help you further...
vanhaze is offline   Reply With Quote
Old 11-03-2016, 02:49 PM   #3
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 3,689
Default

Np, thanks for testing it anyway vanhaze. Yea, Win10 here so we have different OS. The way of selecting the MIDI items doesn't seem to matter here. I can select from the Main arrange, MIDI editor track list, double clicking on the MIDI editor grid, they all produce the same results.
xpander is offline   Reply With Quote
Old 11-03-2016, 02:57 PM   #4
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 3,216
Default

Thank you for responding.
Glad to be of any help to you.

I hope your issue get's fixed by Cockos Guys soon, cause to me, it smells like a (Reaper-windows) bug.
vanhaze is offline   Reply With Quote
Old 12-19-2016, 01:27 AM   #5
zacki
Human being with feelings
 
zacki's Avatar
 
Join Date: Feb 2013
Location: TBB - Germany
Posts: 89
Default

Quote:
Originally Posted by xpander View Post
Key snapping seems to be somewhat broken in MIDI editor.
I can reproduce this here. Exact the same behavior as described from xpander. I'm using Win7x64 and REAPER 5.29 x86
__________________
Some of my favourite posts: 1 2 3 --- to be continued...
zacki is offline   Reply With Quote
Old 12-19-2016, 05:27 AM   #6
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,057
Default

Fixing, thanks.
schwa is offline   Reply With Quote
Old 01-21-2017, 02:30 AM   #7
adriaan
Human being with feelings
 
Join Date: Jan 2017
Posts: 1
Default

Hi!
I read that this was fixed, but could it be that it still isn't entirely working as intended?

I'm running into the problem that when setting the Key Snap in a number of Midi Items the key/scale is changed at some point and also the keyboard keys are not greyed out accordingly.

To reproduce:
1. Set preference to one MIDI editor per project.
2. Create three MIDI items, then open one of them in MIDI editor.
3. Now in every item: Click the Key snap on, set the scale to D-Harmonic Minor.

4. Without closing the MIDI editor, switch randomly over to the other MIDI items.

When switched over:
- either it's correct: key/scale are correct, keyboard keys are greyed out correct;
- or the key/scale is correct, but the keyboard graying out doesn't reflect the key/scale;
- or the key/scale is set to C-Major and the keyboard keys are greyed out accordingly;
- or the key/scale is set to C-Major but the keyboard keys are not greyed out accordingly;

I'm using Reaper 5.32/x64 on Win10/x64.
adriaan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.