Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 02-13-2017, 05:28 PM   #1
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,827
Default 5.33 multiple crashes involving volume envelopes

REAPER 5.33 - 64 OSX 10.10.5

Over the past week I've had a few crashes while adjusting volume envelopes.
This project is really big, but I don't know if that's part of the problem.

Was able to repeat a crash in one scenario, other times it is random.

Video

https://youtu.be/nMiWXrbzVrI

Steps to reproduce:
two items are selected. Second item has a volume envelope.
Heal splits in items (volume envelope moves to first item)
UNDO
reaper crashes

Other times it's simply dragging an envelope point that causes the crash.

I can PM or email the project file without audio if needed.
Crash logs here
https://dl.dropboxusercontent.com/u/...crash_logs.zip
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 02-14-2017, 02:41 AM   #2
vitalker
Human being with feelings
 
vitalker's Avatar
 
Join Date: Dec 2012
Posts: 2,544
Default

Can't confirm. 5.33 32bit, Win7 64bit.
vitalker is offline   Reply With Quote
Old 02-18-2017, 12:04 AM   #3
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,827
Default

three more crashes today, same project.

Code:
Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000018189

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   reaper_csurf.dylib            	0x000000010cb5d744 CSurf_WWW::Run() + 164
1   com.cockos.reaper             	0x00000001002e1688 CSurf_Run() + 632
2   com.cockos.reaper             	0x00000001000b3431 runMiscTimers() + 6225
3   com.cockos.reaper             	0x00000001000b0fda Main_OnTimer(HWND__*, unsigned long) + 138
4   com.cockos.reaper             	0x00000001005af3d8 MainProc(HWND__*, unsigned int, unsigned long, long) + 7832
5   ???                           	0x5fbfd4d000000001 0 + 6899467143973175297
--------
Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x0000000102c437d2  rcx: 0x00007fff5fbfb6f0  rdx: 0x00007fff5fbfb670
  rdi: 0x0000000000018189  rsi: 0x00007fff5fbfb5f0  rbp: 0x0000000100aa88d0  rsp: 0x00007fff5fbfb7c0
   r8: 0x00007fff5fbfb770   r9: 0x00007fff71bba300  r10: 0x000000010cb9bc60  r11: 0x0000000000000217
  r12: 0x0000000000000003  r13: 0x0000000102c43a02  r14: 0x0000000100b48400  r15: 0x0000000000000000
  rip: 0x000000010cb5d744  rfl: 0x0000000000010246  cr2: 0x0000000000018189
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 02-18-2017, 01:14 AM   #4
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 1,050
Default

Quote:
Originally Posted by EpicSounds View Post
Steps to reproduce:
two items are selected. Second item has a volume envelope.
Heal splits in items (volume envelope moves to first item)
UNDO
reaper crashes
I can confirm, but here it's triggered by moving the mouse cursor over the item after healing. Same backtrace as in the video and "REAPER_2017-02-13-160238_Jons-iMac.crash" from your zip.


(Offscreen: clicking on "Heal splits in items")

Last edited by cfillion; 02-18-2017 at 01:54 AM.
cfillion is online now   Reply With Quote
Old 02-18-2017, 02:05 AM   #5
vitalker
Human being with feelings
 
vitalker's Avatar
 
Join Date: Dec 2012
Posts: 2,544
Default

I'm on Windows, by the way. So it could be macOS issue.
vitalker is offline   Reply With Quote
Old 02-18-2017, 07:51 AM   #6
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,055
Default

Can't reproduce. The crash report shows the REAPER web control interface code; what web interface (basic.html, click.html, etc) are you using?
schwa is offline   Reply With Quote
Old 02-18-2017, 09:40 AM   #7
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,827
Default

Quote:
Originally Posted by schwa View Post
Can't reproduce. The crash report shows the REAPER web control interface code; what web interface (basic.html, click.html, etc) are you using?
hmm ok it was enabled but not in use. I have the imperial style interface.
http://forum.cockos.com/showthread.php?t=186872

I also have a BCF2000 using Mackie Extender mode.

Next time I'm in the project I will disable my control surfaces.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 02-18-2017, 12:04 PM   #8
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,112
Default

Fixed the heal-related crash, thanks! As for the csurf_www one, if you end up reproducing it let us know.
Justin is online now   Reply With Quote
Old 02-24-2017, 07:23 PM   #9
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 3,827
Default

Several hours of work in the project today and no crashes now that I've disabled the web control. Haven't updated to 5.34 yet.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:36 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.