Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 02-17-2017, 01:25 PM   #1
cfillion
Human being with feelings
 
Join Date: May 2015
Location: Québec, Canada
Posts: 1,148
Default Crash when toggling off removed envelope (any plugin) (FIXED)

I'm getting this crash when toggling off envelopes I've just cleared/removed. I initially thought it happened only with Reaktor 5, but after more testing it crashed with ReaEQ as well.

This is with REAPER v5.33 on macOS 10.10:



Code:
Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       EXC_I386_GPFLT

Application Specific Information:
objc_msgSend() selector name: respondsToSelector:


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x00007fff8554b0d7 objc_msgSend + 23
1   com.cockos.reaper             	0x000000010001ce51 TrackEnvelope::SetActive(bool) + 1009
2   com.cockos.reaper             	0x00000001007f683a EnvDlgState::EnvDlgProc(HWND__*, unsigned int, unsigned long, long) + 2330
3   com.cockos.reaper             	0x00000001007f5efe EnvDlgState::_EnvDlgProc(HWND__*, unsigned int, unsigned long, long) + 94
4   com.cockos.reaper             	0x000000010049c10c SwellDialogDefaultWindowProc(HWND__*, unsigned int, unsigned long, long) + 364
5   com.cockos.reaper             	0x000000010067ae4a CoolSBWndProc(HWND__*, unsigned int, unsigned long, long) + 250
6   com.cockos.reaper             	0x0000000100498e1d -[REAPERSwell_hwnd onSwellMessage:p1:p2:] + 829
7   com.cockos.reaper             	0x00000001004b9dfa SendMessage(HWND__*, unsigned int, unsigned long, long) + 90
8   com.cockos.reaper             	0x0000000100312415 WDL_VWnd::SendCommand(int, long, long, WDL_VWnd*) + 21
9   com.cockos.reaper             	0x000000010031242f WDL_VWnd::SendCommand(int, long, long, WDL_VWnd*) + 47
10  com.cockos.reaper             	0x0000000100317fe1 WDL_VirtualIconButton::OnMouseUp(int, int) + 289
11  com.cockos.reaper             	0x0000000100311bd6 WDL_VWnd::OnMouseUp(int, int) + 166
12  com.cockos.reaper             	0x00000001007fa227 EnvDlgState::EnvDlgProc(HWND__*, unsigned int, unsigned long, long) + 17159
13  ???                           	0x5fbff24000000000 0 + 6899499510846717952

Last edited by cfillion; 02-17-2017 at 04:22 PM.
cfillion is online now   Reply With Quote
Old 02-17-2017, 02:48 PM   #2
cfillion
Human being with feelings
 
Join Date: May 2015
Location: Québec, Canada
Posts: 1,148
Default

It seems to be somewhat random. While here it crashes every time with Reaktor 5, with other plugins such as ReaEQ it either works fine, crashes like above, or freezes. Here's a spindump taken while REAPER was frozen: http://sprunge.us/TQcZ.

Last edited by cfillion; 02-17-2017 at 03:06 PM.
cfillion is online now   Reply With Quote
Old 02-17-2017, 07:24 PM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,161
Default

Thanks, fixing!
Justin is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.