Old 02-03-2010, 07:40 PM   #1
bucolic
Human being with feelings
 
Join Date: Feb 2010
Posts: 3
Default No sound at all - Windows 7

I downloaded Reaper a few days ago to begin trying it out, but I soon discovered that I was unable to get any sound output.

I'm on an HP Pavilion dv4 laptop, with Windows 7 Home Premium, 64-bit.

All I'm trying to do is to get sound through my laptop's speakers...it should be the simplest setup possible.

When I tried playing the All Through the Night demo project, I could see the meters moving, but no sound. I then tried recording some MIDI data to play back. Again, I could see the red meter move during playback, but still no sound.

I've tried all the options Preferences > Audio > Devices dialog:

WaveOut
- Microsoft Sound Mapper
- Speakers and Dual Headphones (I
- SPDIF (Digital Out via HP Dock)

DirectSound
- Primary Sound Driver
- Speakers and dual Headphones (IDT High Definition Audio)
- SPDIF (Digital Out via HP Dock) (IDT High Definition Audio)

None of them work.

Someone on the IRC channel suggested that I download ASIO4ALL and try that, which I did. With ASIO selected, I have the following options for the output range:

- SpdifOut 1
- SpdifOut 2
- Speaker1 1
- Speaker1 2

No combination of the above works.

(as a side note, I also don't get any sound when using ASIO4ALL in Sibelius 6 or Ableton Live Lite 8. But I get sound with any of the other outputs above for either program.)

In my Device Manager, I have the following devices listed under Sound, Video, and Audio Controllers:
- IDT HIgh Definition Audio CODEC
- Intel(R) High Definition Audio HDMI

They are all up-to-date.

Thinking it could be a compatibility issue with the latest version, I uninstalled 3.22, downloaded 3.21 and repeated all the above steps, with no luck. I then uninstalled the program again, downloaded the 32-bit version, and repeated all of the above steps once more. Still nothing.

I can't figure out why the same settings work in Sibelius and Live but not Reaper. Are there other settings I'll need to look at other than those in Preferences > Audio > Devices ?

Perhaps it's a Windows 7 issue...I don't know really know my way around the system yet. I did notice that the volume control now has options for individual programs, but I checked those and the ones for Reaper aren't muted or set at zero.

I've been asking on the IRC help channel, but it seems like no one knows what's going on.

It's incredibly frustrating...this seems like a great program, but I'm stuck on this seemingly simple issue and I can't do anything because I can't hear anything. I've spent over 20 hours "evaluating" the program, and the only feature I've gotten around to evaluating is the preferences dialog.
bucolic is offline   Reply With Quote
Old 02-10-2010, 03:45 PM   #2
bucolic
Human being with feelings
 
Join Date: Feb 2010
Posts: 3
Default

No one knows?

I thought maybe Reaper was ReWiring itself somehow even though there were no other applications running, so that's why there was no sound. I couldn't find the ReWire options in the 3.22 release, but I downloaded the 3.3 release and saw nothing unusual with the ReWire options.

I tried ReWiring Reaper and Live with Reaper as host, and then with Live as host. Neither gave any sound. Interestingly, when I hosted Reaper with Live, all the MIDI tracks in Live stopped outputting sound too.
bucolic is offline   Reply With Quote
Old 02-10-2010, 04:01 PM   #3
ChaseEversole
Human being with feelings
 
ChaseEversole's Avatar
 
Join Date: Jan 2010
Location: Indiana
Posts: 415
Default

Quote:
Originally Posted by bucolic View Post
I downloaded Reaper a few days ago to begin trying it out, but I soon discovered that I was unable to get any sound output.

I'm on an HP Pavilion dv4 laptop, with Windows 7 Home Premium, 64-bit.

All I'm trying to do is to get sound through my laptop's speakers...it should be the simplest setup possible.

When I tried playing the All Through the Night demo project, I could see the meters moving, but no sound. I then tried recording some MIDI data to play back. Again, I could see the red meter move during playback, but still no sound.

I've tried all the options Preferences > Audio > Devices dialog:

WaveOut
- Microsoft Sound Mapper
- Speakers and Dual Headphones (I
- SPDIF (Digital Out via HP Dock)

DirectSound
- Primary Sound Driver
- Speakers and dual Headphones (IDT High Definition Audio)
- SPDIF (Digital Out via HP Dock) (IDT High Definition Audio)

None of them work.

Someone on the IRC channel suggested that I download ASIO4ALL and try that, which I did. With ASIO selected, I have the following options for the output range:

- SpdifOut 1
- SpdifOut 2
- Speaker1 1
- Speaker1 2

No combination of the above works.

(as a side note, I also don't get any sound when using ASIO4ALL in Sibelius 6 or Ableton Live Lite 8. But I get sound with any of the other outputs above for either program.)

In my Device Manager, I have the following devices listed under Sound, Video, and Audio Controllers:
- IDT HIgh Definition Audio CODEC
- Intel(R) High Definition Audio HDMI

They are all up-to-date.

Thinking it could be a compatibility issue with the latest version, I uninstalled 3.22, downloaded 3.21 and repeated all the above steps, with no luck. I then uninstalled the program again, downloaded the 32-bit version, and repeated all of the above steps once more. Still nothing.

I can't figure out why the same settings work in Sibelius and Live but not Reaper. Are there other settings I'll need to look at other than those in Preferences > Audio > Devices ?

Perhaps it's a Windows 7 issue...I don't know really know my way around the system yet. I did notice that the volume control now has options for individual programs, but I checked those and the ones for Reaper aren't muted or set at zero.

I've been asking on the IRC help channel, but it seems like no one knows what's going on.

It's incredibly frustrating...this seems like a great program, but I'm stuck on this seemingly simple issue and I can't do anything because I can't hear anything. I've spent over 20 hours "evaluating" the program, and the only feature I've gotten around to evaluating is the preferences dialog.
Are you sure there is no other media application or website opened? I know it sounds dumb and irrelevant, but Reaper will not play audio if something like iTunes/Media Player, or even Youtube is up in your browser..I don't think its an issue with 7..people have reported using 7 with Reaper and it is flawless (Probably the best suited).

However, your sound settings seem kind of peculiar..I currently have a laptop setup too. And out of curiosity, I unplugged my interface and monitors to test and see if Reaper would play back through the shitty built in speakers (Configured for doing so) and it worked...this puzzles me.

I would check all essentials..make sure no mute/solo buttons are active on the tracks, try plugging in outboard speakers, etc.
__________________
3.4 GhZ Quad Core PC, Windows 7 64-bit, 10GB RAM, 2TB hdd space, 24" BenQ monitor, Line 6 UX2 Interface, Behringer MS40 studio monitors, many mics, many plugins, endless supply of Capri Sun and melancholy.
ChaseEversole is offline   Reply With Quote
Old 02-10-2010, 07:24 PM   #4
bucolic
Human being with feelings
 
Join Date: Feb 2010
Posts: 3
Default

Thanks for your help, ChaseEversole.

I tried your suggestion and started terminating all other audio-related processes. That didn't seem to do anything, but halfway through I figured out what the problem actually was.

I had been following the tutorial and loading the demo file All Through the Night. It turns out the file was preconfigured with master output set to Channel 7 / Channel 8, which doesn't exist on my system. I didn't know that was possible...I thought the only place to specify your output device was in the preferences, and that it would have to come out of that device. So I had been looking in the wrong place all this time.

After changing it to Left Output / Right Output, it worked perfectly. Now I can start trying the rest of the program out.
bucolic is offline   Reply With Quote
Old 02-10-2010, 07:27 PM   #5
ChaseEversole
Human being with feelings
 
ChaseEversole's Avatar
 
Join Date: Jan 2010
Location: Indiana
Posts: 415
Default

Quote:
Originally Posted by bucolic View Post
Thanks for your help, ChaseEversole.

I tried your suggestion and started terminating all other audio-related processes. That didn't seem to do anything, but halfway through I figured out what the problem actually was.

I had been following the tutorial and loading the demo file All Through the Night. It turns out the file was preconfigured with master output set to Channel 7 / Channel 8, which doesn't exist on my system. I didn't know that was possible...I thought the only place to specify your output device was in the preferences, and that it would have to come out of that device. So I had been looking in the wrong place all this time.

After changing it to Left Output / Right Output, it worked perfectly. Now I can start trying the rest of the program out.
You'll love it, I'm sure . Reaper has served us all well, and welcome to the boards, Btw.
__________________
3.4 GhZ Quad Core PC, Windows 7 64-bit, 10GB RAM, 2TB hdd space, 24" BenQ monitor, Line 6 UX2 Interface, Behringer MS40 studio monitors, many mics, many plugins, endless supply of Capri Sun and melancholy.
ChaseEversole is offline   Reply With Quote
Reply

Tags
no sound, windows 7

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.