PDA

View Full Version : Mixes sound very different after exporting from Reaper


ugly_guitar_guy
03-09-2009, 09:45 AM
Hello,

I've been using reaper for over a year now and have only recently been delving seriously into getting full songs recorded )instead of just keeping track of new song ideas) since I finally have the plugins to make life easier for me to record (Amplitube, EZDrummer, Melodyne, to name a few).

Now, my problem that I seem to be running into is that I'll get my song all mixed in Reaper and the whole thing sounds balanced and great and then I'll render a wav file of the project and play it in Media Player or iTunes or even my car and they all sound like complete crap. There's always too much reverb, the vocals are way low in the mix, and the mix as a whole sounds like someone put a blanket over the speaker, when it was crystal clear before. Any thoughts on what I'm experiencing here? Thanks!

stupeT
03-09-2009, 10:06 AM
Hmmm... what WAV version do you use? I mean bitdepth and samplerate...

ugly_guitar_guy
03-09-2009, 10:09 AM
Hmmm... what WAV version do you use? I mean bitdepth and samplerate...


bit depth is 24, sample rate is 48k. I usually render on the "Better" Resample mode.

audioguytodd
03-09-2009, 10:10 AM
Are you using studio reference monitors???

ugly_guitar_guy
03-09-2009, 10:20 AM
sadly no. I'm using Roland MA-8's because that's all I have the room for. But even so, I'm able to get a great sound with them IN Reaper, but not out of Reaper...

stupeT
03-09-2009, 10:29 AM
bit depth is 24, sample rate is 48k. I usually render on the "Better" Resample mode.


How can you listen to a 24bit/48k WAV file in your car?

ugly_guitar_guy
03-09-2009, 10:36 AM
well, i put the song into my ipod because my truck has an ipod harness (not just the 1/8" cable) and check how it sounds there too. Should I try something less like 16 bit, 44.1k? Would that make a difference?

billybk1
03-09-2009, 10:51 AM
It is not REAPER that is the issue but more likely it is the environment that you are mixing in. A properly treated room and/or a eq'd room for flat freq response & good well placed reference monitor speakers will go a long way to getting your mixes to translate well to a variety of listening settings (boombox, home stereo, car stereo, etc.).
Baring that you will have do a lot of extra work and make notes about what is pronounced/lacking in your mixes when listening to them in various environments and then go back to your mix and make any changes in REAPER and re-render. Then go back, listen again and repeat as many times as necessary.


Cheers,

Billy Buck

ugly_guitar_guy
03-09-2009, 11:02 AM
It is not REAPER that is the issue but more likely it is the environment that you are mixing in. A properly treated room and/or a eq'd room for flat freq response & good well placed reference monitor speakers will go a long way to getting your mixes to translate well to a variety of listening settings (boombox, home stereo, car stereo, etc.).
Baring that you will have do a lot of extra work and make notes about what is pronounced/lacking in your mixes when listening to them in various environments and then go back to your mix and make any changes in REAPER and re-render. Then go back, listen again and repeat as many times as necessary.


Cheers,

Billy Buck


Yeah, this is kind of what I figured would be what i would need to do since I can't really get better speakers or acoustically treat the bedroom (where my computer is). I guess I just don't understand why the mix comes out differently when using the same speakers but only the playback program changes. Shouldn't the mix that I'm hearing out of reaper accurately translate to itunes or Win Media Player? Perhaps I'm missing a concept here or something....

Bubbagump
03-09-2009, 11:11 AM
sadly no. I'm using Roland MA-8's because that's all I have the room for. But even so, I'm able to get a great sound with them IN Reaper, but not out of Reaper...

Those aren;t worth mixing on... I spent a miserable summer about 8 years ago trying to mix on a pair of those and they simply don't have the detail necessary to give you a good idea as to what is going on. What you are describing sounds like my experience... everything was poo on other systems.

audioguytodd
03-09-2009, 11:14 AM
Yeah, but it SHOULD sound the same on the same speakers and the same environment. I don't think the speakers/room are the problem (although they will cause other problems).

There should be no difference in the sound of the same file being played in reaper and windows media player.

Jonas_Eriksson_Swe
03-09-2009, 12:07 PM
I guess I just don't understand why the mix comes out differently when using the same speakers but only the playback program changes. Shouldn't the mix that I'm hearing out of reaper accurately translate to itunes or Win Media Player? Perhaps I'm missing a concept here or something....

No you're right, but try this:

1. Open a project that sounds good when played back in Reaper, turn off any fx on the master track (if any) and set the master fader to zero
2. Render it to a wav-file
3. Return to the project and add a new track
4. Insert the newly rendered file on this track and flip its phase switch

Hit play and you shouldn't be hearing anything. (Since the rendered file with flipped phase should cancel all the other tracks.) If you do hear stuff there's sth funny going on...

Regards,
- Jonas

Jim Roseberry
03-09-2009, 12:28 PM
Yeah, this is kind of what I figured would be what i would need to do since I can't really get better speakers or acoustically treat the bedroom (where my computer is). I guess I just don't understand why the mix comes out differently when using the same speakers but only the playback program changes. Shouldn't the mix that I'm hearing out of reaper accurately translate to itunes or Win Media Player? Perhaps I'm missing a concept here or something....


You're tweaking the mix to sound good on inaccurate monitors.
So... it sounds good while listening to those speakers.
But... because the monitors are inaccurate, the tweaks you make don't sound good when played on other systems.

This is why you don't want studio monitors to sound "good"... but rather they need to provide an "accurate" representation of the sound.
Otherwise, you're chasing your tail when mixing...

If you have no choice but to use those speakers, you need to learn their limitations... and check your mixes on multiple playback systems (making tweaks as you go). Also, it'll help to reference some commercial mixes that you're really familiar with (in similar style) to see how far off your mixes sound. Try to get your mix in the same sonic ballpark as the commercial mix.
If your mix is radically different in any frequency zone (low, mids, high)... then you need to make some adjustments.


Jim Roseberry
www.studiocat.com
jim@studiocat.com

nprime
03-09-2009, 12:52 PM
Maybe I'm the only one reading the OP's post this way, but it seems to me that he is saying that the exported mix sounds bad ON THE SAME SPEAKERS, as well as elsewhere.

The mix not travelling well I would blame on inaccurate monitors in an untreated room, definitely. However, the exported mix should sound the same on the same speakers.

Must be something about the export settings.

adouglas
03-09-2009, 12:56 PM
I've encountered the exact same thing. It's a huge hurdle for the poor uninformed newb.

You're putting this stuff on your iPod? Do you have EQ engaged on your iPod? On your car stereo?

Set everything flat on all systems.

A few things that have helped me tremendously (I'm still learning):

1) LESS IS MORE. Reduce the number of fx per track, and reduce the extremity of those fx.

2) Use fx busses, especially for reverb, instead of individual FX on each track. I had been adding reverb to each vocal track. Now I route all the individual vocal tracks through a master vocal track and apply reverb only to that.

3) Consider trying out a mastering suite. I tried iZotope Ozone and it made such a huge difference for me that I bought it. I don't want to launch a "presets" argument, but I STARTED with the "CD Master" preset and then tweaked it until I got what sounded good to me. This group of settings sounds very plain and dry compared to some of the stuff in Ozone, but when you burn your CD you'll find it works better than the "fruitier" settings.

Most experienced people here will tell you that presets are worthless. I agree in principle, but only in the sense that if you pick a preset and rely entirely on it without ever going beyond those settings, you won't get optimum results. I do, however, think that they make a good STARTING point. I think of them as "advice," such as that provided in tutorial books, not "magic bullets."

4) Consider buying the ReaMix book (http://www.lulu.com/content/2539885). I just picked this up and look forward to learning a lot from it.

Jim Roseberry
03-09-2009, 01:02 PM
Maybe I'm the only one reading the OP's post this way, but it seems to me that he is saying that the exported mix sounds bad ON THE SAME SPEAKERS, as well as elsewhere.

The mix not travelling well I would blame on inaccurate monitors in an untreated room, definitely. However, the exported mix should sound the same on the same speakers.

Must be something about the export settings.

Sample-rate conversion???

@OP: What happens if you capture Reaper's playback to a Wav file in realtime?
(Instead of using the offline bounce-down)

Jim Roseberry
www.studiocat.com
jim@studiocat.com

spikemullings
03-09-2009, 01:33 PM
I have certainly experienced what you are talking about before I got reasonable (although budget) monitors.

But like people have been saying, it seems you are getting these results through the same speakers in the same room.

So the question must be, what can cause you to hear the vox (and I guess the top end) so loud when mixing, that it is underplayed when rendered, and to unknowingly hype up the reverb so that it is so prominent after render?

You are not accidentally mixing in mono are you? Maybe have the mono button on the master engaged? I could see that in terms of the reverb, not so sure about the vox though.

Sorry if that is a stupid suggestion but you did say "any" thoughts. ;)

Maybe a screenshot of your mixer would be revelatory . . .

ugly_guitar_guy
03-09-2009, 01:53 PM
Maybe I'm the only one reading the OP's post this way, but it seems to me that he is saying that the exported mix sounds bad ON THE SAME SPEAKERS, as well as elsewhere.

The mix not travelling well I would blame on inaccurate monitors in an untreated room, definitely. However, the exported mix should sound the same on the same speakers.

Must be something about the export settings.

Yes, this is correct. It sounds completely different played back on Media Player or iTunes on the SAME speakers, even though it sounds great in Reaper. I understand that the monitors that I have aren't that great, but I would hate to be in a situation where I get different monitors just to end up with the same problem in the end. I'll post a pic of my export screen when I get home and see if there's something that you guys might catch that I am missing.

ugly_guitar_guy
03-09-2009, 02:02 PM
I have certainly experienced what you are talking about before I got reasonable (although budget) monitors.

But like people have been saying, it seems you are getting these results through the same speakers in the same room.

So the question must be, what can cause you to hear the vox (and I guess the top end) so loud when mixing, that it is underplayed when rendered, and to unknowingly hype up the reverb so that it is so prominent after render?

You are not accidentally mixing in mono are you? Maybe have the mono button on the master engaged? I could see that in terms of the reverb, not so sure about the vox though.

Sorry if that is a stupid suggestion but you did say "any" thoughts. ;)

Maybe a screenshot of your mixer would be revelatory . . .

No, it's definitely in stereo because all of the panning is there. I'll post some screen shots tonight when I get home...

Jonas_Eriksson_Swe
03-09-2009, 02:15 PM
I hate to repeat myself (no I don't : ) but:

(...) try this:

1. Open a project that sounds good when played back in Reaper, turn off any fx on the master track (if any) and set the master fader to zero
2. Render it to a wav-file
3. Return to the project and add a new track
4. Insert the newly rendered file on this track and flip its phase switch

Hit play and you shouldn't be hearing anything. (Since the rendered file with flipped phase should cancel all the other tracks.) If you do hear stuff there's sth funny going on...

Try this and we'll know if it's Reaper or not. Regards,
- Jonas

Pembo
03-09-2009, 02:18 PM
Well there's a couple of things I can think of that might change it so drastically.

One, check if there's any overall EQ affecting the song in iTunes or Windows Media Player.

Two, in REAPER, open the routing matrix (View > Show Routing Matrix or Alt+R).
There could be a track (vocals perhaps) that is routed to go to the speakers our AS WELL AS the master track. This would cause vocals to be louder in REAPER and not be rendered.
I don't think there should be anything going to the speakers (which should be listed along the top of the matrix) apart from your master track.

Hope you sort it out soon,
Pembo.

ugly_guitar_guy
03-09-2009, 02:49 PM
I hate to repeat myself (no I don't : ) but:



Try this and we'll know if it's Reaper or not. Regards,
- Jonas

Yup, I'll give that a shot as well...

dub3000
03-09-2009, 04:27 PM
this comes up every now and then and i think is stickied in the forum somewhere.

things to check:

1. check your routing setup. if you're routing directly to a soundcard output anything going there WON'T GET RENDERED. everything has to go to the master channel to get rendered.
2. itunes and wmp both do "sound enhancement" by default. make sure it's turned off. if in doubt, make a new empty session in reaper with no effects and drag the file in there.
3. you probably want to be targeting 44kHz, 16bit unless you really know what you're doing.

ugly_guitar_guy
03-09-2009, 10:24 PM
No you're right, but try this:

1. Open a project that sounds good when played back in Reaper, turn off any fx on the master track (if any) and set the master fader to zero
2. Render it to a wav-file
3. Return to the project and add a new track
4. Insert the newly rendered file on this track and flip its phase switch

Hit play and you shouldn't be hearing anything. (Since the rendered file with flipped phase should cancel all the other tracks.) If you do hear stuff there's sth funny going on...

Regards,
- Jonas

Ok, I did exactly this and when I inverted the phase of the rendered song and played it back with all the individual tracks I still hear everything but in a different mix. The vocals are really loud and everything else is very quiet (except cymbals all seem to be the same volume for some reason). So what might this mean?... I'm such a newb that I dont even know how to troubleshoot this one :S

Edit: Oh, and if I mute the phase inverted track the mix goes back to normal.

schwa
03-09-2009, 10:29 PM
dub3000 probably had it right with his first guess. If your rendered mix doesn't sound like playback, it's usually because something in your project is being improperly routed direct to hardware output.

Most of the time, you want all of your tracks to end up in the master, and only the master track gets routed to hardware output. (There are exceptions, monitor mixes and so on, but they are for specific situations.) You want to hear exactly what you are mixing on the master.

I suggest going through the IO setup for each track and looking for any sends to hardware output, and removing those sends.

LOSER
03-09-2009, 10:30 PM
this comes up every now and then and i think is stickied in the forum somewhere.

things to check:

1. check your routing setup. if you're routing directly to a soundcard output anything going there WON'T GET RENDERED. everything has to go to the master channel to get rendered.
2. itunes and wmp both do "sound enhancement" by default. make sure it's turned off. if in doubt, make a new empty session in reaper with no effects and drag the file in there.


+1 those are the main reasons for those problems.

ugly_guitar_guy
03-09-2009, 11:04 PM
+1 those are the main reasons for those problems.

Well here's my routing matrix:

http://i16.photobucket.com/albums/b27/ugly_guitar_guy/routingmatrix.jpg

I can't find anything that is routed quirky when I look through track by track...

moliere
03-10-2009, 02:33 AM
whats your audio interface? My presonus firestudio can get a bit funny with multiple outputs (set via the separate presonus interface control panel). I can get weird phasing when I have certain options selected, where its kinda mixing a delayed signal with itself.

what drivers are you using? is reaper using asio and your other players using direct sound? can you switch reaper to what your other players are using and see if that affects it (better/worse)?

*edit*

am I missing something, or shouldn't your tracks all have the master/parent box selected? the vertical column on the far left? and the master output should be set to one of your soundcard outs on the far right?

j79
03-10-2009, 03:37 AM
something definately is setup wrong in your routing matrix. you shouldnt be able to hear anything the way it is, and the meter in your master channel shouldnt show any activity as you arent sending anything to the master...and i am also puzzled that you get any sound at all in exported files. unless i missed something obviously...

is your master meter moving, and do you export via render or bounce?

dub3000
03-10-2009, 04:11 AM
no, it looks alright- i think the highlight colour is very close to the background colour though.

dub3000
03-10-2009, 04:12 AM
is it possible one of your plugins is freaking out on render? what happens if you do a live 1x speed render?

ugly_guitar_guy
03-10-2009, 09:48 AM
whats your audio interface? My presonus firestudio can get a bit funny with multiple outputs (set via the separate presonus interface control panel). I can get weird phasing when I have certain options selected, where its kinda mixing a delayed signal with itself.

what drivers are you using? is reaper using asio and your other players using direct sound? can you switch reaper to what your other players are using and see if that affects it (better/worse)?

*edit*

am I missing something, or shouldn't your tracks all have the master/parent box selected? the vertical column on the far left? and the master output should be set to one of your soundcard outs on the far right?

I'm using an Edirol M-16DX using ASIO drivers. Now, I just spoke with a friend this morning that has more experience with recording in general than I do, and in talking to him I realized that Reaper is playing back through the M-16DX, but Media Player and iTunes are playing through the computer sound card, so that explains the difference in overall sound issues there, which point back to my crappy monitors being the reason that the mix doesn't translate well to other audio systems...

BUT...

That still doesn't answer the phase cancel experiment and why the exported track is obviously not what it is "supposed" to be.

I'll switch the computer settings tonight so that the M-16DX is the main sound card for the computer and that should solve the issue of differences with sound inside the same computer.

I'll also try the real-time 1x render tonight and see what happens when I do that. Would any other screen shots help you guys?

dub3000
03-10-2009, 02:20 PM
i'm not sure if that phase cancel experiment will work if you have anything on your master bus

my current bet is one of your plugins doesn't like being run in full-speed render mode. this can happen with some synthedit plugins apparently.

the other thing to check: import the render into a new blank reaper session and listen to it there. does it sound alright if you do that?

ugly_guitar_guy
03-12-2009, 11:55 AM
i'm not sure if that phase cancel experiment will work if you have anything on your master bus

my current bet is one of your plugins doesn't like being run in full-speed render mode. this can happen with some synthedit plugins apparently.

the other thing to check: import the render into a new blank reaper session and listen to it there. does it sound alright if you do that?

Well the only VSTi I'm using is EZDrummer. Now, when I started this new project I loaded in the track template that I got from someone that had posted their templates here on the forum (same one thats on the resource page I believe). Is it possible that there's something hidden in that track template that is causing this issue.

Yes, if I render anything out of reaper and then put it back into reaper it sounds the same as the original recording project.

Thanks for all your suggestions guys. I think I'm just gonna have to deal with eq issues until I can get some better monitors and pre's to record with. I'm sure now that's ultimately the issue.

Sheppola
03-12-2009, 12:10 PM
Getting a mix to,"Sit" right on most playback devices is one of the hardest parts of recording.All the professional studios I've had the good fortune to record in had a 3 way monitor system which they switched between.Studio class monitors,Hi-Fi speakers and usually a couple of small speakers made out of small transistor radios.When they get the mix to sound good on all three they know they have done a good job.

My 10 penn'th :)

jackdied
03-12-2009, 05:36 PM
When i use "Drumatic 3" vsti in a project i get same result. I dont know why.

dub3000
03-12-2009, 06:07 PM
silly question, maybe: are you using the most recent version of EZDrummer?

dub3000
03-12-2009, 06:07 PM
When i use "Drumatic 3" vsti in a project i get same result. I dont know why.

i think drumatic is a synthedit plugin - some of these are known to have problems in renders on some systems (seems to be fine for me, though)

Coerce
03-12-2009, 07:49 PM
This is how i render my mixes :

Create a new track and label it with the name of your song

Arm it for record

Right click on the meter and select record stereo output (you can also choose latency compensated).

ALT + R to the routing matrix and untick the master output on all your tracks (except the new one) and then send all the outputs to your new track.

Solo your new track and chck everything is playing, if it isn't you've not set up a send correctly.

Go to the start of the session, hit record and reaper will record your track in realtime in to the new track.

After you've saved it, open the new wav file of your song in to a different program and convert it to the format of your choice. I personally use adobe audition.

For me this gives the most accurate mix rather than rending it down and also give me the chance to tweak it in audition after and tidy up the start end fade and over all level.

Lawrence
03-12-2009, 08:01 PM
sadly no. I'm using Roland MA-8's because that's all I have the room for. But even so, I'm able to get a great sound with them IN Reaper, but not out of Reaper...

Translation. Number one issue of home studio mixes.

At the habit of repeating myself (or others speaking of acoustic treatment, etc which is the best way)... the least expensive way to improve translation from a bad room is to listen to CD's there. A lot.

What happens is that you compensate for the deficienies of the room when you mix to the sound you want in your head. But as you see when you play it elsewhere, that sound isn't really there.

So you have to treat the room (best way) and/or create a new image of that room sound in your brain. Probably a little of both.

gavriloP
03-13-2009, 01:59 AM
Of course the sound should be same with same monitors and same PC, no matter what. There is slight change in sound if you use media player that uses directsound etc. but it is very small unless there are some freaky settings going on. You should use foobar2000 http://www.foobar2000.org/ because it can use ASIO drivers and then the sound should be 100% same as in reaper.

If the rendered song sounds the same in new empty reaper project (not a template with something already in) then it should also sound the same in foobar.

Youn
03-13-2009, 06:46 AM
have you tried the following:
- pre-rendering your vstis
- Save live output to disk (I know it's been mentioned before)
- match your "render" settings with your "project settings"
- upload your .rpp project file here for others to look at, many of us are more then welcome to take a peek (no audio data is required, just the single .rpp file)

TheArchitect
03-13-2009, 07:21 AM
Hello,

I've been using reaper for over a year now and have only recently been delving seriously into getting full songs recorded )instead of just keeping track of new song ideas) since I finally have the plugins to make life easier for me to record (Amplitube, EZDrummer, Melodyne, to name a few).

Now, my problem that I seem to be running into is that I'll get my song all mixed in Reaper and the whole thing sounds balanced and great and then I'll render a wav file of the project and play it in Media Player or iTunes or even my car and they all sound like complete crap. There's always too much reverb, the vocals are way low in the mix, and the mix as a whole sounds like someone put a blanket over the speaker, when it was crystal clear before. Any thoughts on what I'm experiencing here? Thanks!
Sounds like your mix room could use some acoustical treatment. That far and away the most common problem when mixes don't translate well

TheArchitect
03-13-2009, 07:25 AM
Maybe I'm the only one reading the OP's post this way, but it seems to me that he is saying that the exported mix sounds bad ON THE SAME SPEAKERS, as well as elsewhere.

The mix not travelling well I would blame on inaccurate monitors in an untreated room, definitely. However, the exported mix should sound the same on the same speakers.

Must be something about the export settings.

I agree, but iTunes and WMP are notorious for the various EQ's etc that come turned on by default. Make sure all ofthat nonsense is turned off if you are going to play a mix with them.

TheArchitect
03-13-2009, 07:33 AM
This is how i render my mixes :

Create a new track and label it with the name of your song

Arm it for record

Right click on the meter and select record stereo output (you can also choose latency compensated).

ALT + R to the routing matrix and untick the master output on all your tracks (except the new one) and then send all the outputs to your new track.

Solo your new track and chck everything is playing, if it isn't you've not set up a send correctly.

Go to the start of the session, hit record and reaper will record your track in realtime in to the new track.



Why is all that necessary? A real time render would get you same result with a lot less complexity and potential for error.

Coerce
03-20-2009, 04:17 AM
It's the wy I feel comfortable doing it. I can see the file being rendered and hear it at the same time giving me one last listen to correct any mistakes that I find in the mix on the final print.

Sometimes I'll send it out and back in through a couple of pre's as well for some flavour but that's a different story

Piotr
03-20-2009, 08:08 AM
Jeez can't you people read? The guy is talkin about listening to the mix in the same set up. How could the room or speakers have anything to do with that when the same audio interface, power amp and speakers are being used?

*lol*

To thread starter, you said you used "better" for SRC.. use the best. Also check so taht you are using dither when going from 24 > 16 bit (if you do that) otherwise you will have quantization distortion.

I have had some unpleasant moments with reaper when using realtime SRC and using default settings. The audio sounded broken until I changed to best possible (allthough the highest resolution can not be used in realtime).


/Peter

JonnyHomes
01-06-2010, 02:22 PM
Maybe I'm the only one reading the OP's post this way, but it seems to me that he is saying that the exported mix sounds bad ON THE SAME SPEAKERS, as well as elsewhere.


That's what I'm reading too...

I found this post because I'm now experiencing a similar problem. My mix sounds perfect when I play it in Reaper but after I render it, it's all screwed up. The volume is lower and I'm getting clips! I've tried rendering with a few different settings and I can't seem to get rid of this problem. Quite frustrating...

dub3000
01-06-2010, 02:58 PM
That's what I'm reading too...

I found this post because I'm now experiencing a similar problem. My mix sounds perfect when I play it in Reaper but after I render it, it's all screwed up. The volume is lower and I'm getting clips! I've tried rendering with a few different settings and I can't seem to get rid of this problem. Quite frustrating...

what are you monitoring through? what format are you exporting to?

exporting to mp3 WILL mess with stuff (and will introduce clipping if you're too close to full scale). does exporting to 16 bit WAV w/ dither export cleanly?

monitoring through some programs (e.g. iTunes) WILL mess with your sound if you have any of the sound processing options turned on, and many sound interfaces will try and do their own processing when you're using waveout. what happens if you re-import the file back into a new reaper session?

JonnyHomes
01-06-2010, 03:08 PM
what are you monitoring through? what format are you exporting to?

1. KRK 5 Monitors & ATH-M50 Headphones.

2. I'm rendering my 24/96 project to 16/44 WAV --- I have the dither & noise shaping boxes checked (I didn't the first time and it was even worse.)

---

I haven't tried re-importing it yet... I'll check that out now...

OK, when I re-import it I'm still getting some distortions that aren't in the original... I guess I should expect some degradation of the sound but it's really quite bad.

Are there any best practices on how to render to 16/44 WAV for best results? I'm looking through Reaper Power and can't seem to find anything there on this subject.

mr. moon
01-06-2010, 03:13 PM
what format are you exporting to?



Not only is the format a concern, but sample rate and bit depth are as well, especially with FX. I work at 96K 24-bit, and if I render directly to 44.1K 16-bit, the FX get all funked up and the mix goes to h3ll. To circumvent this, I render to 96K 32-bit float, which locks in the sound of the FX, and then do my sample rate and bit depth converting after that.

Don't know if this will help, but I hope so...

Good luck!

mr. moon
01-06-2010, 03:14 PM
2. I'm rendering my 24/96 project to 16/44 WAV --- I have the dither & noise shaping boxes checked (I didn't the first time and it was even worse.)



Hah!! I hit the nail on the head!!

Read my post above!!!

JonnyHomes
01-06-2010, 03:15 PM
Not only is the format a concern, but sample rate and bit depth are as well, especially with FX. I work at 96K 24-bit, and if I render directly to 44.1K 16-bit, the FX get all funked up and the mix goes to h3ll. To circumvent this, I render to 96K 32-bit float, which locks in the sound of the FX, and then do my sample rate and bit depth converting after that.

Nice to see I'm not the only one experiencing this problem with rendering to 44.1/16 ... but even nicer to see that there appears to be a work around! I'll try out your solution now.

dub3000
01-06-2010, 03:20 PM
Nice to see I'm not the only one experiencing this problem with rendering to 44.1/16 ... but even nicer to see that there appears to be a work around! I'll try out your solution now.

you might be using a plugin that doesn't handle switched sample rates properly. there's an easy way around this: in the render dialog, if you're targeting 44kHz, try selecting the "use project samplerate for mixing and FX/synth processing" checkbox. if this isn't selected, close the render window, hit alt-enter and set the project samplerate checkbox/rate in there to your native rate (96khz), then try the render thing again.

also, don't run *too* hot. all sample rate conversions involve a filter/eq step (this isn't reaper specific, this is any kind of sample rate conversion), and this will change the level of your track a bit. e.g. try limiting at -0.5dB, not -0.01dB. and make sure you're using the "best" render resample mode.

you shouldn't lose any audible quality when you render if you're doing that stuff right.

edit: or just do what mr. moon says. end result should be the same.

mr. moon
01-06-2010, 03:31 PM
Nice to see I'm not the only one experiencing this problem with rendering to 44.1/16 ... but even nicer to see that there appears to be a work around! I'll try out your solution now.

What you're hearing is the difference of the FX at 96k and 44.1k. If you render to 96k 32-bit float, you will render the FX as they sound at 96K.

This is not so much a "problem" which requires a fix, but more of a demonstration of how different FX sound at 96K vs. 44.1K.

If you search the forum here for posts started by "mr. moon", you'll find the thread that I posted about this a couple years or so ago about it. Even Justin joined in on it!

EDIT: Actually, I was thinking of a different thread about another issue right around the same time. With the 96K -> 44.1K issue, we exchanged PMs about it and such as well as with the Voxengo developer.

;)

unsound
01-06-2010, 04:09 PM
That's what I'm reading too...

I found this post because I'm now experiencing a similar problem. My mix sounds perfect when I play it in Reaper but after I render it, it's all screwed up. The volume is lower and I'm getting clips! I've tried rendering with a few different settings and I can't seem to get rid of this problem. Quite frustrating...

Same problem here, just the past couple of days I have been trying to finish up a project and everything has been fine. But the last couple of times I have rendered their songs (7 songs) 2 of them came out really different than the last listen of the mix......vocals and bass are both clipping and when I go to the wav file in media explorer in Reaper you can't even listen to the song........the settings are all the same across all songs, each in their own project but I have went thru and made damn sure all settings are identical, in project settings and routing.

Another thing.........I will save the project, render the file, see it clip during render then when it is done play the project again and the mix that I just saved is all messed up and clipping....?????? I then open the project that I just saved and rendered and everything is fine. Try to render it again and the same thing happens........

If I have something set up different on these 2 project I can't for the life of me find it.....

-scott

mr. moon
01-06-2010, 04:19 PM
Same problem here, just the past couple of days I have been trying to finish up a project and everything has been fine. But the last couple of times I have rendered their songs (7 songs) 2 of them came out really different than the last listen of the mix......vocals and bass are both clipping and when I go to the wav file in media explorer in Reaper you can't even listen to the song........the settings are all the same across all songs, each in their own project but I have went thru and made damn sure all settings are identical, in project settings and routing.

Another thing.........I will save the project, render the file, see it clip during render then when it is done play the project again and the mix that I just saved is all messed up and clipping....?????? I then open the project that I just saved and rendered and everything is fine. Try to render it again and the same thing happens........

If I have something set up different on these 2 project I can't for the life of me find it.....

-scott

Sample rate?

toyhouse
01-06-2010, 04:29 PM
Something very similar happened to me on a macbook last year.
After rendering, (not in real time), reverb was ten times where is was in the mix. Way over the top.
It was a convolution rev, (reaverb),.
For the record; I had the poor macbook really loaded down!

I haven't been able to replicate the problem again either.
I don't generally work that way, lol.

The only thing I could figure was that the efx weren't being produced correctly during mixing playback simply due to processor overload.
Is that even possible?


Jim P.




.

unsound
01-06-2010, 06:10 PM
Sample rate?

48 at 24 rendered to 44 at 16

and also as I said after I render to wav the very same project that I just rendered is messed up and I can't seem to fix it other than reopening the previously saved project.

My workaround was to save live output to disk...........worked but didn't solve the original problem....

-scott

capthook
01-06-2010, 06:48 PM
3 things about sound out of I-tunes:

1) Sound enhancements: as has been mentioned - If this is on will obviously change the sound (I always have off - don't like it)

2) EQ: I usually have EQ set to drop the upper highs as to take the out 'phasy' sound of many .mp3's (especially low bit ones). Again, if on, will obviously change the sound

3) Sound Check: often overlooked. This levels the volume on all songs in your library so they are about equal in volume.
This feature can greatly change the sound.

So to listen to my Reaper produced .mp3 in Itunes, for it to sound like the original, I needed to turn of EQ and Sound Check.

Also try checking it in Audacity (with no settings)... seems to sound more like the original project sound than Itunes.

I did numerous renders of my 24bit 44.1 audio/project:
24 bit to 16 bit in project
24 bit render then drop that file into Reaper for a render to 16 bit
mp3 render from project
mp3 render from 24 bit and 16 bit file rendered files
others.....

Then A/B'd them in SPAN and listened.
No noticable difference in SPAN or to my ears.

So in my tests, it is the player and/or it's settings that is changing the sound rather the output from Reaper.

Now... all that said....

Note: audio device settings in Reaper

My once top-of-the-line computer is 5 yrs old... so with numerous VSTi/VST it bogs down easy.
ASIO of all flavors sucks for me during playback/mixing/editing etc.
(I record everything with ASIO drivers though)
So I use *WaveOut* as my audio device for everything except recording.

One thing I have noticed with ASIO when using it though:
The sound seems overly hyped - louder and brighter mostly compared to the WaveOut driver.
So when a song is rendered from an project mixed with ASIO as the playback device.... it *DOES* sound different than the project IMO.

mr. moon
01-06-2010, 07:28 PM
48 at 24 rendered to 44 at 16

and also as I said after I render to wav the very same project that I just rendered is messed up and I can't seem to fix it other than reopening the previously saved project.

My workaround was to save live output to disk...........worked but didn't solve the original problem....

-scott

Render to 48/24 in reaper to a stereo file. Then using either reaper or an audio editor (i.e. soundforge, etc.) "master" the file down to 44.1/16 making sure to dither at the last step.

There are tons of rendering/dithering threads to choose from around here that will give you the step by step in more detail.

JonnyHomes
01-06-2010, 07:53 PM
OK, I was finally able to get rid of the glitches... I rendered as a 96/24 wav (to match my project settings) and then opened that wav up in Sound Forge where I used the dithering process to go from 24 bit to 16 bit. I then saved it as a 44/16 wav and that worked.

J Kennedy
01-06-2010, 07:55 PM
Glad this issue is back on the front page so people can get some input toward solving it. Iíve never had much luck rendering with the final wave sounding like the open project. Effects are changed (reverbs especially) and can go anywhere from too much to almost no processing. Other parameters altered are volume and sometimes eq. Often, only certain tracks in a mix come out different, so itís not just a global problem. This is something aside from sample rate or rendering quality choices.

There is a second Reaper based studio in the area here and the musician is struggling with the same issues. Iíll have to comb through the routings and look at Schwa and Dubís advice on this also.

At least there is the live bounce to disc option that does record everything accurately and true to the open project. I only do a few songs at a time so this isnít a big inconvenience. If you have several hours of material, having to bounce in real time could be a problem.

John

dub3000
01-06-2010, 08:10 PM
OK, I was finally able to get rid of the glitches... I rendered as a 96/24 wav (to match my project settings) and then opened that wav up in Sound Forge where I used the dithering process to go from 24 bit to 16 bit. I then saved it as a 44/16 wav and that worked.

and...

Glad this issue is back on the front page so people can get some input toward solving it.

again, this probably isn't a reaper problem, it's a plugin problem. i've seen plugins that behave totally differently depending on the sample rate - not always "wrong", just inconsistently. bootsy's plugins are known to do this, as are a lot of older synthedit plugs - they're just WEIRD at high sample rates. if you get the sound right at a high sample rate, then render at a low sample rate, it's all gonna turn to crap.

render at the native sample rate, either directly or via the checkbox workaround i posted a few posts ago, and make sure you do your final check with neutral software (e.g. re-importing to reaper into a new session at the correct sample rate).

OR, you can just work at the target sample rate (44khz for audio, 48khz for video) the whole time, which is probably better for most people really.

mr. moon
01-06-2010, 08:27 PM
and...

again, this probably isn't a reaper problem, it's a plugin problem.

It is not a plugin problem *or* a REAPER problem. As I have had it explained and simplified for me, it's just a fact that certain plugins (especially things like delays, reverbs, etc. modulation effects) sound better at higher sample rates and bit depths due to the higher resolution. If you want your rendered file to sound like the multitrack version of it does, you have to render it at the same sample rate and bit depth as your multitrack is set at.

Rock on!

J Kennedy
01-06-2010, 08:28 PM
Dub,

You’re probably right since this would explain how some tracks are affected and others not. At least direct bounce records everything in real time exactly as it sounds, requiring at most trimming some silence off the ends.

John

Mr Moon,

I've had the problem with everything equal and tried at different sampling rates without success. I used to use PowerTracks and had much worse problems rendering vsti's. Real time recording to disc was the only option. Will have to revisit all this when I can get back to a civilized computer.

unsound
01-06-2010, 08:34 PM
Render to 48/24 in reaper to a stereo file. Then using either reaper or an audio editor (i.e. soundforge, etc.) "master" the file down to 44.1/16 making sure to dither at the last step.

There are tons of rendering/dithering threads to choose from around here that will give you the step by step in more detail.

I'll try that as soon as I can back to the studio....but I've been doing this for a while with no problems and other songs with the same project, sample rate, dither and any other settings don't have this problem.....
so does it make any sense that my project would be fine until I render, then after rendering the vocals and bass are peaking in the project (just like the rendered wav)but yet none of the levels/faders have changed???.........

mr. moon
01-06-2010, 08:51 PM
Mr Moon,

I've had the problem with everything equal and tried at different sampling rates without success. I used to use PowerTracks and had much worse problems rendering vsti's. Real time recording to disc was the only option. Will have to revisit all this when I can get back to a civilized computer.

I'm not using VSTi's, so that could very well be a different ball of wax altogether.

You might also want to look over your gain-staging into/out of your plugins on the master track if there are any. I've also been told to keep the REAPER master fader at "0" and solo each plugin on the master track to make sure that your not overloading any of them. Also be sure to leave plenty of headroom on the rendered stereo track to leave plenty of space for the mastering/dithering process.

I don't know if any of my babbling will help, but I'm going to keep my eye on this thread to see if I can learn a thing or two!

Dstruct
01-06-2010, 08:51 PM
Never had such problems in my whole daw life. User or plugin error ...

WorldofNoise
01-06-2010, 09:10 PM
I've experienced this issue in multiple hosts. I record using a MOTU 24i, PCI-424 card, 24bit 44.1k in, render down to 16bit 44.1. I do all my mastering in Reaper (or whatever host).

I have experienced this in Reaper, and Sonar 7 & 8.

I want to blame plug ins, bit depth conversion, etc...but I don't get this issue in PT LE or Samplitude.

I also like to think that I'm experienced enough to know if I had a routing problem, etc. I've been at this and on different systems for about 8 years now. However, dumber things have happened. Seeing as how Reaper and Sonar are both 64bit mix engines...could that have something to do with it?

ernesto
01-06-2010, 09:17 PM
I've had problems rendering with NI Battery not playing back the samples as it's suppose to. For example, not changing the pitch if I had it lowered in Battery. The best solution is to do a live bounce as Coerce suggested.

dub3000
01-06-2010, 09:19 PM
It is not a plugin problem *or* a REAPER problem.

Never had such problems in my whole daw life. User or plugin error ...

well... i've actually built plugins for personal use that do exactly this, because i was lazy. if you assume your sample rate is 44100, your filter/eqs and delay times will all be totally wrong. it is totally possible there are lots of "released" plugins that still kinda work but have eq frequencies etc that move to other places when you change the session sample rate.

similar stuff happens in lots of otherwise excellent "proper" plugins - e.g. look at the developer comments in here: http://varietyofsound.wordpress.com/2009/02/04/booteq-mkii-lf-shaping/
that one only supports 48khz and 44khz properly.

mr. moon
01-06-2010, 09:28 PM
well... i've actually built plugins for personal use that do exactly this, because i was lazy. if you assume your sample rate is 44100, your filter/eqs and delay times will all be totally wrong. it is totally possible there are lots of "released" plugins that still kinda work but have eq frequencies etc that move to other places when you change the session sample rate.

similar stuff happens in lots of otherwise excellent "proper" plugins - e.g. look at the developer comments in here: http://varietyofsound.wordpress.com/2009/02/04/booteq-mkii-lf-shaping/
that one only supports 48khz and 44khz properly.

I believe what you're saying, and it makes sense. The one thing I have heard is that even some "great" delays will sound differently due to nothing more than the higher resolution and bit depth. True?

J Kennedy
01-06-2010, 09:31 PM
Dstruct,

Luck has been with you then. I’m sure it’s something I’ve got set wrong or a renegade plug. Last project here was a Christmas album with 4 songs, very simple, a couple vocal tracks, couple guitars and keyboards. The rendered files cut the reverb to almost nothing on the vocals (Reverberate LE at the time). Keyboard tracks were not affected in the render. The only way we got the project out the door was to bounce to disc and cut the ends with Audition before going to CD. This worked well and everyone was happy in the end.

I’ll go thru all the advice brought up here and figure it out. Would posting one of the projects (without wave content) be worth anything? It would illustrate the real problem and maybe the dumb cause.

John

Jeez, you guys are fast replying

toyhouse
01-06-2010, 09:51 PM
Folks here keep mentioning different sample rates involved?
When this anomaly hit me, it was business as usual.
No varying sample rates.
As I stated in my post, the only thing I recall being different was cpu load? Crazy-high.
Maybe I hit some arbitrary limit?
I didn't think about it much at the time.
Since the apple version wasn't that stable, I just assumed it to be par for the course.

Not operator error, lol.

Jim P.



.

dub3000
01-06-2010, 10:08 PM
I believe what you're saying, and it makes sense. The one thing I have heard is that even some "great" delays will sound differently due to nothing more than the higher resolution and bit depth. True?

no way will they sound heaps different - you might get a slightly cleaner high end and circuit emulation plugs might work a little better but nothing night and day. lots of "great" plugins (especially recent ones) will run in an oversampled mode internally anyway, so you don't gain anything by running at a higher session rate.

when you see a plugin that isn't a lookahead compressor or a convolution/fft based tool introducing 4 to 256 samples of delay, that's usually a sign they might oversample internally (although not always).

dub3000
01-06-2010, 10:09 PM
*deleted post - was thinking of a different plugin*

original post was unfairly marking reverberate LE as buggy - the problems i had were with a totally different plugin with a similar name. i haven't used reverberate LE. really sorry about the confusion.

karbomusic
01-06-2010, 10:17 PM
well... i've actually built plugins for personal use that do exactly this, because i was lazy. if you assume your sample rate is 44100, your filter/eqs and delay times will all be totally wrong. it is totally possible there are lots of "released" plugins that still kinda work but have eq frequencies etc that move to other places when you change the session sample rate.

similar stuff happens in lots of otherwise excellent "proper" plugins - e.g. look at the developer comments in here: http://varietyofsound.wordpress.com/2009/02/04/booteq-mkii-lf-shaping/
that one only supports 48khz and 44khz properly.

I typically runaway from the how DAWs sound discussions but since this part of the discussion isn't really aruging about that, I'll share an experience...

On a few occassions I have rendered and the render suddenly has the vocal too loud, guitar too low or something similar. I normally assume it to be my perception, not reality but its odd that I had to render, take notes from that render, make those adjustments to the mix (causing the mix to not sound right), render that and then render sounds correct. Damndest thing...

When it has happened it has jerked my head around to a "what the hell just happened, it was fine 2 minutes ago" moment. If it happens again, I'll drop a realtime and a rendered mix to see if they null. Like I said, being someone who knows DAWs don't sound different, I have had a few renders that raised my eyebrows unexpectedly. I still plan on considering it a perception issue until I confirm with a null test but thought I would mention it. The first time or two it happened in Nuendo and it happened in Reaper last week. Only problem is, in these cases I rendered at the native sample rate but probably dropped the bit rate from 32 to 24.

Karbo

liquidsonics
01-07-2010, 03:25 PM
again, this probably isn't a reaper problem, it's a plugin problem. i've seen plugins that behave totally differently depending on the sample rate - not always "wrong", just inconsistently. bootsy's plugins are known to do this, as are a lot of older synthedit plugs - they're just WEIRD at high sample rates. if you get the sound right at a high sample rate, then render at a low sample rate, it's all gonna turn to crap.

render at the native sample rate, either directly or via the checkbox workaround i posted a few posts ago, and make sure you do your final check with neutral software (e.g. re-importing to reaper into a new session at the correct sample rate).

OR, you can just work at the target sample rate (44khz for audio, 48khz for video) the whole time, which is probably better for most people really.In Reverberate LE this can happen, if you render at a higher sample rate to the project rate you'll find the convolved audio to be louder than it was during play-back. This is a side-effect of convolution with resampled IRs (you resample to match the higher rate, add more samples in the IR, and then you get more energy in the output which corresponds to a louder sound). I (today, 2 hours ago as of writing) added an option in Reverberate (full version) to compensate for this effect (SIR has had it for a while so this is me catching up here). I may add it to LE if the donation rates pick up.

Matt
ps. If dub3000 would like to elaborate on 'buggy as hell' I'll happily look into any fixes that may be needed. Reverberate or Reverberate LE are natively coded, no SE involved at all.

magicchord
01-07-2010, 03:46 PM
Not only is the format a concern, but sample rate and bit depth are as well, especially with FX. I work at 96K 24-bit, and if I render directly to 44.1K 16-bit, the FX get all funked up and the mix goes to h3ll. To circumvent this, I render to 96K 32-bit float, which locks in the sound of the FX, and then do my sample rate and bit depth converting after that.

Don't know if this will help, but I hope so...

Good luck!

I was going to say the same thing.
Many plugins behave oddly when you render to something other than the project sampling rate. It's just something I have to watch out for.
I recommend ALWAYS rendering at the same sample rate as the project, then to SRC the rendered file afterward.

stratman
01-07-2010, 03:52 PM
OT
I (today, 2 hours ago as of writing) added an option in Reverberate (full version) to compensate for this effect

Just got the email about this update :)

Pete

dub3000
01-07-2010, 05:14 PM
ps. If dub3000 would like to elaborate on 'buggy as hell' I'll happily look into any fixes that may be needed. Reverberate or Reverberate LE are natively coded, no SE involved at all.

i'm really sorry - i had an entirely different convolution plugin in mind ("reflections LE"). my sincere apologies, i've deleted my original post. i haven't used reverberate LE.

Deltones
01-07-2010, 05:45 PM
Had that problem before where my rendered file sounded brighter than the mix. Eventually found out that when I played my mix through Reaper, the sound was produced by my Firestudio. However, when I played the rendered file in Windows Media for exemple, the sound was produced by my Live Value soundcard. Set everyting so that all sound used my Firestudio interface.

liquidsonics
01-08-2010, 12:53 PM
i'm really sorry - i had an entirely different convolution plugin in mind ("reflections LE"). my sincere apologies, i've deleted my original post. i haven't used reverberate LE.No problem, glad to hear there are no issues :)

Gelic
04-11-2010, 09:48 AM
Hello,

I've been using reaper for over a year now and have only recently been delving seriously into getting full songs recorded )instead of just keeping track of new song ideas) since I finally have the plugins to make life easier for me to record (Amplitube, EZDrummer, Melodyne, to name a few).

Now, my problem that I seem to be running into is that I'll get my song all mixed in Reaper and the whole thing sounds balanced and great and then I'll render a wav file of the project and play it in Media Player or iTunes or even my car and they all sound like complete crap. There's always too much reverb, the vocals are way low in the mix, and the mix as a whole sounds like someone put a blanket over the speaker, when it was crystal clear before. Any thoughts on what I'm experiencing here? Thanks!

I had the exact same issue as you - sounded great played from Reaper, but FROM THE EXACT SAME COMPUTER when played on any media player - winamp, kmplayer, windows media player, vlc player, etc, etc....it sounded lifeless.

In my case, I had some extra sends and receives hidden on a couple of the tracks. And since each send/receive can send an extra signal source to the Master track - essentially I was doubling up my sound. However when rendered, these extra send/receives were not sent to the mixdown stream - thus a weaker audio signal.

You probably solved this - but for other users - click the IO button on each track in the mix - check for sends/receives that are doubling the sound. If the IO button is green - you have extra sends/receives on that track.

One other consideration is: Check the sample rate in 3 places: Project Settings, Preferences, and the Render dialog. Make them consistent so no resampling occurs. Also - my Emu1820m has a sample rate display and setting dialog - couldn't hurt to be aware of this as well.

Lastly - wherever you have double sound sources, whether it's tracks or extra sends/receives, or vst's - that play in Reaper but don't get included in the ultimate mixdown signal - you will have an acoustic delta - the rendered version will sound less than the version you hear in Reaper.

oh...one more important thing! Some cards have extra monitoring facilities that send extra sound signals to the speakers/monitors - this won't make mixdown so your rendered file will sound flatter without the monitor signals you hear when played in Reaper.

Good luck!

Gelic

malexander
03-28-2012, 07:28 PM
This thread is a bit old, but I was having the same problem (file sounded hissy, muddier, and lower in decibels after rendering), so I thought I'd also add my experiences to the knowledge database.

Mixes in Reaper would sound different after rendering using the same audio routing - from a laptop (running audio just out of the headphone jack) and low-end Tannoy near-field monitor setup and when playing back in another program (any of them, iTunes, Foobar, Windows Media Player). But I put the same .wav file in my iPhone and it sounded ok listening through headphones or my car speakers.

So I tried hooking up my cheap Behringer U-Control UCA202 audio interface (which I should be using anyway instead of the headphone jack, except I get some weird low volume beeping interference) and playing back in Foobar on the same laptop through the headphone out, and the .wav file was as it sounded in Reaper, for the most part.

Lesson #1 - need a better audio interface or computer with a better internal audio card. Lesson #2 - the computer is processing audio differently internally depending on what program is used and if I'm using the interface. In Reaper, it's using ASIO. Foobar without the interface is using something else, and with the interface, I'm not sure what it's doing, but it's different than without. And when in Reaper, it doesn't matter if I'm using the interface or going out through the headphone jack.

At least that's where I'm at, for now.

Narayan
04-13-2012, 08:52 AM
This thread is a bit old, but I was having a similar problem and I searched but I couldn't see the answer here.


I simply unchecked the box "Allow large files to use Wav 64" in the render options and suddenly the sound on the new rendered track in question was much the same as in the project.

Tod
04-13-2012, 09:41 AM
I simply unchecked the box "Allow large files to use Wav 64" in the render options and suddenly the sound on the new rendered track in question was much the same as in the project.

Humm, I couldn't find anything in the manual about that, do you have any idea what it pertains too? Also I wonder what is considered a large file?

Narayan
04-14-2012, 04:44 AM
(I assume you can see it to the right of Wav Bit Depth.) I'm not sure about how it applies in terms of the science of it; but it seems to show a marked difference on a specific track or tracks by processing a higher quality version of it.

When the box was checked my lead synth stem sounded like a 56k mp3 within the final render. Unchecked it maintained it's characteristic sound and body. The difference on other tracks wasn't noticable (to me) either way though.

Dstruct
04-15-2012, 06:06 AM
Also I wonder what is considered a large file?

Files larger than 4GB I think.

Smurf
04-15-2012, 09:00 AM
Hmm, I tried the Wave64 thing (along with EVERYTHING mentioned in this thread over the years) and a render STILL sounds like it has a blanket over it, exporting in Real Time seems to be the only way around this....

timlloyd
04-15-2012, 09:06 AM
What plugins are you typically using when you notice this, and do you have the "inform plugins of offline rendering state" preference enabled?

Smurf
04-15-2012, 11:02 AM
It sounds like this even if there are NO plugins on any tracks or the master...it just sounds like there is a blanket over the sound unless I render in Real Time.

Same Tracks in Studio1 or KAE, effects or not, same bitrate & sample rate or not, .wav or mp3 or flac or ape, the sound is just like the mix in the DAW when rendered.....

No big deal, just another quirk in a piece of DAW software, ya just work around it & get on with making music!

timlloyd
04-15-2012, 11:22 AM
No big deal, just another quirk in a piece of DAW software, ya just work around it & get on with making music!

Nooooo :) IF it's happening when rendering with no processing, it's a colossal bug and needs fixing. I have never noticed it though - do you have any comparison clips?

Tod
04-15-2012, 01:48 PM
Nooooo :) IF it's happening when rendering with no processing, it's a colossal bug and needs fixing. I have never noticed it though - do you have any comparison clips?

I agree. I've also not noticed any problems but if there's even the remotest possibility or certain situation it would be good to know or be aware of it. :)

thfox
03-01-2013, 12:59 PM
Like many others, after spending much time tweaking my effects and settings to perfection until I'm really happy about the total sound of my project, I find that the stereo mixdown sounds like a poor imitation of the project playback ; lacking punch, brightness & dimension. I always use the ASIO4ALL driver, so I tried switching to anything else, and got a sound very close to the file I previously rendered. So would not the goal here be to render from the ASIO4ALL output ? Is this possible ? Any suggestions would be appreciated !

richie43
03-01-2013, 03:27 PM
I have checked for this issue many times, ever since I first saw the thread, and have never had a problem with the renders being different than the playback. Are you all rendering to the same sample-rate and bit depth? Are you rendering from projects that have audio items of varying sample-rates or bit depths? I don't doubt that this is happening to some people, but if it were a Reaper bug, we ALL would be experiencing it (and we are not). So I bet that this is some kind of user error on a large scale......

thfox
03-01-2013, 04:39 PM
Yup, same sample rate, but not sure about bit depth. Would that be listed at : Project settings > Advanced > Track mixing bit depth ? It's set at 64 (default). Although, I'm recording my tracks in .ogg format VBR Quality :.7 which doesn't allow a bit rate to be specified.

richie43
03-01-2013, 07:14 PM
Yup, same sample rate, but not sure about bit depth. Would that be listed at : Project settings > Advanced > Track mixing bit depth ? It's set at 64 (default). Although, I'm recording my tracks in .ogg format VBR Quality :.7 which doesn't allow a bit rate to be specified.

I was more curious about the sample rate and bit depth of the render. And why are you using 64bit in the project settings? 32bit FP is as high as anyone needs to go, in my opinion, and even that is not even recognized by 99% of the convertors in use.

karbomusic
03-01-2013, 07:30 PM
I was more curious about the sample rate and bit depth of the render. And why are you using 64bit in the project settings? 32bit FP is as high as anyone needs to go, in my opinion, and even that is not even recognized by 99% of the convertors in use.

The OP is speaking of the internal mixing engine bit depth which is 64bit by default, not the WAV bit depth.

What if a questionable render is made then a realtime, do they null and if not what remains might give a clue.

richie43
03-01-2013, 07:42 PM
The OP is speaking of the internal mixing engine bit depth which is 64bit by default, not the WAV bit depth.

Duh.......... I knew that......:rolleyes:

dea-man
03-01-2013, 07:51 PM
Sorry OP, I didn't read every post in this thread. I just wanted to jump in with my two cents.

If you study the monitors you DO have, by listening to other recordings through them, then you will have an idea of how to mix on those speakers, in order to get the mix to translate well, in other listening environments.

Listen to you favorite recordings, and note how the bass is, how the highs sound, etc....then you'll know what you have to shoot for, in order to get a better mix.

richie43
03-01-2013, 08:04 PM
Sorry OP, I didn't read every post in this thread. I just wanted to jump in with my two cents.

If you study the monitors you DO have, by listening to other recordings through them, then you will have an idea of how to mix on those speakers, in order to get the mix to translate well, in other listening environments.

Listen to you favorite recordings, and note how the bass is, how the highs sound, etc....then you'll know what you have to shoot for, in order to get a better mix.

His issue is that his mixes sound worse listening back on the same monitors that he mixed on, the renders are different than the play-back.

karbomusic
03-01-2013, 08:04 PM
Hmmm... reading the first post again....

If you drag that render into a new project in reaper and play it there is it bad then? If not, its not the render, its the playback software/device/OS settings etc.

ramses
03-01-2013, 10:10 PM
His issue is that his mixes sound worse listening back on the same monitors that he mixed on, the renders are different than the play-back.

I will go out on a limb here and suggest that some of these reports might simply be a matter of psycho accoustics. When I started out mixing I often thought that something was wrong with my playback/daw/speakers, etc. I now know that it was my mind playing all sorts of tricks on me because of inexperience/varying visual stimuli, etc. I'm still easily distracted by visual cues while mixing and frequently turn my monitor off to un-bias myself if I feel that something is hard to get right. I'm not saying that it's not possible that something else is wrong, but it's important to remember this aspect as well. Also, untreated rooms can have WIDELY varying responses at close points in space - lean forward 10cm's and the high mids disappear - and so on...

thfox
03-01-2013, 10:53 PM
Thanx for these suggestions - It seems that playing my mixes thru the ASIO4ALL driver either add depth & dimension to my projects OR playing thru other drivers reduce them noticeably. If there was a way to tap in to the output of the driver w/o using outboard equipment I could prove this.

thfox
03-01-2013, 11:19 PM
Oh, and I've been checking other forums & it seems to be a common problem w/ many DAWs (mixdowns sounding inferior to playback).

brainwreck
03-01-2013, 11:25 PM
The driver should not have an effect on the sound quality. If you are noticing some difference between drivers, I would have to think that something else is causing the difference.

richie43
03-01-2013, 11:28 PM
Thanx for these suggestions - It seems that playing my mixes thru the ASIO4ALL driver either add depth & dimension to my projects OR playing thru other drivers reduce them noticeably. If there was a way to tap in to the output of the driver w/o using outboard equipment I could prove this.

This makes no sense, other than whatever soundcard you use works better with one or the other driver. Are you using the same soundcard during playback of the inferior render that you use when playing the mix in Reaper?

brainwreck
03-02-2013, 12:22 AM
I haven't read through this thread, but I saw that Asio4all is being used, indicating a generic sound card. Soundcards typically have some spatial and other effects in their included software. If any of that stuff is on, that could be the cause of the sound difference.

richie43
03-02-2013, 09:02 AM
I haven't read through this thread, but I saw that Asio4all is being used, indicating a generic sound card. Soundcards typically have some spatial and other effects in their included software. If any of that stuff is on, that could be the cause of the sound difference.

I thought of that too, but even if he is using a generic soundcard that has these effects on the software, he is still using the same soundcard for the Reaper mix/playback and listening to the render, which are sounding different from one another. I bet that it has to do with some kind of fx/tone shaping on the media player, or he is rendering to a different format and it is not converting well. I thought about this and think that since he is not ever sending it out of the computer and back in, like through some hardware, this is all being done in the computer, it never even hits a AD/DA convertor or anything like that. I am still curious if the OP has tried importing the render back into Reaper and listening that way, to see if maybe it is the media player causing this.

karbomusic
03-02-2013, 09:44 AM
I am still curious if the OP has tried importing the render back into Reaper and listening that way, to see if maybe it is the media player causing this.

Mee too. ;)

thfox
03-02-2013, 10:34 AM
Gentlemen, Thanks for your input. Yes, I imported the rendered file back into Reaper & it sounded great. I also imported the file into T-Racks3 Standalone w/ no processing - also sounded great. What do they both have in common ? Both are using the ASIO4ALL driver. (I know this is starting to sound like a commercial!) I tried to find a media player that would be asio compatible, but no luck yet. (the windows media player asio fix doesn't work for me)

dea-man
03-02-2013, 10:36 AM
Gentlemen, Thanks for your input. Yes, I imported the rendered file back into Reaper & it sounded great. I also imported the file into T-Racks Standalone w/ no
processing - also sounded great. What do they both have in common ? Both are using the ASIO4ALL driver. (I know this is starting to sound like a commercial!)
I tried to find a media player that would be asio compatible, but no luck yet.

I guess I just don't understand how you have things hooked up.

What are you using, specifically, and how is it hooked up. Describe everything.

richie43
03-02-2013, 11:23 AM
If you imported the render into Reaper and it sounds fine, then the issue isn't Reaper and the renders, it is a setting in your media player. Whether or not a media player uses an asio driver or not makes zero difference in the final sound, it's a driver. Try downloading VLC Player and play the file on it. Also, look into your windows audio settings, many onboard soundcards have additional software attached to it besides the simple driver, and usually this software has tone presets, room and environment simulations, etc. I wouldn't be surprised if this stuff is even on by default, but I wouldn't know...it has been over 3 years since my main rig had any onboard soundcard. I didn't just disable the onboard sound, I completely uninstalled the drivers and disabled it at the bios level.I can almost guarantee that your problem is in either the Windows audio settings or your chosen media player.

thfox
03-02-2013, 01:58 PM
I guess I just don't understand how you have things hooked up.

What are you using, specifically, and how is it hooked up. Describe everything.

My Reaper stereo output > ASIO4ALL > stock onboard Realtek HD Audio "device" running at 24 bit 44,100 hz, no enhancements enabled. I listen w/ headphones plugged into the computer 1/8" stereo phone jack output.

richie43
03-02-2013, 03:03 PM
....no enhancements enabled....

The check settings on your media player. Like I said (and I believe a few other people have said this also), if the same render sounds fine when you import it back into Reaper and listen that way, but it still sounds weird when played on a different player on the same computer, then it definitely has to do with your media player. If it was a rendering issue, then it would not sound ok when listened to in Reaper. And I know that you are convinced that it is driver related, but the driver will not affect audio quality unless we are talking about latency issues or quality of performance of the actual hardware. Have you tried listening to these renders on completely different systems, by chance? Like on an mp3 player, stereo/car stereo, different computer?

dea-man
03-02-2013, 03:51 PM
My Reaper stereo output > ASIO4ALL > stock onboard Realtek HD Audio "device" running at 24 bit 44,100 hz, no enhancements enabled. I listen w/ headphones plugged into the computer 1/8" stereo phone jack output.

I believe you really need a proper audio interface.

Onboard soundcards are not really made to handle serious audio processing.

brainwreck
03-02-2013, 05:00 PM
I believe you really need a proper audio interface.

Onboard soundcards are not really made to handle serious audio processing.

Unless he is bringing in audio through the sound card, it shouldn't matter much at all.

thfox
03-03-2013, 10:37 AM
I believe you really need a proper audio interface.

Onboard soundcards are not really made to handle serious audio processing.

I do have a Line6 Toneport interface (the older red & black one). Do U think that's sufficient ?

dea-man
03-03-2013, 05:18 PM
I do have a Line6 Toneport interface (the older red & black one). Do U think that's sufficient ?

Well, it may be good for your guitar, but does it have interface for Line In/Mic, Hi Impedance, Low Impedance, Digital, SP dif, Firewire and USB?

You know a good little dedicated box for all your recording needs. Something like:
https://www.google.com/#hl=en&sugexp=les%3B&gs_rn=5&gs_ri=psy-ab&tok=y-wTeDLx8PfExKvPmVLq8Q&cp=16&gs_id=1u&xhr=t&q=M-audio+firewire+410&es_nrs=true&pf=p&sclient=psy-ab&oq=M-audio+firewire&gs_l=&pbx=1&bav=on.2,or.r_gc.r_pw.r_cp.r_qf.&bvm=bv.43148975,d.cGE&fp=c1794afd088c3d78&biw=800&bih=487

I think it would benefit you, greatly!

What does the Toneport plug into?

thfox
03-08-2013, 02:29 PM
It plugs into the PC by way of USB.
(and thanx for the link)

bluzkat
03-08-2013, 05:21 PM
I do have a Line6 Toneport interface (the older red & black one). Do U think that's sufficient ?

Why aren't you using the Toneport? Download the driver from Line 6 and install it, you want to use the Line 6 audio driver instead of Asio4All.

I have an older (red & black) UX2 and it was my only interface for several years and it performed well. Still does!

:cool:

bluzkat
03-08-2013, 05:32 PM
Well, it may be good for your guitar, but does it have interface for Line In/Mic, Hi Impedance, Low Impedance, Digital, SP dif, Firewire and USB?


dea-man,

A Line 6 Toneport is an interface and not just for guitar, see here:

http://www.sweetwater.com/store/detail/PodStuUX2/.

The only difference between these and the original Toneport is the color. The original ones were black and red, the newer ones are black. Everything else is the same.

I've had one of these for several years and it has served me well.

:cool:

Narayan
03-24-2013, 04:21 PM
Agh. Back here again. The renders to WAV, FLAC, AIFF are shortening my percussive sounds like a bit crusher, and MP3 is destroying the sound on the chorus too much....

Anyone found any good alternatives like a VST render plug in?

Billoon
03-24-2013, 04:44 PM
Your having this problem even when using 'Save live output' set to the sample rate of your project, 64 bit WAV?

richie43
03-24-2013, 05:35 PM
Agh. Back here again. The renders to WAV, FLAC, AIFF are shortening my percussive sounds like a bit crusher, and MP3 is destroying the sound on the chorus too much....

Anyone found any good alternatives like a VST render plug in?

How can rendering to mp3 destroy only the chorus? Unless your chorus is much louder than everything else, so it compresses more..... What is your render level? Are you slamming it with a brickwall limiter by chance? Are you rendering to a different bit depth?

Narayan
03-24-2013, 05:59 PM
Billoon-I'm not using any live recordings it's all constructs and mostly midi, but the 64 bit wav setting with 384 pt showed a great improvement, so thanks!

Richie-I think the reason the MP3 compression hits the chorus so much is because it's almost all different elements to the verse, bridge etc. The chorus bassline in particular sounds stripped out when rendered to mp3. Speaking as someone who doesn't know the science well, it would be great to have some dynamic capability for varying the way a compressor applies itself (ie so that it hit freq that weren't important to the sound for instance).

richie43
03-24-2013, 06:14 PM
Billoon-I'm not using any live recordings it's all constructs and mostly midi, but the 64 bit wav setting with 384 pt showed a great improvement, so thanks!

Richie-I think the reason the MP3 compression hits the chorus so much is because it's almost all different elements to the verse, bridge etc. The chorus bassline in particular sounds stripped out when rendered to mp3. Speaking as someone who doesn't know the science well, it would be great to have some dynamic capability for varying the way a compressor applies itself (ie so that it hit freq that weren't important to the sound for instance).

No matter how different a chorus is, the compression from rendering to mp3 should not be noticeable unless your whole mix is just too loud and already too compressed. And for that compression idea of yours.... look up multi-band compressors (ask and ye shall receive!)

Can you upload the rendered mp3 somewhere so we can hear it? Maybe that will help us help you. Also, why are you recording at 64bit? If i remember correctly, you are merely making bigger files, but I don't think you are increasing the quality.

Billoon
03-24-2013, 06:18 PM
Billoon-I'm not using any live recordings it's all constructs and mostly midi, but the 64 bit wav setting with 384 pt showed a great improvement, so thanks!

Ah, if your going to be resampling, why not use the highest option then too?

Narayan
04-08-2013, 02:46 AM
Thanks folks. Yeah the volume reductions did seem to yield an improvement in overall quality. I am not sure whether resampling applies to the rendering process with the midi track compression to MP3. It is a variable I don't know about but I thought I would include it for a full picture.

How do you know whether resampling is needed and used in such a render? How does it impact on the product?


Regards

Narayan
05-04-2013, 03:12 PM
Also, Why is there such a direct relationship between volume level and output quality?

The more I reduce the volume the greater the output quality I am finding. But the high sound quality renders don't stand terribly well next to mainstream material in terms of amplification (ie not as loud).

Thoughts and guidance if you please?


Cheers

brainwreck
05-04-2013, 05:39 PM
Billoon-I'm not using any live recordings it's all constructs and mostly midi, but the 64 bit wav setting with 384 pt showed a great improvement, so thanks!

Richie-I think the reason the MP3 compression hits the chorus so much is because it's almost all different elements to the verse, bridge etc. The chorus bassline in particular sounds stripped out when rendered to mp3. Speaking as someone who doesn't know the science well, it would be great to have some dynamic capability for varying the way a compressor applies itself (ie so that it hit freq that weren't important to the sound for instance).

There really should not be any audible sound difference between say, a 24 bit and 64 bit floating point audio file, and there is no point in rendering to 64 bit floating point unless you have a specific need to do so.

By 'live', Billoon is talking about a feature of Reaper that allows for recording the live output of Reaper to a file. When it is turned on, any sound that goes through Reaper will be output (recorded) to the file until it is turned off. Think of it as a secondary stereo recorder running in the background that never goes off until you specifically turn it off.

If rendering to mp3 is really messing with the rendered sound, up the bitrate. At a constant bitrate of 320 kbps, anyone would be hard pressed to hear the difference between mp3 and wav. Mp3 is inferior to wav, but the difference is subtle, and it can only be heard on some material, not all. It is not something that will jump out at you.

Thanks folks. Yeah the volume reductions did seem to yield an improvement in overall quality. I am not sure whether resampling applies to the rendering process with the midi track compression to MP3. It is a variable I don't know about but I thought I would include it for a full picture.

How do you know whether resampling is needed and used in such a render? How does it impact on the product?


Regards

Unless you were going over 0 dbfs (in the red), what you render should be what you hear in Reaper. Don't go over 0. When you do that, your sound is being clipped, essentially reducing the bit depth. You mentioned previously that your percussion sounded like it is going through a bitcrusher. If you're outputting heavily over 0, it will sound like that.

Resamplinng applies when you render to a different sample rate other than what your project uses. For example, if your project is recorded at 48k, and you render to 44.1k, resampling takes place. You should read a bit about the basics of digital audio to understand this stuff better. Just do a search, check wikipedia, youtube, etc. I'm sure that with a little patience and time, you can find enough info to understand how the basics of digital audio works. Also, there are books available that explain this stuff.

As for how resampling affects the render, that is all up to your ears. And btw, don't be fooled by all of the numbers and settings. Higher numbers does not necessarily equate to higher sound quality. A lot of this stuff is subjective, and you should use your ears above all else, along with a basic understanding of how digital audio works. And be objective about it. Can you really hear the difference, or are you allowing your judgement to be skewed by some number or setting? Do some blind tests. If you are ever hearing major differences in sound quality, it is safe to assume that it probably has nothing to do with the file format, the bit depth, or the sample rate.

Also, Why is there such a direct relationship between volume level and output quality?

The more I reduce the volume the greater the output quality I am finding. But the high sound quality renders don't stand terribly well next to mainstream material in terms of amplification (ie not as loud).

Thoughts and guidance if you please?


Cheers

On rendered sound levels, that is an issue of skills in recording, mixing, and mastering the recording. Without going into too much detail, getting a healthy sound level on the render is about removing junk from the mix such as boomy low end, or transient highs, taming dynamics, etc., i.e., mixing for clarity and fitting a lot of sound into a little space. The problem there is not a problem of the software. It has to do with how well you record tracks, how well you mix, and how dynamic the final track needs to be.

MikComposer
05-04-2013, 05:54 PM
I'm having few of those issues, thought there is one thing i haven't tried yet. To start with the issues:

- Rendered track ( wave 24 bit ) sounds worst then mix, sounds muted and reverb sound seams wetter.
- When mixing with lower volumes everything sounds ok, but when volume is raised within reappear everything starting sounding bit harsh even on lower listening volumes, as the sound would forcing itself to be louder. I'm using limiter to cut of picks.

With the first problem apparently if you record whole track on one pre-stereo buss and then render it it should apparently be fine, but haven't tried that yet.

With the second i don't know.

brainwreck
05-04-2013, 06:09 PM
I'm having few of those issues, thought there is one thing i haven't tried yet. To start with the issues:

- Rendered track ( wave 24 bit ) sounds worst then mix, sounds muted and reverb sound seams wetter.
- When mixing with lower volumes everything sounds ok, but when volume is raised within reappear everything starting sounding bit harsh even on lower listening volumes, as the sound would forcing itself to be louder. I'm using limiter to cut of picks.

With the first problem apparently if you record whole track on one pre-stereo buss and then render it it should apparently be fine, but haven't tried that yet.

With the second i don't know.

Something for you guys to try when hearing a difference between the render and the master output in Reaper: Render your track. Open media explorer in Reaper (View > Media Explorer). Play your file using media explorer, making sure that the level is set to 0. If you hear no difference between the file playing in Media Explorer and the full mix, then the difference that you are describing to us is not an issue with Reaper.

As for the harshness when raising the volume, well, if you push your music into a limiter, the peaks get clipped off. A limiter is not magic. If your tracks aren't mixed well, pushing them into a limiter will not give you much more volume, and it will sound worse. When using a limiter to get more volume, use it to catch maybe 1 or 2 db. If you're doing more than that, you're probably doing damage to the mix, unless the mix is really dynamic, and in that case, you might not want a limter any way. Just remember that mixing isn't easy, and it takes a lot of practice. If you are hearing other people's mixes that sound well balanced and with a healthy volume, I would wage a bet that person has spent a lot of time practicing mixing. From what you are describing, you should ditch the limiter and focus on mixing for clarity. It might be months or longer before you should even think about touching a limiter again. It's about listening skills in balance and frequencies, in the same way that hearing pitch and timing is a music skill. It takes time to develop. Once you get balance and clarity, a healthier render level will come along for the ride, for free.

Maybe the best thing that I can think to tell you guys who are chasing after louder levels is to use reference tracks, and forget louder for now. Compare your rendered tracks with other music that you listen to, adjusting them so that both sound to be at the same level. Listen to the balance of instruments in the reference tracks compared to your tracks. Listen individually - how loud is the kick, the bass, the guitars, the cymbals, the vocals, etc.? Work on getting your stuff balanced in levels and pan your tracks to take advantage of the stereo field - if everything is coming down the middle, then you're trying to cram too much into that little bit of space. Listen to your render for frequency balance as well. How much bass does your track have compared to the reference? How about mids and highs? How about dynamic peaks? After you get the instruments balanced and panned, start trying to figure out which frequencies need to be carved away from which tracks, and which tracks need to have their dynamics tamed using compression. This stuff is going to take a lot of practice. Then there is reverb and delay for adding space and cohesion. The worst thing that you can probably do at this point is to compress and limit the master. Steer clear of that for a while, until you feel like you're getting a handle on everything else. It could take weeks, months, a year, or more. Everyone is different with different circumstances. A beginner asking why his rendered level is low is a bit like a beginning guitar player asking why his speed is so slow. He hasn't put in the time. That might not be obvious, so don't take what I'm saying as a lecture. It's just reality. Practice, practice, practice. Taking up recording and mixing is learning a whole new skill set outside of playing instruments. Oh, and most important, ignore everything that everyone says and make your own mistakes...lots of them. You won't learn shit without messing up something. Experiment with lots of things. But try and reflect on your mistakes and figure them out. Ignoring them and reaching for a magic box will only prolong your time in newbieland. And of course, if you don't understand exactly how something works, go find out. Do you know how a limiter works, and what it is doing?

edit: because I can't shutup.

MikComposer
05-04-2013, 06:20 PM
Something for you guys to try when hearing a difference between the render and the master output in Reaper: Render your track. Open a new tab in Reaper. Open media explorer in Reaper (View > Media Explorer). Play your file using media explorer, making sure that the level is set to 0. If you hear no difference between the file playing in Media Explorer and the full mix running in the other tab, then the difference that you are describing to us is not an issue with Reaper.

As for the harshness when raising the volume, well, if you push your music into a limiter, the peaks get clipped off. A limiter is not magic. If tracks aren't mixed well, pushing them into a limiter will not give you much more volume, and it will sound worse. When using a limiter to get more volume, use it to catch maybe a 1 or 2 db. If you're doing more than that, you're probably doing damage to the mix. Just remember that mixing isn't easy, and it takes a lot of practice. If you are hearing other people's mixes that sound well balanced and with a healthy volume, I would wage a bet that person has spent a lot of time practicing mixing. From what you are describing, you should ditch the limiter and focus on mixing for clarity. It might be months or longer before you should even think about touching a limiter again.

Ah, I'm not pushing it in to limiter hard. With some tracks it only touches it and only occasionally every several bars or even whole phrases.

I agree that mixing is damn hard. I'm practicing it now for 2 years, and finally just starting getting better at it. It's just my understanding is that until i hit the pick everything should sound ok even not mixed. For example the track's loudest pick is at around -40db, and let's say I will up it by +35db and I lower the monitors volume to closely match the volume of track from before rising its volume. I can hear harshness! Mathematically I shouldn't that is my guess!

As for the first thing, I will try that.

brainwreck
05-04-2013, 06:59 PM
Ah, I'm not pushing it in to limiter hard. With some tracks it only touches it and only occasionally every several bars or even whole phrases.

I agree that mixing is damn hard. I'm practicing it now for 2 years, and finally just starting getting better at it. It's just my understanding is that until i hit the pick everything should sound ok even not mixed. For example the track's loudest pick is at around -40db, and let's say I will up it by +35db and I lower the monitors volume to closely match the volume of track from before rising its volume. I can hear harshness! Mathematically I shouldn't that is my guess!

As for the first thing, I will try that.

Not picking on you, but I think you mean peak, not pick. To think of it pseudo-mathematically, your various tracks' levels add up. If you have a capacity of 110 db on the master track, feeding it with 80 db worth of sound content from multiple tracks is going to cause an overflow. See what I mean? What you have to do is essentially miniaturize everything to fit. Think of the master as a picture frame, and you have a bunch of pictures that must all fit into that same frame. You're going to have to shrink your pictures to fit. This is where carving away frequencies from tracks, and compressing tracks' peaks comes into play. Does that make sense? A track with a lot of bass is big. It takes up more room. A track with a high dynamic range takes up a lot of space. You have to try and get everything smaller to fit into a limited space, giving the illusion that everything is full size.

MikComposer
05-04-2013, 07:05 PM
Not picking on you, but I think you mean peak, not pick. To think of it pseudo-mathematically, your various tracks' levels add up. If you have a capacity of 110 db of room on the master track, feeding it with 80 db worth of sound content from multiple tracks is going to cause an overflow. See what I mean? What you have to do is essentially miniaturize everything to fit. Think of the master as a picture frame, and you have a bunch of pictures that must all fit into that same frame. You're going to have to shrink your pictures to fit. This is where carving away frequencies from tracks, and compressing tracks' peaks comes into play. Does that make sense?

Yeah it does. It's a good metaphor. Cheers ;)
And yes i meant peaks. Eng is not my first language so i do make mistakes sometimes.

grinder
05-04-2013, 07:18 PM
Brainwork I consider your answer to be a jewel- only on the Reaper forum,

Grinder

brainwreck
05-04-2013, 07:21 PM
Yeah it does. It's a good metaphor. Cheers ;)
And yes i meant peaks. Eng is not my first language so i do make mistakes sometimes.

Hmmm...I subconsciously ripped that metaphor off, now that I think about it. A female engineer (I forget who, exactly) described mixing as a miniature stage. She said that the mixer's job is to shrink everything to fit on the miniature stage, giving the illusion that all of the instruments are fullsize, or something to that effect.

MikComposer
05-04-2013, 07:23 PM
Hmmm...I subconsciously ripped that metaphor off, now that I think about it. A female engineer (I forget who, exactly) described mixing as a miniature stage. She said that the mixer's job is to shrink everything to fit on the miniature stage, giving the illusion that all of the instruments are fullsize.

Probably yeah ;)

But you know, I do miss that old school analog sound. It was beautiful in its imperfection and everything sounded big because of that.

grinder
05-04-2013, 07:26 PM
Nice all the same!

Grinder

brainwreck
05-04-2013, 07:36 PM
Probably yeah ;)

But you know, I do miss that old school analog sound. It was beautiful in its imperfection and everything sounded big because of that.

You and me both! Maybe some day...

Narayan
05-05-2013, 02:36 PM
Wow thanks for these in depth responses. This is great. The people on the forums and the people putting out free and affordable software and helping others in a largely anonymous fashion across the internet....Really are unsung heroes.

Cheers

Minionist
12-17-2013, 02:44 PM
Dear Fellow Reaper users,

I also had this problem: in Reaper music sounds good, rendered version: not that good.

What helped: instead of Full-speed offline render I am using the Online Render option, and that doesn't ruin my bass sound. I suspect this has something to do with how certain VST synths are working - or maybe not at all. But nevertheless this trick helped, so I am a happy user.

Cheers,
Minionist

MikComposer
12-17-2013, 03:35 PM
Hello,

It's my 4th year practicing mixing. Reaper renderer make things sound bad and I had no idea why is that just till recently. I found a way: mix in 96 or higher ( Fx just don't sound good at anything below 96 ), then record the all tracks live on to another track ( is it called bounce track, sum track?; not sure ) and then you can safely render in to whatever format you want. That said, it looks to me that it makes big difference only if your mixes are decent ( as not muddy and balanced).

Funny fact: my mixes significantly improved since I've switched from mackie mr8mk2 as my main monitors to my secondary speakers Alesis M1Active 320's ( they're like, what, 3,5 inches! XD ).

RangeAntelope
01-27-2014, 03:41 PM
Since Reaper added the option: Allow large files to use WAVE 64 (which is checked by default?) my "renderings" having been "breathing" in and out like I have some type of super over-compression.

When I play the mixes through my studio monitors, they sound fine.
After I render, they sound hideous.

I researched into WAVE 64 today and, after review, I decided to uncheck the WAVE 64 box. I rendered the file, brought it up on Windows Media Player (under Windows 8 64bit) and it was just as butt kickin as when I listen to it "raw" within Reaper.

I don't care WHAT anyone says, WAVE 64 DEFINITELY uses some type of compression algorithm that screws up the rendering process.

Hope this helps.

Lazz
01-27-2014, 08:37 PM
I apologize I have not read the three pages of this thread....

I also experience this to. I'm no pro by any means but I do know what I'm doing to very good extent. My room is lightly treated at home an I mix on NS10's an VXT6's that I'm very familiar with. I also use HR824's along with another set of NS10's at a friend's professional studio that I work at very frequently. Mix sounds great at home and the studio, after rending to Dropbox and listening back on any other commercial source, ie stereo, phone, computer speakers etc, etc, it's sound terrible. The Studio uses PT and I don't have this issue when bouncing down??? It utterly confuses me......

I will be back to read this entire thread....

ARP
01-28-2014, 03:36 AM
OK, I had a problem similar to is at one point, I found that I had applied effects during tracking, and then on mixing they were being applied again, it's important to turn them off when mastering or rendering. Also, if you render effects to a new take, if the effect isn't switched off it will also reapply itself to that take. Also, if you are creating effects sends going to another track, the reverb on that track when rendering will be added again through the track send if you don't turn it off. This may not be your problem, but it thought it worth mentioning anyway, as it's always good to check all your effects settings before mastering to make sure nothing is being duplicated.

ARP.

logikmtr
02-09-2014, 06:16 PM
I have been scouring the internet looking for a solution to this problem, and I have found none. I registered specifically to add my findings regarding this issue.

I have been using Reaper (mostly) without problems for a few years now. I record at 96 kHz, 24 bit. I tend to render to 44.1 kHz 16 bit when sending files to people. I do this conversion at render time, through the Reaper render dialog.

I believe the problem being described here is an INTERMITTENT problem. I upgraded to version 4.591 recently and found that my rendered files sounded wrong--they lacked punch, and sounded sort of "phased out", like many of you are describing. I rendered the same file using every combination of settings in the render dialog. The issue is the sample rate conversion. If I render to a file using the same sample rate as I used to record (96 kHz), it sounds fine. If I set the sample rate to 44.1, it sounds like trash, REGARDLESS of the resample mode (I rendered using each one). It seems to me that during render, there are some set of conditions that occur to cause Reaper to render the file WITHOUT applying the resample algorithms.

Some observations:
1. Rendering to a lower sample rate has always worked for me in the past, so this seems like an intermittent (conditional) issue.
2. The rendering time remained constant no matter what resampling mode I used (linear or extreme), which makes me think they aren't being applied at all.
3. The bigger the delta in the sampling rate, the worse the sound will be. For example, with 96 kHz source material, 48 kHz render sounds better than 44.1 kHz.

I also did online and 1x offline renders, using wav, aiff, and mp3. These variables do not make a difference.

Has ANYONE else here experienced this, and does anyone in the world know if there is a way to get it working?

logikmtr
02-09-2014, 06:36 PM
Check this out. I hope this works for other people...

Open the project settings (File->Project Settings). Set the sample rate to what is recorded in your project (this is in the upper right hand corner above the timeline). Check the box next to the sample rate value. Render again and see if it's any different.

I think Reaper uses this value in the project settings to determine what resample mode ought to be applied at render time... but in this case it was using an incorrect value. When I opened my project settings, the check box was unchecked and the value said 44.1 kHz, even though my recorded material is 96 kHz 24 bit.

thfox
02-16-2014, 03:06 PM
dub3000 probably had it right with his first guess. If your rendered mix doesn't sound like playback, it's usually because something in your project is being improperly routed direct to hardware output.

Most of the time, you want all of your tracks to end up in the master, and only the master track gets routed to hardware output. (There are exceptions, monitor mixes and so on, but they are for specific situations.) You want to hear exactly what you are mixing on the master.

I suggest going through the IO setup for each track and looking for any sends to hardware output, and removing those sends.

If you place a few Mastering Fx in the Master channel as inserts, will the output from them send to hardware output ?

thfox
07-13-2014, 10:27 PM
OK ...... I've found my answer ! It has nothing to do w/ ASIO, or settings within Reaper. It has to do with bypassing the windows audio stack by using any decent outboard audio device. I realize this is not profound amazing news to most of U who are experienced w/ high end production ! U can play your rendered mixes thru just about any media player as long as it bypasses the windows sound software & hardware. I plug in my trusty Behringer UCA-202 interface, select it as my default device & I AM HAPPNIN' !

richie43
07-13-2014, 10:31 PM
OK ...... I've found my answer ! It has nothing to do w/ ASIO, or settings within Reaper. It has to do with bypassing the windows audio stack by using any decent outboard audio device. I realize this is not profound amazing news to most of U who are experienced w/ high end production ! U can play your rendered mixes thru just about any media player as long as it bypasses the windows sound software & hardware. I plug in my trusty Behringer UCA-202 interface, select it as my default device & I AM HAPPNIN' !

I am glad that you figured this out! Having experience or none at all doesn't mean anything sometimes, everyone has these "duh" moments. It's always the simple answers to things that elude us, for sure! I have had my on-board audio drivers disabled on my main DAW for so long, I forget that this can cause issues like yours. Nice work sussing that out!

JazzCamel
07-13-2014, 10:57 PM
When I first started using Reaper I noticed that things would distort and sound bad especially after adding some plugins. Compared to the rest of the computer's audio output Reaper is way hotter. Regardless of listening environment and sample rates RENDER did at one time not ever equal what I heard when I hit play (crud in the mix & oversaturated upon render.)

NOW, I don't have this problem anymore, though I can't claim I really fixed anything. Two things have changed:

The most important being that I started mixing "in the green," meaning never let your tracks hit yellow or red on the meters... MASTER included at first until you can bring up the overall volume with strict control in the end. I like loudness or limiter plugs on the end of the master channel to bring the volume up to par, find one you love. This eliminates a lot of potential "digital-y" drive in the mix and apparently the rendering process (not that I know why, but certainly experienced this first hand).

Secondly I now have 16gig of fast RAM w a collection of plugins I can trust to work. Plugs can sometimes be the culprit.. especially if they are older than Reaper 4.x.

In a way I am still not sure that my render is precisely equal to playback, but I love my rendered files enough to pump 'em to peeps... benchmark met! I see the OP found an OpSys thing.. so I guess this was different. You can always drop your bounce into a track and bypass the parent send and send to your hardware so you can A/B... in fact there is a checkbox to have Reaper do it for you (you still make the sends).

Happy Mixing ;)

Some call me Danno
12-03-2014, 08:15 PM
Check this out. I hope this works for other people...

Open the project settings (File->Project Settings). Set the sample rate to what is recorded in your project (this is in the upper right hand corner above the timeline). Check the box next to the sample rate value. Render again and see if it's any different.

I think Reaper uses this value in the project settings to determine what resample mode ought to be applied at render time... but in this case it was using an incorrect value. When I opened my project settings, the check box was unchecked and the value said 44.1 kHz, even though my recorded material is 96 kHz 24 bit.

I'm using Reaper V4.731, and have found that the exact same situation that LOGIKMTR has described has fixed my sound quality issues I was having when comparing a rendered track to the live mix.

richie43
12-03-2014, 08:52 PM
I have seen some interfaces/audio cards that do not change sample rates from a message from a DAW, so is it possible that this is the case? Maybe it has to do with your specific audio card and you need to set the rates on the cars manually.

kodebode2
12-18-2014, 10:06 AM
In Reverberate LE this can happen, if you render at a higher sample rate to the project rate you'll find the convolved audio to be louder than it was during play-back. This is a side-effect of convolution with resampled IRs (you resample to match the higher rate, add more samples in the IR, and then you get more energy in the output which corresponds to a louder sound). I (today, 2 hours ago as of writing) added an option in Reverberate (full version) to compensate for this effect (SIR has had it for a while so this is me catching up here). I may add it to LE if the donation rates pick up.

Matt
ps. If dub3000 would like to elaborate on 'buggy as hell' I'll happily look into any fixes that may be needed. Reverberate or Reverberate LE are natively coded, no SE involved at all.

I am a bit late to this discussion, as it only became relevant to me recently.

Wow, this really shed so much light for me. I had made so many assumptions that rendering offline would give me exactly the same result, I guess If I overcome the processor utilisation of higher sampling rates by freezing, maybe this helps

I wonder if there are any significant differences in plugins between realtime mixdowns and offline mixdowns.

Definitely I appreciate that mixing at a different sample rate would introduce changes, filtering accuracy, aliasing reduction etc, to my ears the end result just sounds more solid, i.e real. believable. cleaner. especially with effects.

kodebode2
12-18-2014, 10:38 AM
Yes, this is correct. It sounds completely different played back on Media Player or iTunes on the SAME speakers, even though it sounds great in Reaper. I understand that the monitors that I have aren't that great, but I would hate to be in a situation where I get different monitors just to end up with the same problem in the end. I'll post a pic of my export screen when I get home and see if there's something that you guys might catch that I am missing.

Many years ago on several occasions over many years it was a revelation for me to discover that Windows Media Player includes very subtle enhancement to the audio. Its definitely not a transparent audio player.

The difference you hear is quite true.

Much investigation revealed that the Windows audio subsystem is the culprit and the Windows Player contributes some mojo of its own.

To reduce this you should use a clean player such as Foobar which plays cleaner even through the Windows subsystem.

Furthermore using Foobar with an ASIO driver on an interface that has native ASIO drivers (not ASIO4ALL which is simply a bridge to the windows audio subsystem) provided the closest audio to the experience in Reaper real time playback.

A few more things I would recommend.

1. When Reaper plays back, audio has to be downsampled from its internal 64 bit to a 24 bit audio stream at some point in time before it exits the audio system, as most sound cards will not play anything higher than 24 bit. If the final destination e. a 16 bit CD or WAV format. this is a major source of the discrepancy you are hearing. You listen in 24 bit, while you then ask Reaper to convert at mixdown to a 16 bit file. Definitely in my experience these two representations do not exactly sound the same. How do I describe this. A certain detail is lost in the translation. A workaround would be to have a 16 bit dithering plug in at the end of the mastering bus, so that what you are hearing had already lost its 24 bit detail. i.e you are mixing with the final end in sight. The concept is similar to :

a) using a realtime mp3 coder/decoder while mixing so that you "hear" what the end user hears and this influences your mix decisions.

An example here:

http://www.sonnoxplugins.com/pub/plugins/products/pro-codec.htm

b) referencing on small speakers.

c) placing some mastering plugins on the bus so you "mix into them" and have some idea of what the mastering engineer is likely to apply. I.e you mix with the end in sight.


2. For the final mixdown, I would suggest you also export at the same frequency as your playback, and exactly the same bit depth or at least 24 bits, same as your audio interface. if mixing at 44 KHz the output would be at least 44.1Khz and 24 bits without any noise shaping by Reaper or with a dither to 24 bit dither as the last item on the master bus, to avoid Reaper making changes. Then use a high quality sample rate converter to dither to 16 bit. SOX I hear is a good example, or R8Brain. While Reaper does a good job, it cannot be the best at everything, so lets let it do its job, mix, sequence. nothing more. and leave sample rate conversion to better tools.

3. Similarly if you are using audio files which you did not record at you mix session sampling rate or bit depth, use an external sample rate converter to create appropriate versions of these files to avoid Reaper applying its own sample rate algorithms.

A bit belated but hope you get to read this and it helps

richie43
12-18-2014, 11:09 AM
Reaper does not downsample to play back at 24bit. 64bit floating point is not a conversion. Read up on this, you are somewhat correct about some of your info but not that. I unfortunately am out the door right now and have no time to delve into this, but I felt compelled to add some input.

Here's a start though:
http://en.wikipedia.org/wiki/Audio_bit_depth

Also, sample rate conversion has nothing to do with dithering. Dithering is when you are changing bit depth. Reaper actually does a great job at both, I have done some extensive testing with this and have recently ditched R8Brain and Sox for sample rate conversion (the files nulled to a ridiculous low level). But Dithering is a completely different thing with completely different requirements and times it's needed. You have some awesome and accurate info in your great post, but you are also giving out some misleading info.