Cockos Incorporated Forums

Cockos Incorporated Forums (https://forum.cockos.com/index.php)
-   REAPER Bug Reports (https://forum.cockos.com/forumdisplay.php?f=22)
-   -   ReaSurround automation major bug (FIXED) (https://forum.cockos.com/showthread.php?t=197727)

mavericksound 10-27-2017 06:20 AM

ReaSurround automation major bug (FIXED)
 
Panning of channels seems to be ok, but I have been trying to automate the "LFE" faders on the input faders pull-down menu, and also the "influence" on the speaker faders pull-down. Both work the first time through in touch mode, but then when I go to do another pass on a section, it will not work. I move the faders, or even draw out the keyframes, and it will not play back again.

I have to reboot reaper every time I make a change, and then it will play back correctly. I work on a Mac, but another person here tried it on a PC and has the same issue there, so it does not seem to be an OS problem.

Please help! Thank you!

schwa 10-27-2017 07:05 AM

Fixing, thanks for the report.

mavericksound 10-27-2017 07:38 PM

Wow! That was fast! However, I downloaded the latest version that shows the fix, but it's still behaving the same. When I do the 1st pass it's fine and plays back fine. Then second pass, it shows that it's drawing out the keyframes correctly, but on playback of that pass, the slider bar stays in a locked position, and the automation will not play back.

Thanks!

schwa 10-28-2017 07:56 AM

Hm. Are you editing the parameter with the mouse on the slider, or the mousewheel, or... ?

schwa 10-28-2017 08:41 AM

Actually, never mind. The problem is that these little "trackbar" sliders, which we use almost nowhere, have some different behaviors from the regular REAPER faders. We're just going to replace the trackbars with small versions of the regular faders and then everything should be fine.

mavericksound 10-28-2017 08:50 AM

Ok that sounds good. But it also happens when I physically draw out the keyframes. They draw out fine, but then they won't play back. This is still only after the first pass when I'm making changes on the 2nd pass. If I switch to read mode, it still doesn't play back until I reboot.

schwa 10-28-2017 08:52 AM

Pretty sure that's the same bug. If you open the project, never touch the LFE trackbar (little slider), and draw automation, does the automation play back correctly?

mavericksound 10-28-2017 09:51 AM

AHHH!!! I think you hit it on the head. Just kept drawing the keyframes only and it worked! The slider also moved correctly along with the keyframes. Did several passes that way and it was all good. Then went to the slider and tried that again and it stoped working. I also did confirm that physical LFE output does not work either when everything stops.

Thanks!!!

mavericksound 11-06-2017 07:22 AM

Is there a projected ETA on the new sliders? I'm headed onsite tomorrow to do a 7.1 and 5.1 mix. I can muddle through using the keyframe drawing, but really looking forward to the sliders.

schwa 11-06-2017 08:57 AM

The fix has been in prerelease builds since 10/28. We don't recommend using prerelease builds for production work, but they are available. If you want to test the fix, that would be great. There are instructions in the prerelease forum about how to do a portable install, if you want to leave your current production install unaffected.

5.62rc1 will be posted shortly including this fix, and hopefully 5.62 final within a day or two.

mavericksound 11-15-2017 07:39 AM

Awesome! I was able to get it installed on the last couple of days mixing and it worked beautifully!
Thanks You!

However, after spending more time with the panning, I'm having the same problems with the knobs up top: Diffusion bias, Diffusion level, etc. Except this time, I can do the automation, make changes and play back fine, until I quit Reaper and re-open. Then the diffusion is wrong... mainly on the bias. Sliders would also be great for these, but then I can see there would be a problem with the rotate function without a knob. I'll leave that to you brilliant designers to figure out.

I had a couple of other issues, but they are not bugs, so I will add them to feature requests.

Thanks again! This is potentially an incredibly powerful tool!


All times are GMT -7. The time now is 11:11 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.