Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

API: send/receives/routing display issues Issue Tools
issueid=2642 06-19-2010 02:09 AM
Mortal
API: send/receives/routing display issues
API: external (eg Csurf) send/receives/routing display issues

Just visual issues but when they're updated through the API, new sends/receives values are not "notified" to the mixer, routing matrix, "Control" window, etc..:

Quote:
Originally Posted by nofish View Post
http://www.swfcabin.com/open/1266450378

In this screencast I'm adjusting the send amount via the BCR2000 with this plugin found here:

http://forum.cockos.com/showthread.php?t=48376

The display in the MCP only updates when I hover the mouse over it.
Also, there are similar routing update issues (also done through the API):
- Create 2 tracks
- Create sends/rcvs 1->2, 2->1
- "Cut" the routing on track 1 with "SWS/S&M: Cut routing for selected tracks"
=> track 2's IO button still enlighten while routings have been removed (using TrackList_AdjustWindows() doesn't help)
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category GUI and graphics
Status Fixed
Priority 5 - Medium
Affected Version 3.60
Closed Version 4.721
Yes votes 10
No votes 0
Assigned Users (none)
Tags (none)

08-14-2012 05:43 AM
Human being with feelings
 
Fingers crossed for a fix here - it affects the SWS extensions Snapshots feature, which I posted about here: http://forum.cockos.com/showpost.php...&postcount=943

This is still present as of 4.25 & the 4.26 release candidates...
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.