Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

the following midi inputs could not be opened Issue Tools
issueid=3174 01-10-2011 05:02 AM
Human being with feelings
the following midi inputs could not be opened
if I focus on another window, midi devices go away until I restart reaper

not sure if it happens on PC, but it does on my mac and a few other user's confirmed:

open reaper (and have midi devices plugged in. I use a radium49.)
keep reaper open, but go and browse the web for like 5 minutes
when you go back to reaper you get a midi inputs could not be opened error and the only way to get your midi devices back is to close reaper and open it again.

I have had this issue in reaper 3 and the new alphas as well.

*edit* 2/07/11 persists in alpha 38
*edit* 3/09/11 seems to be fixed in latest alphas, but persists in the v3 cycle.

discussion thread:

Justin's words about putting into v3:
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category MIDI recording and playback
Status Fixed
Priority 1 - Highest
Affected Version 3.73
Closed Version (none)
Yes votes 11
No votes 0
Assigned Users (none)
Tags (none)

01-10-2011 05:03 AM
Human being with feelings
02-06-2011 02:12 PM
Human being with feelings
I am having the same problem, except I doesn't just happen when I navigate away- if I open up another VSTi i lose all of my MIDI ports. In fact, restarting Reaper doesn't even work- it just tells me I don't have any MIDI ports. I have to reboot my whole computer to get them back. What is going on? I am using a pretty old Opcode Studio 128x Midi interface- it actually plugs into a serial port on my computer. Is this part of the problem? Just for background- I'm a very experienced Cubase user who's evaluating reaper- I'm intrigued, and I want to be a Reap-ite VERY badly, but I've been so frustrated by the way Reaper handles MIDI that I'm getting discouraged about making the switch. Please help!!!
02-07-2011 10:00 AM
Human being with feelings
This problem applies to both vers. 3 and vers. 4 alpha. I know the devs. have tried to fix it earlier on, but as it seems with no luck :-)....
02-07-2011 10:21 AM
Human being with feelings
Same for me - all the way to Raper4alpha38.

Mac OSX 10.6.6 with M-Audio Fastrack Pro but I had same problem with previous Yamaha UX96 midi interface.
02-08-2011 04:24 AM
Happened to me too some time ago (3.x & 4alpha). [edit]Win XP 32[/edit]. You have re-define your MIDI setup each time you start REAPER.

I fixed it this way:
- Delete "reaper-midihw.ini"
- Start REAPER and (re-)define your MIDI setup (i.e. enabled IOs, controls IOs, aliases) once for all
- Quit REPAER (a new file will be created, this one will be ok)

Remark: i think it's due to a conflict between 3.x and v4alpha. I reported several issues like that in the v4alpha bug thread. It definitly occurs in 3.x if you didn't do a v4 *portable* install or if you remove your v4 portable reaper.ini file (=> v3.x get corrupted)
02-08-2011 04:52 AM
Human being with feelings
It happens here, on XP64 - didn't get it with XP32, but then again I didn't have R4 Alpha on that install either. I thought it was an XP64 thing.

Interestingly, it only loses my Axiom ports, which are connected via USB. It doesn't lose my FF400 (firewire, obviously) ports OR my Alphatrack, which is also USB.

One of the difference(s) between the Alphatrack and Axiom is that the Alphatrack has drivers, whereas the Axiom is Plug n Play. Dunno if that has anything to do with anything, but it's worth mentioning.
02-09-2011 03:48 AM
Human being with feelings
Newbie here. Win7 32bit AOK. On x64 'cannot open the midi port' message appears when using Mackie Control and HUI and hitting 'play'. Same result on both Midisport 4x4 and RME Hammerfall. Other controls seem OK.
x64 Reaper flys.
03-04-2011 02:34 AM
Human being with feelings
Hey guys, I had the same issue when trying to use rtpMIDI as a MIDI interface in REAPER for control via the AC-7 app from an iPod Touch.

I found in a post somewhere that if you're using a control surface then the MIDI interface(s) you set under Control Surfaces must be not be enabled in the MIDI devices section. It seems that the control surface needs to have complete access to the device and when Reaper tries to open a connection to the MIDI interface it can't.

Sucks if you a control surface and and other midi device on the same midi interface. It didn't matter to me because I was using a virtual MIDI interface set up just for the controller.

Is having a control surface configured the common thread here?
05-13-2011 01:13 AM
Human being with feelings
update: it is 100% fixed in v4, we are just waiting for them to follow through on the v3 fix:

see here:
01-04-2012 10:11 AM
Human being with feelings
*edit* Solved. Now on I'll read the whole thread before posting...
05-03-2012 08:33 PM
Human being with feelings
Windows XP sp3 M-Audio Oxygen 49 Reaper 4

Always get the error

Have to keep the Keyboards' Power off
Once Reaper is running I power up the Oxygen go to the preferences midi devices double click the Oxygen then hit apply
It then shows up ready to work!
05-04-2012 07:27 AM
Super Moderator (no feelings)
Sorry for the trouble! Please post bugs/help requests in the appropriate forums first, not here in the issue tracker (a database for confirmed REAPER bugs). If you still have the issue (which may be completely different from this actually fixed ticket), can you repost this in the forums for further investigation, please? Thanks!

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 04:34 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.