Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

reaper plays/read an end of midi note randomally which shouldn't be read/played (which is out of the area) . Issue Tools
issueid=3293 03-24-2011 03:37 AM
Human being with feelings
reaper plays/read an end of midi note randomally which shouldn't be read/played (which is out of the area) .
see inside...

please see the image for more details:

[img]http://img683.**************/img683/5586/randomshitu.png[/img]
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category MIDI recording and playback
Status Fixed
Priority 2
Affected Version 3.73
Closed Version 4.0
Yes votes 26
No votes 0
Assigned Users (none)
Tags MIDI events, note

05-29-2011 12:47 PM
Human being with feelings
 
lets get rid of this embarrassing behaviour ???

Vid:
https://www.youtube.com/watch?v=1NuaPMeRzd4

follow this thread for more details: http://forum.cockos.com/showthread.php?t=81062
Reply
06-01-2011 03:45 AM
-blšnk-
 
Confirmed for notes that end exactly (snapped) at loop start position.


Status changed to "Confirmed".

EDIT: Here's a comment from the discussion thread which might be hinting at something:

Quote:
Originally Posted by Fabian View Post
I DL'ed the project from the FR and ran it. I could not hear any problem... until I upped the asio buffer! At 64 samples buffer I do not get any random play of the last note in the first item. At 128 samples (and above) I do get it.
Myself I don't get rid of the problem when reducing the ASIO buffer to 64 on my Tascam FireOne. I've got no other device to test here, unfortunately.
Reply
06-02-2011 01:39 AM
-blšnk-
 
Licecap of ReaControlMIDI registering the note at every loop start:



I am adding that project (1 track, 1 note, 1 ReaControlMIDI)
to the issue ticket.

What's weird about it is that some synths (eg ReaSynth) won't make a sound, even when that short blip of a note is sent for sure. Fabian (who got it sounding only with buffer settings above 128 samples) confirmed that the note does register in ReaControlMIDI even with lower buffers - but makes no sound for him.
Reply
07-29-2011 08:46 AM
Administrator
 
Edit: actually we might have a fix for this in 4.0 :)
Reply
This petition for a change to Fixed was accepted
08-11-2011 12:25 AM
Human being with feelings
 
FIXED (4.01)
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.