Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

MAC OS X Keyboard assignation problem Issue Tools
issueid=3550 08-25-2011 04:06 AM
Human being with feelings
MAC OS X Keyboard assignation problem
Some keys in Macintosh keyboard don't send the good value (in the Action window)

see this thread http://forum.cockos.com/showthread.php?t=77926

I'm stiil having this problem, even in reaper 4.01. And I don't think it's about the azerty or american keyboard:

For example the keys F16 until F19 (wich are typically Macintosh keys I think) are interpreted in the Action keyboard input windows as "MIDI f9 00 00"

Others strange keys:


$ => "Shift+4"
=> "MIDI f9 00 00"
1 => "Shift+7"
shift+1 => "shift+1" (this one is ok!!??)
2 => "MIDI f9 00 00"
5 => "shift+9"
6 => "MIDI f9 00 00"
F13 => "Printscreen"

It's with an apple azerty belgium keyboard.


Anyone could try just typing F16 to F19 keys in the Assign windows, because these keys are the same in belgium or american keyboards....

Thank you
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category OSX particulars
Status Not a Reaper Bug
Priority 3
Affected Version 4.01
Closed Version (none)
Yes votes 1
No votes 0
Assigned Users (none)
Tags (none)

07-03-2012 03:39 PM
Human being with feelings
 
Hey y'all
first time poster here... and I start out with saying sorry for bumping an old thread.
I had the same problem as the OP (at least with the F13-F19 keys) with a german keyboard layout.
A workaround is to create "Application Shortcuts" in the "System Preferences" of your mac.

here's an example: if you want to assign "Load window set #01" to "F16" do this:

1) Open up System Preferences and go to Keyboard > Keyboard Shortcuts > Application Shortcuts (in the left pane)
2) Click the + button below the right pane, choose Application: REAPER.app
3) in the field "Menu Title" write "Load window set #01" (exact name as in the reaper menu)
4) Click the "Keyboard Shortcut" field and hit the F16 key
5) Click the Add button. done.

worked for me, hope it helps someone else as well!
best
Tom
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.