Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Windows 7 (64 bit OS) running 32 bit Waves plug ins freezes Reaper Issue Tools
issueid=3717 10-29-2011 12:59 AM
Human being with feelings
Windows 7 (64 bit OS) running 32 bit Waves plug ins freezes Reaper
64bit OS Windows 7 / 32 bit Waves plug ins / 32 bit Reaper = Reaper freezes when Waves plug ins are added to track

I am running a Windows 7 64-bit OS with 32-bit Reaper so that I may use my 32-bit Waves plug ins. Often when a DX Waves plug in is added to a track, Reaper will immediately stop responding, resulting in Windows 7 'stopped responding' message "REAPER has stopped working: A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

When forcing the issue, adding "DX: Waves LinEq Broadband Mono" & "DX: Waves RVerb" to a track have a high probability of freezing Reaper. However, adding any Waves plug in, or particularly dragging a Waves plug in from one track to another, may freeze Reaper - it's not specific to these two. There are no problems with Cockos plug ins or JS plug ins.

Note, sometimes you have to add a few Waves plug ins to a track before you freeze Reaper.

I have tried uninstalling my plug ins and reinstalling them. I have tried uninstalling Reaper and reinstalling it. I have tried versions 3.75 and 4.10 of Reaper. None of these solutions have solved the problem.

It's worth noting that my plug ins work fine on Reaper on my Windows XP computer (32 bit OS / 32 bit Reaper / 32 bit Waves plug ins), so it's not the plug ins themselves. I think it's something about Windows 7 64, Reaper 32, and Waves 32 that are in conflict.

I can no longer work effectively with Reaper, which is horrible because it's a great DAW. Any help would be most appreciated.
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Plugins
Status Misdirected Post
Priority 2
Affected Version 4.10
Closed Version (none)
Yes votes 0
No votes 1
Assigned Users (none)
Tags (none)

10-29-2011 10:08 AM
Human being with feelings
What on earth possesed you to use the DirectX versions of the plugins ? Did they work alright before a certain version of Reaper ?

I use the Renaissance Maxx bundle v7.1.6, VST versions, with Reaper 32-bit on Windows7 x64, and even though the plugins take a few seconds to instantiate, they work ok.

It's been five or six years since I last ventured in to DirectX country with Waves. You might want to switch to VST versions of the plugins in any case. The DX format is done.
10-29-2011 05:27 PM
Human being with feelings
vst will work just fine. in fact the machine I am typing on has a few waves plugs on it and is working fine in 32bit reaper.

Switch to VST and all will be well.
Unless of course it is an issue not related to waves and reaper...
10-30-2011 07:24 AM
BMU BMU is offline
Human being with feelings
I don't think it's a directx, Reaper 32 or Waves issue. I get the same running Win 7 64, Reaper 64 4.10 and a mixture of 64 and 32-bit plugins. I think it's one or more of the 32-bit plugins causing this, prime suspect is probably Peavey Revalver. But it hasn't bothered me enough to troubleshoot in detail. Reaper freezes perhaps once in two hours for me. Once it unfreezes, it won't play audio. It does play midi. Work is saveable. I haven't lost anything due to this. A quick restart of Reaper and I can carry on.

Previously under Vista 32, Reaper 32 3.76 and the same plugins, things were stable as a rock.

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 06:08 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.