Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Quad Capture (Roland UA-55) +DXi = freeze Issue Tools
issueid=4128 05-02-2012 05:27 AM
Human being with feelings
Quad Capture (Roland UA-55) +DXi = freeze
Using Reaper (last version) with Roland UA-55 Asio causes audio system to freeze when (certain) DXi are used

I have found a strange bug, and I think it is specific to Reaper, at leat partially.
I am using Reaper 4.22 (rev c07d16).
When using DXi instrument, at least Cakewalk TTS-1 and AlienWare Revalver (that I got with Sonar Producer 4), Reaper freezes.
And even more, the Quad Capture ASIO becomes then unavailable, even to other DAW (Sonar Producer 4 and Sonar X1 LE).
Another symptom: if I "kill" Reaper, it stays present in the processes list and all I can do is usually to reboot the computer, in order to close Reaper and to be able to use UA-55 ASIO again. Even logging off does not always kill reaper (in Windows 7, I then get a ghost session with only CRSS.exe and Reaper.exe).

This does not seem to happen with Sonar X1 LE nor with Sonar Producer 4: DXi can be used just fine (but I can say that I have done a lot of testing).

Test environment:
Windows 32bits. I used Windows XP sp3 on an ACER E560 HE79 and Windows 7 on an HP Compaq Elite 8000 SFF. Same result.
I used UA-55 drivers v1.0.1 (the ones on the CD) and v1.50 (from roland.com site): Same result.
I tried the various Reaper combination for ASIO drivers (Pre-zero... Ignore): Same result.

I usually configure Quad-Capture ASIO for 48000kHz and a block size of 128.

I am a professional of computer development (I used to develop WDM kernel drivers, at an "intermediate level", and some applications involving a lot of interactions with system layers and Windows APIs) so I can do things such as creating dump files of the frozen Reaper if that could be useful, run diag tools, alpha/beta versions, import Reapers symbols and dumpa a stack trace etc., use Windows debugger, if I am told what to do.

Maybe not a very high priority issue (who uses DXi these days? Well TTS-1 was great and there is no real VST equivalent ), but still worth reporting
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Stability
Status Misdirected Post
Priority 5 - Medium
Affected Version 4.22
Closed Version (none)
Yes votes 0
No votes 0
Assigned Users (none)
Tags (none)

05-02-2012 06:39 AM
Super Moderator (no feelings)
Sorry for the trouble! Can you repost this in the forums for further investigation, please? (We can't move stuff easily between issue tracker and forums, sorry.) Thanks!

This doesn't seem to be a general issue with REAPER and TTS-1 (since people have it working with REAPER on both XP and W7), please see this thread for a possible cause:


Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 01:21 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.