Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Looped playback and PDC inceasingly delays MIDI Issue Tools
issueid=5178 04-25-2014 01:36 AM
Human being with feelings
Looped playback and PDC inceasingly delays MIDI

When playback is set to a loop and the plug-in on the track declares a plug-in delay, MIDI is delayed by an increasing amount for each loop.

Here is a 1-bar loop of 1 MIDI note, with 3 FX on the track: a MIDI monitor, Alchemy and a second MIDI monitor. The PDC figure in the track FX window is 64/256 and it's the same with other FX.

... Big pic: https://i.imgur.com/Dm97L0E.png

If I disable Alchemy, the MIDI timing is fine.

----------------------
Original BR prompting this Issue:

http://forum.cockos.com/showthread.php?t=138784
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category MIDI recording and playback
Status Fixed
Priority 5 - Medium
Affected Version 4.61
Closed Version 4.62
Yes votes 3
No votes 0
Assigned Users (none)
Tags PDC

05-02-2014 07:28 AM
Super Moderator (no feelings)
 
I attached a simple .RPP using ReaSynth, ReaFIR and another ReaSynth to demonstrate the problem. The problem is not related to VSTi per se, it has to do with plug-ins introducing latency in the chain in general, any instrument plug-in after an PDC-invoking plug-in will receive delayed MIDI on the second and consecutive loop pass.
Reply
05-03-2014 03:08 PM
Human being with feelings
 
Fixed in v4.62pre12 - May 3 2014,
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 08:12 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.