Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Allowing 'All notes off' (cc123) on MIDI hardware outputs Issue Tools
issueid=47 06-13-2009 03:08 PM
Mortal
Allowing 'All notes off' (cc123) on MIDI hardware outputs
Allowing 'All notes off' (cc123) on MIDI hardware outputs

To the point:
Allowing 'All notes off' (cc123) on MIDI hardware outputs - as an user option ? if fired by ReaControlMIDI ? ...

Details:
Non native cc 123 messages still filtered from midi hardware outputs. They're filtered if they're fired by an FX, a JS for example, and even if this FX is ReaControlMIDI (ending the FX chain).
Other details in that thread: http://forum.cockos.com/showthread.php?t=26237

[EDIT] turned into a bug. JS sending "all notes off" attached.
[EDIT2] Same issue when routing CC123 from a track to another. Still present in 3.12.
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category MIDI recording and playback
Status Fixed
Priority 5 - Medium
Affected Version 3.02
Closed Version 3.22
Yes votes 2
No votes 0
Assigned Users (none)
Tags CC, MIDI hardware

06-30-2009 02:25 AM
Mortal
 
Please, Mods !
I want to turn this FR into a bug: I just realize that I'm asking to be able to send all notes off... from a DAW !

So, as a bug, the reproductyion step is: on a track (with Midi hardware output), send a "All notes off" message from a JS.
- The expected result is: the midi message is present on the hardware output (e.g. monitoring in MidiOX)
- The currenty result is (v3.04): the midi message is NOT present on the hardware output

Thanks.

[EDIT] easiest repro: click the "All notes off" button in ReaControlMIDI !
Reply
06-30-2009 03:05 AM
-blšnk-
 
Yes, I confirm this misbehaviour. I would consider this a bug as well.
Reply
06-30-2009 03:21 AM
Human being with feelings
 
Moved to Bug Reports issues :)

And I added a couple of Tags
Reply
01-26-2010 08:35 AM
Mortal
 
I don't want "beeing a dick" (new english expression I've just learnt, I hope it works here ;-) with this BR (FR?) or with another "pro" speech, "my BR is the most important" and stuff.. But I really saw the REAPER solution abandonned in a pro context just 'cause of this bug. So, I'll just say that even if not much users seem to be annoyed with it, this IS a real bummer, there're also some people you never heard of..

so, I warn everybody that I'll bump this thread in 6 months (so the 07/26/2010) if it remain stuck to "unconfirmed" (Guys, "unconfirmed" !? can someone look me in the e-eye and tell me this bug is "unconfirmed" !?)

note for the mods: the bump will be in-topic, something like "IMHO, a DAW without all notes-off is just like a car without brakes"


[edit] aaaahhhh!! this was intended to be a private post!

[edit2] thanks for confirming schwa, much appreciated, really! I delay the bump to 2011 (but for a fix ;-).
LOL!! Finally, I've "been a dick" here.. with this public bump.. Sorry, it was really not intended.
Reply
This petition for a change to Fixed was accepted
01-31-2010 08:23 AM
Mortal
 
FIXED in v3.22.
Cockos, speechless... in short.. a big "THANK YOU!"
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.