Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Feature Request

Snap Grid Not Aligning Properly (non 4/4) Issue Tools
issueid=4224 07-03-2012 03:37 PM
lxm lxm is offline
Human being with feelings
Snap Grid Not Aligning Properly (non 4/4)
Projects set to a 5/4, 3/4 etc time signature that have the grid set for (whole notes 1 or 1/2) the grid shows as if it is 4/4

Example:

Projects set to a 5/4, 3/4 etc time signature that have the grid set for (whole notes 1 or 1/2 notes)grid shows as if it is 4/4. The minimum grid setting has to be 1/4 in order for the grid to line up properly.

Metronome clicks ONE on 1.1, 2.1, 3.1 etc. The grid should work accordingly regardless of the time signature.

Issue Details
Issue Type Feature Request
Project Deprecated REAPER issue tracker
Category Audio recording and playback
Status Suggested
Priority 5 - Medium
Suggested Version 4.22
Implemented Version (none)
Users who would use this feature 35
Users who would not use this feature 3
Assigned Users (none)
Tags (none)

08-13-2012 01:09 PM
lxm lxm is offline
Human being with feelings
 
Wish this could get fixed. It seems like a very simple fix. PLEASE!
Reply
12-06-2012 08:00 AM
Human being with feelings
 
I think, what is needed is the option to select a grid size of 1 bar. Currently grid sizes seem to be specified in terms of note size so selecting "1" means a whole note which is 4 quarter notes. Naturally if you select a whole note grid in a time signature that only contains 3 quarter notes per bar (3/4), there is going to be a problem.
Reply
12-06-2012 11:01 PM
lxm lxm is offline
Human being with feelings
 
I still see the same behavior in the latest pre(3/4 time sig). How is this implemented? Picture attached.


image ru
Reply
12-07-2012 07:07 AM
Human being with feelings
 
Imho this should be a bug report instead of a FR. +1 in any case.
Reply
12-12-2012 08:04 PM
lxm lxm is offline
Human being with feelings
 
Quote:
Originally Posted by lxm
I still see the same behavior in the latest pre(3/4 time sig). How is this implemented? Picture attached.


image ru
Can anyone explain plz? :)
Reply
07-06-2013 08:30 PM
Human being with feelings
 
Just ran into this problem as well. I hope this gets fixed real soon. This should definitely be considered a bug. A lot of people don't make music that is exclusively in 4/4.
Reply
07-07-2013 04:06 AM
Human being with feelings
 
+1 definitively
Reply
07-07-2013 04:10 PM
Human being with feelings
 
This "bug" is the main reason i rarely make things that aren't in 4/4 as its too hard and frustrating to edit...
Reply
07-08-2013 09:03 AM
Human being with feelings
 
Status says "Implemented"!?
Reply
07-08-2013 09:04 AM
Human being with feelings
 
Yeah that sounds wrong.
Reply
08-13-2013 12:38 AM
lxm lxm is offline
Human being with feelings
 
Quote:
Originally Posted by EvilDragon
Yeah that sounds wrong.
It is! Is this some sort of practical joke?
Reply
08-13-2013 12:24 PM
Administrator
 
I think that several versions ago the ruler code was updated to more reliably show the starts of measures regardless of time signatures. That is probably why this was marked as implemented, even though the arrange area grid still is based on beats, rather than measures.
Reply
08-13-2013 04:27 PM
Human being with feelings
 
Ruler is still buggy (using 4.5repre6) when dealing with a lot of tempo markers (I think it happens if you have more than 1 marker per measure). Working with tempo mapped material can really become confusing even in 4/4

Reply
08-14-2013 02:08 AM
Human being with feelings
 
This is why Reaper should also have an option for linear grid (fixed spacing), like in Cubase.

http://forum.cockos.com/project.php?issueid=2502
Reply
08-09-2014 03:47 PM
Human being with feelings
 
Can confirm this is fixed now in 4.71, at least as far as OP concerns go.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.