Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

[4.61] MIDI editors silently applies quantization for some items when editing multiple items Issue Tools
issueid=5222 06-03-2014 04:08 AM
Human being with feelings
[4.61] MIDI editors silently applies quantization for some items when editing multiple items

Either create a new project file and start at step 1 or get this project file and start at step 4.
  1. New project. Create two tracks with a midi item for each one.
  2. Open the first item in the midi editor, set the grid to 1/16 and draw in some notes.
  3. Open the second item in the midi editor, set the grid to 1/2 and draw in some notes.
  4. Open both items in the midi editor, (check that both are editable) select all notes, change the grid to 1/32.
  5. Press (Q) to open the quantization dialogue. You should now see the changes you get if you'd click on "Commit" (don't do that)
  6. Instead, click on "Cancel" (so you don't commit) and quit the editor.
  7. Open all items again: quantization has been applied silently (bug)
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Editing behavior
Status Fixed
Priority 2
Affected Version 4.61
Closed Version 5.20
Yes votes 2
No votes 1
Assigned Users (none)
Tags (none)

06-03-2014 07:46 AM
Super Moderator (no feelings)
 
The grid setting doesn't make a difference, can be 1/16 on both items.

Project file attached to this ticket, created this way:

0. Create 2 tracks

1. Create an item on each track, with some off-grid events so you have something to quantize

2. Open both in the editor, make both editable

3. Hit Q and watch quantization at work, then hit "Cancel" -> quantization looks like it was removed, close the editor

4. Open the items again or only the second item - quantization has been committed to the second item*.

*The misbehaving item is always the one which was marked as target for editing, so you can also make track 1 misbehave.

Here's some more oddness (which is also how to repair the item with the unwanted quantization):

5. Open the second item with the unwanted quantization only, then hit Q again, then 'Cancel' again -> unwanted quantization is gone and events in that item react in normal ways to the quantization dialog again (when opened alone in editor of course).

Edit: this may be by design, but it does not work when other items are visible in the same editor.
Reply
06-03-2014 07:51 AM
Human being with feelings
 
Yes, this bug is not grid related. The grid is merely used to demonstrate the problem. Creating off-grid notes reduces the amount of steps necessary to guarantee the bug will show up.
The cause is that the MIDI editor has several bugs when editing items that do not have the green arrow activated (= are not in focus). This can lead to a diversity of problems including broken undo system or this specific bug.
Reply
This petition for a change to Fixed was rejected
05-30-2016 09:48 AM
Human being with feelings
 
FIXED (5.201)
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 09:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.