View Single Post
Old 03-27-2014, 10:17 AM  
Banned
Human being with feelings
 
Banned's Avatar
 
Join Date: Mar 2008
Location: Unwired (probably in the proximity of Amsterdam)
Posts: 4,868
Default

Quote:
Originally Posted by N2NPro View Post
Hi Banned, yes, the motorized faders have priority. The assignable knobs would be very nice. Perhaps as I become better acquainted the procedure of mapping etcetera, I may be able to tackle some of these things my own.
Looking forward to getting my hands a bit dirty

N2N
Cool. Ok, let's start getting a bit practical then.

There are two important things to set up before we can proceed to test a script. Let's get these out of the way first, so we can get to the fun stuff:

[1] Configure an 'OSC Control Surface' in REAPER;

[2] Install OSCII-bot and set it up to communicate with [A] the OSC Control Surface (using OSC), and [B] with your StudioMix device (using MIDI).

For [1], you open REAPER, and go Preferences > Control Surfaces > [Add] > Control surface mode: OSC (Open Sound Control). Then, at the "Pattern config" drop-down menu, choose "(open config directory)", which should open the folder (in Explorer for Windows, Finder for OS X) where configuration files for REAPER's OSC Control Surfaces are kept.

While the default configuration should work, it would have REAPER send a whole lot of OSC messages for things we aren't interested in ('flooding'). So it makes sense to use an optimized version of the default configuration, where lots of things are disabled (by 'commenting out' lines, i.e. prefixing them with a "#" character). (Btw, note that editing the Default.ReaperOSC file itself does not have any effect - so we *have* to use a different file if we wish to change anything.)

Here is my configuration file for this setup: OSCII-bot+StudioMix.ReaperOSC. Unzip and move to the folder you just opened. Now go to the "Pattern config" drop-down menu again, and choose "OSCII-bot+StudioMix" to select this configuration file.

Side note: these .ReaperOSC config files are in fact simple text files, but they have the extension .ReaperOSC. For editing convenience, you may want to instruct your operating system to open these files with a plain text editor when you double click them.

Next, take a look at the settings for the IP networking. Make sure the boxes for receive and send are ticked, as well as "Allow binding messages to REAPER actions and FX learn". The default port numbers and IP addresses should probably work; we'll test those next, when we have OSCII-bot running.

[2] Install OSCII-bot. First, we start with a very simple script for testing the MIDI and OSC input/output, to achieve this:

[REAPER] <==OSC==> [OSCII-bot] <==MIDI==> [StudioMix]

Connect and switch on your StudioMix device. Then, start OSCII-bot. At the top of its window, it should tell you the path to the folder where scripts should be installed. Open that folder, and put this file in it: IOTest.txt. Open that file in a plain text editor.

In REAPER > Preferences > Audio > MIDI Devices > MIDI hardware settings, note the name of MIDI input and output ports associated with the StudioMix device (probably something like "StudioMix In 1" / "StudioMix Out 1"). Also, preferably set the device to <disabled> in REAPER - since REAPER won't have any use whatsoever for the unprocessed NRPN messages that the StudioMix is sending out.

In OSCII-bot, click the "Reload scripts" button in the right bottom corner. It may work out-of-the-box, but don't be surprised if some error messages now appear in OSCII-bot. We need to tweak the config until they're gone.

For the MIDI input (MIDI from the StudioMix device to OSCII-bot), you need to configure this line:
Code:
@input in1 MIDI "StudioMix"
Similarly, for the MIDI output (MIDI from OSCII-bot to the StudioMix device), you need to configure this line:
Code:
@output out1 MIDI "StudioMix"
You should only edit the device name, i.e. the parts between the quote marks ("StudioMix"). (NB: everything coming after "//" on a line are only comments, and don't affect anything.)

For OSC, the input and output needs to match the settings used in REAPER's OSC Control Surface configuration. For that, you may need to tweak these lines:
Code:
@input localhost-input OSC "127.0.0.1:9000"
@output localhost OSC "192.168.1.2:8000" 1024 0
You can (and perhaps have to) use different IP addresses and/or port numbers - whatever works for you. You should probably try to match the default settings shown in REAPER's OSC Control Surface for the IP addresses; I think REAPER uses whatever is already working on your system. Compare the lines above with the settings I used for REAPER's OSC Control Surface:



Note that:
- the settings used for 'Receive on port' / 'Host IP' match the settings at @output;
- the settings used for 'Send to port' / 'Device IP' match the settings at @input.

If you see any errors in OSCII-bot, try editing the IOTest.txt file, saving, and reloading the script again in OSCII-bot.

Any questions or problems so far? Lets hear it.
__________________
˙lɐd 'ʎɐʍ ƃuoɹʍ ǝɥʇ ǝɔıʌǝp ʇɐɥʇ ƃuıploɥ ǝɹ,noʎ

Last edited by Banned; 03-27-2014 at 12:36 PM. Reason: added some clarification
Banned is offline   Reply With Quote