View Single Post
Old 10-23-2014, 12:27 PM   #4
gofer
-blšnk-
 
gofer's Avatar
 
Join Date: Jun 2008
Posts: 11,165
Default

Actually, if you disable "Grid snap settings follow grid visibility", things will snap to the spacing defined in "Grid snap spacing" (which is grayed out when the "follow visibility" option is enabled), whether the grid is visible or not. Assumed "Snap" is enabled, of course.

As the grid is definitely not visible when hidden, I think Reaper is just following the settings to the "t" here .

That's not saying I think it should be this OCD in this case. I'd probably prefer it to keep snapping - just, to which spacing?
Logically it would have to be the one in the grayed out spacing field, right? Or the grid spacing that would theoretically be there in your current horizontal zoom if the grid were not hidden?


A workaround if you need "Grid snap settings follow grid visibility" (which I certainly do):
Use SWS/BR: Toggle "Grid snap settings follow yadayada..." and "Options: Toggle grid lines" together in a custom action (and set something usable in the spacing field).
But you'd need to take care that the toggles stay in sync... maybe doable with a script?

Last edited by gofer; 10-23-2014 at 12:43 PM.
gofer is online now   Reply With Quote