View Single Post
Old 07-10-2019, 06:01 PM  
mustgroove
Human being with feelings
 
Join Date: Mar 2007
Posts: 443
Default

Got a weird bug with custom keyboard shortcuts

I have several keyboard shortcuts set up for nudging, which I use all the time:

- N is assigned to "Item edit: Nudge right by saved nudge dialog settings 1", and the saved nudge setting is to nudge an item to the right by 15 minutes.

- Q is set to "Item edit: Nudge left by saved nudge dialog settings 8", and the saved nudge setting is to nudge an item to the left by a very small amount.

I'm seeing a weird bug which only happens 1st time I try to use these shortcuts after Reaper has launched:

1) Launch Reaper, blank project is created
2) Create a track and draw a blank MIDI item
3.1) Hit N to nudge the item - instead of performing action assigned to N (nudge to the right by 15 minutes), the item is duplicated to the right.
3.2) Hit Q to nudge the item - instead of performing the action assigned to Q (nudge to the left a tiny bit), the item is duplicated to the left.

This only occurs the very first time I use these keyboard shortcuts after Reaper has been launched, whether in a blank project or in an existing project that has been opened. Every subsequent time I use these shortcuts, they work fine, either in the same project where the bug occurred, or in another project that was opened or created.

If I quit Reaper and re-launch it, the same thing happens again - those keyboard shortcuts are bugged, but only the 1st time I use them. Every subsequent time they work as expected.
mustgroove is offline   Reply With Quote