View Single Post
Old 06-15-2012, 04:59 AM   #3
Human being with feelings
Join Date: Jun 2012
Posts: 2

Originally Posted by ivansc View Post
First things first.

Have you tried looking in the main prefs menu for the ASIO and Audio Interface settings? (along with everything else)
Top menu bar: Options/Preferences/Audio/Device

If you have the drivers for the Tascam correctly installed, you should see in the Audio System a number of options, one of which should be ASIO.
If you are not even seeing this, you have not installed the Tascam ASIO driver correctly - and possibly the Tascam MIDI driver as well. More of this later.

If you see ASIO as an option, select it and move on to the next dro down box. Here you should see your Tascam ASIO device.

If it is there, select it. You are now routing your reaper audio through the Tascam's ASIO driver.

Next step is to enable your inputs and outputs in the appropriate box, then comes the interesting box.
ASIO configuration.

This should have all the available options for your particular interface.
Since they all vary and this piece of software is actually part of your interface, not reaper, I cant tell you what it will llok like, but there will be a setting for audio buffers. To be on the safe side, start with this set to something fairly large - 512 maybe? You can always lower it later to get better latency performance.

So you should now be able to insert track, enable it for recording and switch on record monitoring (little triangular speaker-like icon in the track controls. Cycles between on off and auto - I always use auto.

Plug in an instrument or mic and you should now have signal.
Come back to us if you dont.

And of course the next step is going to be helping you figure out VST plugins and VSTi instruments.

Note that Reaper comes with very little in the way of bundled instruments but some excellent effects plugins.

YES you have a steep learning curve because Garageband from my experience is really really easy to learn but not very powerful in terms of what you can do with it.
Hopefully you wont get too frustrated but the manual and the video tutorials on Youtube or from Johnny Ginese and Kenny G ( are incredibly helpful.
I opened the Tascam US-122 control panel.

This is what I see.


For this option there is a bar with the numbers 256 512 1024 and 2048

Then below this there is 'USB bandwidth usage' which has two options

These options are Midi and audio enabled and 'Midi enabled, Audio disabled'. The first one is selected.

The other option at the top of is 'Tuner'.

Does this mean that I did not properly install the drivers? It's not that it's not producing output, but only under the forementioned audio driver. Not the ASIO one.

And to answer your other question yes, I used the right pathway to get to the audio options in the program. I pretty much selected options-preferences-device. Like I said the ASIO driver is there for selection but not producing sound output. I tried enabling the different output options too, nothing. The only driver producing sound is the 'Waveout' one. And I wouldn't even mind using this one if I could resolve the latency issue in it. But it seems everyone is recommending the ASIO drivers.

Would you mind giving me some proper advice on how to make sure I download the drovers that include the ASIO audio driver?

Last edited by MusicalMantra; 06-15-2012 at 05:05 AM.
MusicalMantra is offline   Reply With Quote