View Single Post
Old 03-31-2020, 06:35 PM   #1
Human being with feelings
Sauraen's Avatar
Join Date: Mar 2014
Posts: 5
Default No sound from AU plugins

tl;dr: No sound comes through any AU plugins in Reaper, from multiple manufacturers. Mac OS 10.13, tried on Reaper 5.76, 5.99, and 6.07.

I'm developing a cross-platform, cross-format plugin with JUCE. I've done this many times before with VST2 and VST3 over the years, but for a long time I never tried AU (because I was unable to get the build toolchain working for AU--it works now).

In any case my plugin works correctly in Reaper on Windows and Mac in its VST3 version. However, the AU version will load up and the interface will work normally, but no sound comes out. In the process of investigation, I tried a JUCE demo AU plugin and several of the pre-installed Apple AU plugins. In all cases, no audio comes through the plugin. Unchecking the AU plugin to disable it allows the audio to come through again, as does turning the "wet" knob down from 100% (the dry audio fades in as expected).

From my own debugging on my own plugin, I can confirm that the "start playing" and "stop playing" functions are being called in the AU version of my plugin (Juce PluginProcessor:: prepareToPlay and PluginProcessor:: releaseResources respectively), but the actual audio processing function is never called (Juce PluginProcessor:: processBlock).

Typically I run all plugins in bridged mode (separate processes, so that when in-development plugins crash I don't lose work), but doing so caused the Apple AU plugins to not even load their GUIs properly (though mine and the demo JUCE AU plugin do load their GUIs correctly in this case). So I've tried with both bridged and non-bridged modes. I can't find any other AU-related settings in Reaper to play with.

Any suggestions?
Sauraen is offline   Reply With Quote