Thread: IPlug - Youlean
View Single Post
Old 03-14-2017, 04:05 PM   #12
Human being with feelings
Join Date: Nov 2016
Posts: 332

Ok, so I used the Cairo Windows libs in the 19th post here -, and with those I got the IPlugEffect, IPlugCairoEffect and IPlugLiveEdit example projects compiling and running in Windows 10 with VC2015 absolutely fine - LiveEdit looks really useful btw!. The IPlugEffectGUIResize project compiles without issue, but the app isn't resizing, it currently just has an adjustable window size while the knob retains its size and place.

XCode is still bringing issues. Tried compiling the examples with 8.1, but it gives the error "linker command failed with exit code 1 (use -v to see invocation)" and "ld: library not found for -lpng16". Was using the 10.11 SDK, but tried some others and didn't get it working with those either.

Getting my existing project to compile in Windows was also problematic.

The script isn't renaming some of the files if you try to duplicate a project other than IPlugEffect - I tried duplicating the IPlugEffectCairoGraphics project, but it left a few of the files with the previous project name instead of the new one.

To get my existing project to compile, I went along with adding my files to a duplicated IPlugEffect and made the following changes to my code:

changed all "#include "Youlean_Cairo.h" to "#include "ycairo.h"
changed all "youlean_cairo_base" to "ycairo_base"
changed all "ycairo_prepare_draw()" to ycairo_prepare_draw(mDrawRECT)""
Went into iautogui.h and replaced all occurences of mRECT with mDrawRECT
Removed ycairo = new ycairo_base();
changed "ycairo->attach_background(pGraphics, ycairo, IColor(255, 50, 50, 50))" to "ycairo->attach_background(pGraphics, IColor(255, 50, 50, 50))"

At this point it compiled, but on running it crashed with an Assertion Failed saying "Expression: imgResourceNotFound". I'd added the ID and FN values into resource.h and copied the png to the resources/img folder, but if I try to add the png to the project, it would say 'The operation could not be completed'
Bobflip is offline   Reply With Quote