View Single Post
Old 06-18-2018, 07:45 AM   #581
experimentfailed
Human being with feelings
 
Join Date: Jan 2012
Location: USA/Michigan
Posts: 88
Default Control Surfaces

I have 3 MIDI controllers: Keystation61, BCF2000, and BCR2000. At first, nothing worked and I had no MIDI ports at all. Then I tried running jack with the following:

Code:
jackd -Xalsarawmidi -d alsa --device hw:2 -r 88200 -p 256 > jack.log &
Then I got a bunch of MIDI ports in both JACK and REAPER (under MIDI Devices), was able to set enable+control on them, and they sprang to life - can play VSTi's with my keyboard, use transport, all the faders/kobs on the Behringer devices work, etc. After a process of elimination, I was able to configure aliases to identify which devices are on which ports (hopefully that's not a moving target).

Then I went to set up my BCF in Mackie emulation mode (which I had working in Wine+REAPER, so I know it works in general). Under Control/OSC/web configuration, I can add a Mackie Extender, and can select the MIDI ports then hit OK. However, nothing happens. No error, but no response from the BCF and REAPER does not respond to the BCF. When I go back into Control/OSC/web configuration, the Mackie Extender I added is still listed, but when I click Edit, the window is blank, except for the 3 dropdowns to select mode and midi ports, with only the mode still filled out (midi ports are no longer selected). I can set it up again, but it just does the same thing again.

Also, not sure how to reproduce, but a few times it somehow changed the mode to Faderport instead of Mackie...

This might require a bug report but figured I"d call out here to see if anybody else has had any luck...maybe I'm just doing it wrong.
experimentfailed is offline   Reply With Quote