View Single Post
Old 06-19-2018, 06:17 AM   #594
experimentfailed
Human being with feelings
 
Join Date: Jan 2012
Location: USA/Michigan
Posts: 88
Default

Quote:
Originally Posted by 4duhwinnn View Post
Have you tried a periods/buffer of 3
at 44100 or 48000?

Is there anything running at higher priority
than your audio? Seems like if it's up and running,
the glitches should be defeatable...
I have a pretty standard intel computer,
but the usb implementation is a ratsnest!
Cheers
No, haven't tried that as this is specifically relating to MIDI data and I don't think those settings affect that. Not having any audio glitches/crackling that would be symptomatic of too much sample rate or too little buffers. I'll try it anyway, just in case I'm wrong!

I run everything in default priority; no realtime. Even if I set high priority and realtime, however, I don't think that would sort this...It's far too severe to make me think it's a raw performance/scheduling issue, but again: I could be wrong so will save that as a hail mary.

Quote:
I bought myself a Roland SPD11 last week which I plan to use to feed midi into DrumGizmo. I haven't looked into the Jack / Midi / Reaper combination yet ...

ALSA midi would be nice, as the Jack implementation seems complex and prone for error.

I can't really play the drums, so I expect to do a lot of midi editing anyway
You shouldn't have any issues w/ an instrument MIDI controller, such as electronic drums or keyboard, in case you were concerned! My issue seems to only affect specifically when I set a device up as a Control Surface in REAPER, which is separate from "normal" MIDI configuration.

Quote:
I stopped using a2jmidid -e due to lags and stuck/missing notes and other issues. Then started using ALSA Sequencer MIDI driver and problems are gone.

If you use jack1 you can enable it as Jack says. I have jack2-dbus and have to enable it using "jack_control dps midi-driver seq [dps period 64 dps nperiods 3...]". In jack2 I guess it'll be "jackd -xseq [...]"
Thanks! I'll investigate that asap...Sounds very much like what I'm experiencing, only being a control surface it manifests in the form of missing button presses and jumpy fader movements. I'm using JACK2 so sounds like I'll have a bit to figure out on my own or will have to try to migrate to JACK1 somehow w/o breaking my system.

Last edited by experimentfailed; 06-19-2018 at 06:58 AM.
experimentfailed is offline   Reply With Quote