View Single Post
Old 06-19-2018, 06:43 PM   #596
experimentfailed
Human being with feelings
 
Join Date: Jan 2012
Location: USA/Michigan
Posts: 90
Default

I've done a bit more troubleshooting on my control surface issue. Mainly, I completely forgot that they were plugged into a USB hub. So I rearranged such that they are now plugged directly into the computer.

First, I tried and failed to figure out what kytdkut was talking about.

Then I started over on everything I've tried so far, thusly (after removing the USB hub):

Tried running JACK with "-Xalsarawmidi" again (sans a2jmidid), and weirdly, instead of previous symptoms (which were basically no comms with the control surface at all, and every time I tried to edit the entry under Control/OSC/web, the dialog was blank with only options to select mode and MIDI I/O), now I get the new symptoms that presented in a2jmidid - rare/intermittent input from buttons and jumpy fader movements from the control surface to REAPER). The interface issues seemed to clear up after removing the hub....?

Failing the retry of -Xalsarawmidi, I then tried a2jmidid without the USB hub, and encountered the same symptoms as above and prior.

Now it's late and I'm drunk. I'll probably think of more troubleshooting ideas tomorrow. The USB hub just seemed like a likely suspect, and I think I've proven that not only is it not the culprit, but have presented even more evidence that the issue is related to this build of REAPER and control surface handling. Of the 2 ALSA midi to JACK options I've been able to try, everything is fine until I try to set a device up as a control surface.

---

Quote:
Originally Posted by shosty View Post
I think I've come across a couple of bugs.

Sometimes after rendering the screen stays dark after closing the render dialog.

If jack is not started sometimes you get the windows saying that it's a demo, and the no devices found, but the main reaper window never appears. It is running in the background though.
I've had similar...Not sure how to reproduce the Demo/License screen but it stopped happening after I imported my license key.

If the main window is going black, try tapping F11, then again a second later (it toggles full screen though I've had troubles if I leave REAPER in fullscreen, then quit...when I restart the window won't show...Unfortunately, I can't remember how I fixed it). Still probably a bug but seems there's ways around the couple of GUI/graphics glitches I've come across.

Last edited by experimentfailed; 06-19-2018 at 06:48 PM.
experimentfailed is offline   Reply With Quote