View Single Post
Old 10-04-2019, 03:25 PM   #29
skylinkdave
Human being with feelings
 
Join Date: Feb 2019
Location: Las Vegas, NV
Posts: 6
Cool

Quote:
Originally Posted by brummbear View Post
Your MIDI settings should not be the problem. Maybe something trivial? Did you set track input to the M32 MIDI, Monitor Input?
I seem to have had a little bit more success. When I enabled my M32 on a track, I was able to record some notes, but still got no sound while playing live (until I saved the audio file and played it back).

Is it possible to get a KK controller to work within Reaper, or can it only be done while recording to a track? Is this a limitation with the M32 in Reaper?

Edit/update: I installed the DrivenByMoss 4 Reaper extension and I get the exact same functionality as I do from the ReaKontrol extension. The transport controls work, the knobs work, and I can record to a track with no sound, but the keyboard itself still does not work within Reaper itself.

Edit/update #2: I turned on "Record monitoring" for the track, and I can now hear what I'm playing while recording to a track. So I'm like 75% there...

Edit/update #3: With "Record monitoring" turned on and the track armed for recording, I can now play and hear the instrument on that track even while not recording. I think that does it!

Edit/update #4: A bit of advice: Download and install the ASIO driver to remove/reduce latency.

Consider this case solved, I'm happy with how it works in Reaper now. Thank you for everything!

Last edited by skylinkdave; 10-17-2019 at 09:34 PM.
skylinkdave is offline   Reply With Quote