View Single Post
Old 02-07-2019, 04:30 AM   #3
light_user
Human being with feelings
 
Join Date: Feb 2019
Posts: 2
Default

Quote:
Originally Posted by cyrano View Post
Quit OSCII bot (and maybe Reaper and other audio/midi related apps).
Select OSCII bot's icon in the Finder. Type Command-I (i, not L), or use the "Get info" menu item.
Check "Prevent app nap". Close window.

Think that should work in Sierra too, but don't have a Sierra machine at hand. It doesn't work in High Sierra or Mojave!

Alternatively, you can turn off app nap completely in Terminal:

Code:
defaults write NSGlobalDomain NSAppSleepDisabled -bool YES
Checkbox is not available. System-wide disable of app nap is not possible for me, otherwise my battery is draining.
I found a perl script on the internet to turn off app nap for a specific app using terminal.
Thanks
light_user is offline   Reply With Quote