Thread: AU validation
View Single Post
Old 02-26-2017, 03:28 PM   #18
Youlean
Human being with feelings
 
Youlean's Avatar
 
Join Date: May 2015
Location: Serbia
Posts: 652
Default

Quote:
Originally Posted by Tunca View Post
By the way if i build my plugins with 10.5 SDK,will VST and AAX be fine?Any difference?
I am not sure about AAX, but VST2 will be fine, though I think VST3 needs c++11 so you will need to use at least 10.7 SDK with 10.7 minimum version.

To sum this up, use 10.7 SDK with minimum OS version set to 10.7 and enable c++11 (to save your life) by changing CLANG_CXX_LANGUAGE_STANDARD = c++0x to CLANG_CXX_LANGUAGE_STANDARD = c++11.

If you want to use 10.12 to target 10.7 (save yourself a pain and don't go below that) you will probably need to edit LICE project and VST3 project if you get warning that are telling you that you might have linker problems. Anyways look projects at my branch in VST3_SDK and WDL\lice

https://github.com/Youlean/WDL-Youlean
Youlean is offline   Reply With Quote