Thread: AU validation
View Single Post
Old 02-26-2017, 08:00 AM   #5
Human being with feelings
Join Date: Apr 2016
Posts: 233

Originally Posted by JD Young View Post
Hi Tunca,

Iím by no means an expert on this, but I have had similar issues in the past caused by the following reasons:

- AU not validated when I had two GUI controls linked to the same parameter. I had to explicitly call Ďfalseí as in SetDirty(false), in one of the GUI elements, instead of just SetDirty(), which has Ďtrueí as default argument. (The AU plug-in worked fine initially in Reaper, but not in Logic. It didnít validate though, because of some seemingly unrelated parameter inconsistency. It did successfully validate after my fix)

- I had some bundle ID issues, when the IDís didnít match in recource.h and the plist files.

- If you get inconsistent results over different systems, itís possible your AU got blacklisted by the host after giving an error during load. (It could be another problem in combination with this as well.) Itís usually not very difficult to find the actual Ďblacklistí in a host.

Not sure if this is any help, but it might give you some clues...

Cheers! JD
Thanks for reply!

My plugins have no linked parameter or GUI.I saw this issue in forum and tried but still same.

I checked resource.h and info.plist but there is no difference.

I have trouble with Logic.Reaper can see AUs but no luck with Logic.Other people see some of them with different systems...

Almost i tried everything but...
Tunca is online now   Reply With Quote