View Single Post
Old 09-07-2017, 12:04 PM   #404
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,657
Default

Currently only an operating system requirement can be specified (per individual file). Scripts can manually test for REAPER/SWS compatibility by checking at runtime whether a particular API function exists or by testing the version with the new reaper.ReaPack_CompareVersions API (v1.2beta2+).

I think I could add this @requires feature in ReaPack v1.3. ReaPack currently handles incompatible packages by hiding them away. I think it would be better to show them but with a clear error message upon installation attempt. They would need NOT to be installed when synchronizing with the option to install everything is ON though, because that would be annoying (getting errors every time...).
cfillion is offline   Reply With Quote