View Single Post
Old 09-25-2018, 04:29 PM   #25
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 758
Default

Quote:
Originally Posted by Dehenry View Post
Klar, aber es ist schon super, wenn man nicht nur 8 Fader, sondern zusätzlich 8 Encoder hat, um neben Amp- und Filterhüllkurve auch Cutoff u.a. gleichzeitig im Griff zu haben.

Hast Du eine Erklärung dafür, warum sich ein und derselbe Plugin-Parameter mal steuern lässt und mal nicht, je nachdem, wie langsam oder schnell man beim Anlernen durch den Wertebereich gefahren ist? Wenn ich es richtig verstehe, senden die Encoder ja immer nur +1 / -1 und keine absoluten Werte. Dann müsste es dem Plugin doch eigentlich egal sein, wie grob oder fein die Parameterwerte abgestuft sind, die in der Map abgespeichert sind, solange es gültige Werte sind? Das müssten sie aber eigentlich in jedem Fall sein, denn die Werte sendet das Plugin beim Anlernen ja selbst.
Nee, hab keine Ahnung was da passiert. Auch wenn es von mir nicht so gedacht ist, sollte dieser "Workaround" von Dir eigentlich schon funktionieren.

Quote:
Originally Posted by Dehenry View Post
Heißt das, dass sogar das Blinken vom Protokoll gesteuert wird, also nicht nur einmal der Zustand "blinkend" gesetzt wird und der Controller steuert dann das Blinken, sondern jedes einzelne Ein- und Ausschalten der LED wird über das Protokoll gesteuert?
Doch, doch, blinken als Zustand kann ich setzen, und halt noch an und aus, aber halt kein halbhell oder so.



Quote:
Originally Posted by Dehenry View Post
Die Displays zeigten nur den waagerechten Strich, die LCD-Anzeige blieb dunkel und die X-Touch reagierte auf nichts. Das ist mehrfach passiert. Heute ging es aber auf einmal, d.h. erst X-Touch einschalten und dann Reaper starten geht, ebenso umgekehrt: Reaper läuft bereits, dann X-Touch einschalten.

Was nicht geht: X-Touch im laufenden Betrieb mit Reaper aus- und wieder anschalten oder USB-Kabel abziehen und wieder anstecken. Dann wird die X-Touch nur über den Edit-Button in den Control/OSC/Web-Optionen wieder erkannt wie oben beschrieben.
Ja, das stimmt, die Erweiterung geht davon aus, dass der Controller angeschaltet ist, und ist nicht Hot-Plugable. Bin mir garnicht sicher, ob das überhaupt geht, wie sieht das denn bei anderen DAWs aus?
Klinke is offline   Reply With Quote